second USB controller not working in emulator



  • Hi, After reading many topics regarding how to configure 2 gamepad in the forum, I feel the need to post my own issue here.

    • I got latest recalbox version (17.12.02), I'm using raspberry 3 model b.

    • I'm using 2 arcade joystick from Quimat, using 2 USB controller, with same configuration

    The 2 gamepads are working like a charm in recalbox, but not inside the emulator (neogeo, megadrive, MAME, tested many of them), the buttons in the second player are broken. (but up/down/left/down work), but not (x/y/a/b)

    I've followed this link:
    https://forum.recalbox.com/topic/4630/mapped-2p-buttons-don-t-behave-correctly

    It seems a problem with the USB port, and it proposes adding a custom property in cmdline.txt usbhid.quirks=xxxxx

    This is my lsusb output:

    lsusb

    Bus 001 Device 005: ID 0079:0006
    Bus 001 Device 004: ID 0079:0006

    Bus 001 Device 003: ID 0424:ec00
    Bus 001 Device 002: ID 0424:9514
    Bus 001 Device 001: ID 1d6b:0002

    Does it help? Device 004 and Device005 got the same ID.

    Anyway, I tried to modify the cmdline.txt and configure again the 2 gamepads, but the problem is still there (Probably I'm not doing it correctly )

    I' got the recalbox-support logs, I'll try to attach in the post.
    http://www119.zippyshare.com/v/ylh7egwV/file.html

    it would be nice to know what else can I do to test my 2 gamepads working in the raspberry using latest version of recalbox.

    (I reproduced the same issue in retropie)

    Any help would be very very welcomed.



Want to support us ?

259
Online

81.4k
Users

22.2k
Topics

161.3k
Posts