Recalbox 7.0

Randomly no sound in emulators only when I restart system



  • Hi,

    System : Intel NUC, video and sound through HDMI

    Randomly when I use the restart system command, I get no sound only in emulators, here's the detailed explaination :

    • Sound OK 100% of time on the ES menu (backgound sound always works, so it is not a hardware or configuration problem, by the way I set the sound output on "HDMI 3" on ES, which works fine).

    • Sound OK 100% of time apparently too within emulators too.

    BUT :

    • When I restart, sometimes (most of the time) I still get sound on ES (100% of the time as I said before), but not on any emulators EXCEPT for the Dreamcast one. I have no clue why.

    • Temporary fix ? It does come back after I restart many many times or when I turn off AND unplug the NUC, not sure why nor if it's because of that or just a coincidence and it's totally random since unplugging makes no sense to me for that kind of problem, so the fix' are probably random working restarts.

    • Still get sound on KODI 100% of the time too, but going back to ES and retrying an emulator doesnt change anything, no sound.

    Feel free to ask me any question, or even to try out any things you can think of, also I read somewhere that you can specify a line of code at some point to force refreshing the sound output on HDMI after every boot but i'm not sure it can help since I always hear the ES music / KODI sound anyway. Problem is really just for emulators except for the dreamcast one, and only when I restarts, and not even every time, seems really random but still very often.

    Thanks for your help!



  • Little update, since this is apparently a problem on the Retroarch side, I've tried to get some details about the audio output within the retroarch menu but at this point I have no idea of what else to try.

    Thanks!



  • News :

    I have tested to analyse the audio signal from my amp :

    On the first boot it says "Signal PCM" on both ES and Retroarch running a game, I can hear the sound OK for both.

    After 1 or some reboot (randomly), still says PCM on ES, but says "Unknown" signal on retroarch running a game :

    Screenshots :
    https://imgur.com/a/Hd6cY



Want to support us ?

133
Online

79.1k
Users

20.4k
Topics

149.2k
Posts