Black screens in MAME since last update



  • I have done the last update and since then every time I play a game with MAME, at some point I will just get a black screen.

    The MAME menu can still be brought up and is functional, so the system is not crashed. I can quit MAME and go back to the main menu as well without problem.

    I have tried a variety of games and they all do the same within 1-2 minutes.

    No other emulator seems to be affected.

    Has anyone else experienced something similar?



  • After some research, I found that it is related to the input system: if I leave the games in attract mode, no crash. If I play, it will crash.

    I did fiddle with the gamepad settings, but that still indicates a problem. I'll try to pinpoint what I changed.



  • I have the same problem. no games are working after update. any solution to this problem?



  • @iggy2 The games run in my case, they just all crash



  • I have found the problem, but I don't know what causes it:

    I can run any MAME game, but using the gamepad will crash the emulator.

    If I run the game in attract mode and don't touch the gamepad, it will run fine.
    If I press buttons on the gamepad, the emulator will crash to a black screen.
    This is happening on every title, so there is a problem with the handling of the controller.

    Other emulators are not affected, it is specific to MAME.

    I tried to do button remapping and that was the only controller change I did.



  • I ended up doing a re-install; but there is clearly a bug somewhere linked to controller settings and mame. I wish I had been able to isolate the issue.



Want to support us ?

Join us on :

376
Online

26879
Users

13855
Topics

105387
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.