Recalbox 7.0

Blackscreen NeoGeo



  • Hi, i just set up recalbox and tried different emulation - everything is working fine, except for NeoGeo emulation. When i start a rom i get a blackscreen. Am i missing something. Do i have to add a bios somewhere? Help would be appreciated! Thx in advance. Buddy



  • Hi, do you mean fba fba_libretro and mame are working fine? You must have the bios file neogeo.zip in /recalbox/share/roms/neogeo folder. The link mentionned in /recalbox/share/roms/neogeo/_readme.txt works fine for me. If you have trouble getting the proper bios version you should take a moment and log in to IRC => http://blog.recalbox.com/forums/topic/irc-channel/ You have also this documentation for the other bios => https://github.com/digitalLumberjack/recalbox-os/wiki/Add-system-bios-(EN)



  • In recalbox, "neogeo" is just a separated system here if gamers want to separate arcades's games and neogeo's games. So it don't use a defined emulator as the others systems. It is to you to choose what arcade emulator (fba (pifba), fba_libretro, mame (imame4all), you want to use. So you must define which emulator you want to use to emulate neogeo. Go in the recalbox.conf file and edit it : for pifba (fba) : neogeo.emulator=fba2x for fba_libretro :

    neogeo.emulator=libretro
    neogeo.core=fba
    

    for mame (imame4all) :

    neogeo.emulator=libretro
    neogeo.core=imame4all
    

    Once the neogeo roms from your full arcade romset and the neogeo.zip associated to the emulator, added, you should be able to play.



  • Thx guys! That did the trick. It's working now with pifba. But then i already have the next question. Some of the upper and lower part of the screen is missing. Is this something i can also fix in the recalbox.conf? I have the same issue with MasterSystem Emulation - i can fix that, when i set a custom screen ratio in retroarch, but for some reason the config can't be saved. When i start a new rom, it's the wrong aspect ratio again. I must say i am really amazed with recalbox - it is so straight forward to set up. I was at a friends house on the weekend for some multiplayer fun and now i have to build two more stations for my friends. 😛 Kudos to the guy who did this!



  • Hum the best way, is to configure your TV to have a fullscreen image. Plug your recalbox on the HDMI port with (DVI) written next to. You should have too option to activate in your TV menu. Otherwise you can activate "overscan" option in emulationstation. You can precisely adjust it by editing config.txt file. Give a look on our wiki for more informations : https://github.com/digitalLumberjack/recalbox-os/wiki/Overscan-settings-(EN) https://github.com/digitalLumberjack/recalbox-os/wiki/Mini-How-To-(EN)



  • I think over/underscan only helps, if you have this kind of problem with emulationstation in general. The emulationstation-frontend, SNES, MegaDrive, PSX etc. fit the screen perfectly. I only have this issue with MasterSystem and NeoGeo. With MasterSystem i can fix this with Retroarch settings. It is a bit annoying to set this up, whenever i start a game, but it is not much of a big deal. With NeoGeo i really don't know how to fix it, as it doesn't uses Retroarch. I'll try to figure things out. I´m really new to this - i only knew emulators from Windows, where you can set your native screen resolutions directly in the emulators. This is how it looks on my screen atm. If anyone have a sollution for this, let me know.



  • Humm by default, the core used to emulate mastersystem is picodrive. You can try to switch to Genesis Plus GX by editing your recalbox.conf file. So you have to add this line : mastersystem.core=genesisplusgx And about the NeoGeo, you can try to switch to the FBA Libretro core.

    neogeo.emulator=libretro
    neogeo.core=fba


  • i figured it out. standard video mode in recalbox.conf is global.videomode=CEA 4 HDMI i edited it to global.videomode=CEA 5 HDMI. 1080i instead of 720p. now it fits perfectly. 🙂



  • Hi, I have a very stange problem with neogeo roms, well I have a romset with neogeo roms working well in the folder fbalibretro, but I would have the neogeo roms on the folder neogeo, I copy from fbalibretro to neogeo some roms(mslug1,2,3,4,5 and x) and the neogeo.zip.   When I reboot the raspberry pi 2 with the newest version of recalbox, on neogeo section only have a very nice black screen after execute a rom, after that I change de recalbox.conf file to change the default neogeo emulator   I change an put

    ## NeoGeo emulator
    ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=libretro
    ## If you set libretro as neogeo.emulator, uncomment the line below and set the retroarch core (fba,imame4all)
    neogeo.core=fba
    

    and still black screen and back to menu after

    ## NeoGeo emulator
    ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=libretro
    ## If you set libretro as neogeo.emulator, uncomment the line below and set the retroarch core (fba,imame4all)
    neogeo.core=imame4all
    

    and black screen again

    ## NeoGeo emulator
    ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=fba2x
    ## If you set libretro as neogeo.emulator, uncomment the line below and set the retroarch core (fba,imame4all)
    ;neogeo.core=fba
    

    and still black screen, What´s the problem, because with fbalibretro folder works well? P.D. i try to change the neogeo.zip bios and don´t work and i try to download from de _reademe.txt but whe i try to read the file I delete by error   Sorry for my english, i have a limited english lessons   THANKS


  • Developer
    Global moderator
    Team

    @Sebastian you may experience some framerate slowdown at this resolution. Maybe the best solution is to set 720p in the config.txt, and let the default video mode so you are always in 720p



  • I have the same problem.. the black screen i think the problem is the file neogeo.zip i try to put in the bios folder and in the roms folder, but wont work   any idea ??   Thank you for help !!



  • Can someone upload the _readme.txt from the neogeo directory, thanks



  • i found the solution .. and i share in a mini how-to.. http://blog.recalbox.com/forums/topic/neogeo-how-to-guide/



  • Hi, I have a very stange problem with neogeo roms, well I have a romset with neogeo roms working well in the folder fbalibretro, but I would have the neogeo roms on the folder neogeo, I copy from fbalibretro to neogeo some roms(mslug1,2,3,4,5 and x) and the neogeo.zip. When I reboot the raspberry pi 2 with the newest version of recalbox, on neogeo section only have a very nice black screen after execute a rom, after that I change de recalbox.conf file to change the default neogeo emulator

    @jose-luis-de-dios-callejas : Which text editor are you using to edit your recalbox.conf file ? If you are under windows, we recommend to use notepad++. The other text editors, included out the box with windows, will break recalbox.conf. You can also use nano with a root acces. nano /recalbox/share/system/recalbox.conf



  • @rockaddicted I use the notepad++ or nano with putty and root acces and my result it´s the same with 3 diferent bios on the neogeo folder and another roms, y only have black screen and return to  menu, it´s posible I enconutred a bug? My raspberry pi 2 have in fbalibretro the romset  FBA 0.2.97.30 which is based on MAME 0.154 (Jul 2014) and in this emulator works well with neogeo roms, but if I copy the neogeo.zip and some neogeo roms to neogeo folders, reboot and a  black screen, I edited the recalboxconf with this option again ## NeoGeo emulator ## You can use pifba or a libretro core (fba2x,libretro) neogeo.emulator=libretro ## If you set libretro as neogeo.emulator, uncomment the line below and set the retroarch core (fba,imame4all) neogeo.core=fba reboot and again the neogeo black screen, I think that tihs configuratión it´s the same for the fbalibretro folder no? I don´t know what can I do to use the neogeoroms on his folder



  • Ok so, in recalbox, neogeo is not really a stand alone system. It is only a separated system to split classic arcade games and neogeo games. You can assign one arcade emulator of recalbox to this system using the switch included in recalbox.conf file. So indeed, it you want to use, FBA-Libretro as neogeo emulator, your need to configure recalbox.conf like this :

    ## NeoGeo emulator ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=libretro
    
    ## If you set libretro as neogeo.emulator, uncomment the line below and set the retroarch core (fba,imame4all)
    neogeo.core=fba
    

    Now you need to take neoge'so roms + neogeo.zip bios from your FBA-Libretro romset (FBA 0.2.97.30 which is based on MAME 0.154) and past them in neogeo rom folder. Then after a reboot that should be ok. It is very important to use good roms versions associated to the emulator used.



  • @rockaddicted, I try this option, copy neogeo.zip ans 6 roms of neogeo from fbalibretro folder to neogeo folder, edited the recalbox.cfg file and restart from recalbos menu. But the neogeo roms from neogeo folder don´t work, from fbalibretro works well. I attached the recalbox.cfg from /recalbox/share/system.(i change the extension fot attached) There is anytihing worng?



  • The only thing I saw, is a tabulation character after libretro to remove :

    ## NeoGeo emulator 
    ## You can use pifba or a libretro core (fba2x,libretro)
    neogeo.emulator=libretro


  • @rockaddicted thanks a lot, the problem was the tabulation, now it works



  • Nice, be careful the next time you edit the recalbox.conf file 😉



Want to support us ?

134
Online

79.1k
Users

20.4k
Topics

149.2k
Posts