Recalbox 7.0

Mapping problems w/ xbox 1 and logitech f310



  • I just got a recalbox and it came with usb snes controlers. They Work fine. But when I try to use my xbox one usb or the logitech f310 usb I can go through the configure controller and each key maps as I press them. but in NES games (only ones I really tested) the Start is now the left joystick button, the Select/hotkey ends up being the logitech logo button. Also the a, b buttons end up being x and b (same with the xbox one controler but the xbox logo button being the select/hotkey) I have tried to reconfigure several times. Still same result. Even tried to map it all over the place. IN the menu the new mapping works in game it goes back to what I posted above.

    I have tried reading through a lot of posts. I can't seem to find this problem anywhere. I am completely new at these emulators and not sure where to go.

    Also while trying to get NES advantage controller (with usb adapter) keys again will map but not work in game. ( start/select wont work even though they map fine.)



  • @samhainnc Hi
    first of all, you should supply your Recalbox version, this is very important. Second : i did the mapping of the F310 in both X-input and irect Input mode and had no big problems with it. And tbh, the Direct Input method works better. So I suggest you turn around your pad, and move the switch to D and try again.



  • @Substring Thank you for your reply.

    I tried D mode. I got no response from any button. Unable to map it at all. The version I have I believe that I found in System Settings is: 4.0.0-build-53 2016/04/19 12:36 Emulationstation v2.0.1a I did check in SNES and no mater how I map the buttons it always reverts in game to "Start is now the left joystick button, the Select/hotkey ends up being the logitech logo button. Also the a, b buttons end up being x and b " I do have an old Logitech duel that seems to be fine just the like usb snes that came with it.



  • @samhainnc Holy $h!T this version is way too old dude ! You'd better start with a complete new install !



  • @substring I wouldn't even know where to begin with that. I guess I will check with the guy I bought it from and see if he didn't know that unit had an old version and maybe get him to fix it.



  • @samhainnc let me give you some advice : Recalbox IS freaking FREE you should never have bought it ! 4.0.0 can't be upgraded to the current version



  • @Substring I was lazy. I been using emulators for a while on pc/laptops/tablets but I like being able to hook up to the tv without a ton of crap to do it with those and I got the hardware, software,games etc for a good price including getting it set up. Im sure as I mess around with this one I will learn how to build and work on my own from now on. But had to start somewhere. I never heard of recalbox. Now I should be able to flash the new version and install it? If not well lesson learned and I will build one fresh myself. I have started watching/reading about fresh installs. Also collected a couple controllers I like that works with this one for now.



  • @samhainnc make it easy : find an empty SD, burn recalbox in it



  • @substring Well I took your advice and got a new SD card. I used Paragon to pull all the roms off the old sd. (because of linux I couldn't see the partitions with windows that held them) Did the flash of the newest recalbox and every controller works as mapped that I try. In the process of doing this I now know exactly how to build and work on my own. Thank you again for the help.



Want to support us ?

146
Online

79.1k
Users

20.3k
Topics

149.0k
Posts