Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Plus de son après la derniere mise a jour 17.11.10.2



  • Bonjour
    Je viens de faire la mise a jour de recalbox version PC en 17.11.10.2 et au redémarrage je n'est plus de son. Je n'est pas toucher a mon installation. J'ai vérifier dans le menu son le volume était a 0 donc je le remonte a 100 mais toujours pas de son. Je test toutes les options de sortie audio toujours rien ( je suis en jack sur un moniteur) et plus etrange quand je redémarre la recalbox le son se remet a 0 dans le menu son. pourriez-vous m'aider s'il vous plait ?
    Merci d'avance de vos réponses.



  • @sébastien-avril Essaie de réassigner un autre périphérique son. Pour le volume, ca oui on sait



  • Bonjour
    et merci pour cette idée je n'y avait pas pensé. J'ai branché une vieille carte son en PCI sur ma carte mère et ça marche impeccable. Merci encore de cette réponse aussi rapide



  • @sébastien-avril said in Plus de son après la derniere mise a jour 17.11.10.2:
    @substring

    Bonjour
    et merci pour cette idée je n'y avait pas pensé. J'ai branché une vieille carte son en PCI sur ma carte mère et ça marche impeccable. Merci encore de cette réponse aussi rapide



  • Hello !

    J'ai le même soucis, par contre c'est un Intel Nuc, je ne peux pas brancher un autre périphérique.

    J'ai déjà réassigné un autre périphérique son, et forcé la sortie jack et toujours rien, une idée ?



  • Je viens de voir ça dans les logs :

    [ 9.22] amixer: Control default element write error: Operation not permitted
    [ 9.23] Setting volume for numid=10
    [ 9.43] Restoring ALSA mixers configuration
    [ 9.51] setting audio to jack
    [ 9.52] ---- recalbox-config.sh ----
    [ 9.54] Uknown audio format : jack



  • Même problème suite mise à jours avec le PC décrit dans ma signature, donc déjà avec une carte son PCI.
    Lien support: https://file.ac/ClvxtbNaYwI/

    [18.85] Setting volume for numid=9
    [18.86] amixer: Control default element write error: Operation not permitted
    [18.86] Setting volume for numid=8
    [18.86] 
    [18.86] amixer: Control default element write error: Operation not permitted
    [18.86] Setting volume for numid=6
    [18.86] 
    [18.86] amixer: Control default element write error: Operation not permitted
    [18.86] Setting volume for numid=5
    [18.86] 
    [18.87] Restoring ALSA mixers configuration
    [19.14] setting audio to auto
    [19.15] ---- recalbox-config.sh ----
    [19.15] Uknown audio format : auto
    

    J'ai testé en sélectionnant d'autre périphérique son mais aucune différence.



  • J'ai trouvé ! Alors pour ceux qui auraient le même problème. Cela vient du volume du master qui reste bloqué à zéro. Pour le débloquer :

    Se connecter en SSH (voir doc recalbox) et saisir :

    amixer -c 0 contents | grep "Master Playback Switch"
    

    Noter le numid et taper (changer le numid si nécessaire) :

    amixer -c 0 cset numid=2 on,on
    


  • @sebastien-heyd

    # amixer -c 0 contents | grep "Master Playback Switch"
    numid=2,iface=MIXER,name='Master Playback Switch'
    # amixer -c 0 cset numid=2 on,on
    numid=2,iface=MIXER,name='Master Playback Switch'
      ; type=BOOLEAN,access=rw------,values=1
      : values=on
    

    Bien joué ! J'ai à nouveau du son.
    J'imagine qu'il va y avoir un hotfix sur la dernière MaJ du coup.

    On dirait que le script du démarrage n'a pas l'accès pour modifier la valeur, bien sur en "root" pas de soucis.



  • La ruse est bien plus sioux que ca ... Certains n'ont pas de master en volume par exemple (et ouais ...).

    Je crains que le bug ne se reproduise à chaque maj à cause d'un séquencement d'opérations qu'on ne peut pas maitriser pour le moment ... a voir



  • Bonjour,
    J'ai le même problème, je suis sur PC x64 et à chaque mise à jour je n'ai plus de son du tout.
    Je ne connais rien au ssh.
    Quelqu'un pourrait me dire dans quel fichier se trouve la valeur à modifier ?

    Lors de l'avant dernière mise à jour j'ai résolu le problème en supprimant le dossier "system" de "recalbox" (mes data sont sur un autre disque dur local, j'y accède via Windows car mon PC Recalbox est en multiboot), au reboot Recalbox a recréé un dossier "system" tout neuf et le son fonctionnait à nouveau. Le problème avec cette manip c'est que je perds toute ma configuration.

    Merci.

    Edit : c'est bon, un pote m'a aidé pour le ssh, ça fonctionne.



  • Bonjour tous le monde,

    Depuis la mise a jour 18,03,30 j'ai plus de son (recalbox sur pc)

    j'ai regarder et essayer le ssh mais n'y comprend rien quelqu'un peut m'aider svp?

    je vous remercie d'avance



  • @bheuair une recherche, et tu auras des réponses. Le sujet est abordé au moins 1 fois par semaine ...



  • @substring merci je vais encore regarder mais suis totalement novice avec le ssh j'ai meme regarder sur youtube pour voir si il y avait pas la video mais pas trouver mais j'ai bien regarder la video sur le ssh et au moins j'ai le programme putty



  • @Substring merci j'ai enfin trouvé faut juste appuyer sur la touche "M" sur master

    Pour les autres ouvrir le programme PuTTY se connecter a Recalbox
    entrer TERM=xterm alsamixer enter puis sur Master appuyer sur la touche M et normalement le son revient direct



  • @bheuair mmhhhh ... A chaque fois queje lis ca je ne comprends pas pk master est muté ... il va falloir que je reregarde ca en plus du bug de reglages son perdus lors d'un emaj



  • @substring Ben maintenant que je le sais, la manip n'est pas trop compliqué pour rétablir le son donc ca va encore, c'est vrai que now quand tu es novice c'est en peut chiant mais bon il y a plus hard que juste la perte de son



  • Juste un truc de chiant a chaque fois que je redemarre ma recalbox je dois le refaire (la manipulation) ou alors je n'ai pas sauvegardé mais je regarde mais je vois pas sauvé


  • Banned

    @Substring
    Plus de son non-plus après l'Update du 30. Mais pire TERM=xterm alsamixer ne fonctionne plus. cannot open mixer ?



  • @dragu Quelle arch ? rien n'a été touché de ce côté


Log in to reply
 

Want to support us ?

164
Online

58568
Users

18400
Topics

138477
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.