Problème HDMI DVI



  • Bonjour à tous

    J'ai lu a peu près tout les posts concernant le sujet, les tutos etc.... C'est surement un problème de config. et je ne sais pas quoi modifier ou du moins comment est ou et ce n'est pas faute d'avoir essayé, j'ai installe putty, winscp, notepad plus etc...
    Je ne dois pas être très loin mais je bloque. J'arrive a entrer dans le fichier config avec winscp . Ajouter un # de HDMI_DRIVE=2 ok mais je ne vois pas cette ligne dans ma config.

    Rapsbery pi3, recalbox 4.1 ecran 19" DVI (adaptateur hdmi DVI amazon)

    Merci

    Vincent



  • Bonsoir Vin Cent,

    Il faut editer le fichier config.txt sur la partition boot.
    Si tu n'a pas la ligne hdmi_drive=2 force le DVI:
    hdmi_drive=1
    Par contre tu n'auras pas le son, on est bien d'accord?



  • ok merci mais je sais pas où le mettre hdmi_drive=1 dans le fichier config, je le mets sans # ?
    Pour le son j ai un ampli.



  • Oui dans le fichier config.txt je le mettrai pas loin de la config video, oui sans le #.



  • J'ai essayé toujours rien, je mets ma config si ça peut aider pour m'aider à résoudre ce problème !0_1509223317812_config recalbox.jpg



  • @Vin-Cent
    C'est le mauvais fichier, tu as modifié recalbox.conf, c'est config.txt qu'il faut modifier. Vaut mieux enlever ce que t'as mis au niveau de recalbox.conf.
    Dans config.txt

    un # devant
    # comment to get jack audio
    #hdmi_drive=2
    et un # devant
    # force hdmi while the tv can take time before sending the signal on the hdmi output
    #hdmi_force_hotplug=1
    


  • Ok rectifié. C'est dire si je suis doué ....... ;) Mais je progresse et pense être sur la voie. Je crois avoir trouvé le config.txt avec putty et cette commande nano /boot/config.txt
    0_1509226458756_config txt.jpg
    j'arrive a mettre # devant hdmi_drive=2 mais comment enregistrer cette modif ?



  • @Vin-Cent
    Avant de pouvoir écrire cet fichier tu dois te donner les droits.
    Alors avant nano config.txt, il faut faire la commande
    mount -o remount, rw /boot (-o(ctave) espace entre virgule et rw)
    après nano config.txt ---> modifications ---> Ctrl+X ---> Yes
    Pour contrôler le contenu après
    cat config.txt



  • Merci Dragu pour ton aide ça m'aide beaucoup. Pour le coup entre mon dernier post et le tien j'ai fait cette commande
    je vais ré-essayer avec ce tu viens de me dire .

    Je viens de faire un test je modifie en descendant le curseur j'ajoute le # ctrl+X y=yes et j'arrive à ça sans pouvoir sortir "Get help" et "Cancel"
    0_1509273289626_Sans titre.jpg



  • @Vin-Cent
    Pour sortir, il faut d'abord confirmer file name to write : /boot/config.txt avec enter
    Mais, je vois des drôles de choses. Tu ne dois rien ajouter et surtout pas éditer dans windows, ce qu'il me semble en bas.
    Tu n'as pas de config.txt propre ? Parceque tu as hdmi_force_hotplug 2 fois, il faut juste mettre un # devant les lignes que j'ai montré avant.

    Sinon on va faire la chose suivante, je te donne une version corrigée. Tu compare avec la tienne.

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    disable_overscan=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    
    # comment to get jack audio
    #hdmi_drive=2
    
    # Using /etc/modules is deprecated and no longer supported on 4.4 kernel
    # So manually enable audio
    dtparam=audio=on
    
    config_hdmi_boost=0
    
    # force hdmi while the tv can take time before sending the signal on the hdmi output
    #hdmi_force_hotplug=1
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    # uncomment for lirc-rpi
    #dtoverlay=lirc-rpi
    
    # if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it
    boot_delay=3
    
    # uncomment if you don't want the rainbow at startup
    disable_splash=1
    
    # Overclock
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512
    
    avoid_safe_mode=1
    
    kernel=zImage
    


  • Ok merci, je suis sorti, je regarde ça en rentrant.



  • C'est bon ça marche !!!! J'ai de l'image pour le son j'espère ne pas avoir de soucis mais maintenant je saurais a qui demander ;)
    Un GROS MERCI pour ton aide et ta patience Dragu !!!!

    0_1509295583445_20171029_173804.jpg


Log in to reply
 

Want to support us ?

Join us on :

227
Online

25488
Users

13351
Topics

101185
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.