I am on 6.1-dragonblaze and I definitely need to tell the emulator the cartridge type. Since it was an auto-update, is it possible some elements didn't get updated? I don't know how it behaved before, it's the first time I put the 5200 roms.