@djpcpower

Any idea where the problem comes from?

Probably from video mode, if not I have no idea what it might be, you need to test all the possibilities of video mode before you can guarantee that it isn't.

Is recolbox-user-config.txt the correct configuration file?

Yes it's one of the options, as long as you've edited it correctly it should work, how exactly did you edit it?
what settings have you edited/added? It's hard for me to give an opinion without knowing what you've done. It's a common mistake for users not to remove the # sign in front of lines (if it doesn't, it doesn't work), or edit with the wrong parameter, or not restart and think the change is immediate, for example...

But if you edit the videomode in recalbox.conf, it usually solves the problem, have you checked that?