@Retrogamer63 said in PowKiddy x18: powkiddy x18 it's not compatible.