N64 retro controller issues



  • Hello everybody,

    I have installed Realbox 4.1.0 on a raspberry pi 3 and everything runs as it should. The only thing is, that i cannot get a N64 retro controller to work properly. I have tried a lot of adaptions in the InputAutoCfg.ini file in /mupen64 according to the threads I found online but none of them worked. Everytime I start Super Mario64 on the emunlation the file is resetted to its original content. When I add the line "n64.configfile=dummy" in recalbox.conf it as shown in the tutorials the situation is getting even worse. With this line the y-axis of the controller does not work anymore.

    Is there any solution to get a this controller to work? I have bought those:
    click

    Thanks a lot in advance.

    Best wishes,
    Julian



  • I have found the solution by myself.

    Thank you anyway.



  • @jlorenz89 said in N64 retro controller issues:

    I have found the solution by myself.

    Thank you anyway.

    Can you tell us the solution? thanks



  • Can you tell us the solution please? I'm facing a similar issue



  • Same problem!

    In my case it happens with retrolink N64 controller since the beginning with 4.1.
    I added the ImputAutocfg.ini file as I had it working propperly in the 4.0.2 version and it doesn't help. In fact, it should help PS3 controller work and it doesn't neither. This is the content of the file as I have it:

    [Generic USB Joystick ]
    plugged = True
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = axis(5+)
    DPad L = axis(5-)
    DPad D = axis(6+)
    DPad U = axis(6-)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(8)
    A Button = button(6)
    C Button R = button(1)
    C Button L = button(3)
    C Button D = button(2)
    C Button U = button(0)
    R Trig = button(5)
    L Trig = button(4)
    Mempak switch = key(109)
    Rumblepak switch = key(114)
    Y Axis = axis(1-,1+)
    X Axis = axis(0-,0+)

    [Sony PLAYSTATION(R)3 Controller]
    plugged = True
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = button(5)
    DPad L = button(7)
    DPad D = button(6)
    DPad U = button(4)
    Start = button(3)
    Z Trig = button(10)
    B Button = button(15)
    A Button = button(14)
    C Button R = axis(2+)
    C Button L = axis(2-)
    C Button D = axis(3+)
    C Button U = axis(3-)
    R Trig = button(11)
    L Trig = button(8)
    Mempak switch =
    Rumblepak switch =
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

    Is any of this wrong? Does anybody know where could be the problem?


Log in to reply
 

Want to support us ?

Join us on :

609
Online

28074
Users

14385
Topics

108946
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.