Problema en 4.1 con mando retrolink de N64



  • Hola!

    Tengo un problema con mi mando de retrobit de Nintendo 64 tras la actualización a Recalbox 4.1 estable.

    Le meto el archivo InputAutoCfg.ini que tenía antes, con el que el mando me funcionaba perfecto, y ahora, cuando ejecuto juegos, los controles no funcionan bien. En el Super Mario 64, por ejemplo, el stick me permite girar a Mario a izquierda y derecha, pero no hacia adelante y hacia atrás.

    La configuración de InputAutoCfg.ini es la siguiente:

    [Generic USB Joystick ]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(8)
    A Button = button(6)
    C Button R = button(1)
    C Button L = button(3)
    C Button D = button(2)
    C Button U = button(0)
    R Trig = button(5)
    L Trig = button(4)
    Mempak switch =
    Rumblepak switch =
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)



  • Nadie sabe cómo arreglar esto?

    Y, mientras tanto, alguien a quien le funcione el mando de PS3 (a mí ni me responde en la N64) podría decirme cómo aparece su archivo InputAutoCfd.ini ?

    Saludos y gracias!



  • Una pregunta, de igual forma te pasa si dejas el archivo original? es decir, antes de copiar el tuyo personalizado te pasaba esto que dices?

    Quizá este tema te pueda ayudar:

    https://forum.recalbox.com/topic/5123/n64-controller/8



  • Si mal no recuerdo (he hecho tantas cosas al actualizar que no te lo puedo asegurar), creo que cambié el InputAutoCfg.ini precisamente porque el mando no respondía bien. El problema es que ya no tengo el archivo original. Me podrías decir cómo te sale a ti la configuración? Para ver si puedo hacerle algún apaño...

    Gracias por el link, pero esos posts ya los leí hace tiempo y me ayudaron a tener la configuración que antes me funcionaba y ahora no.



  • Comprendo, si te ayuda de algo, te pongo como aparece mi control de Xbox 360:

    *[Microsoft X-Box 360 pad]
    plugged = True
    plugin = 1
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    Mempak switch =
    Rumblepak switch =
    mouse = False
    A Button = button(0)
    B Button = button(1)
    C Button D = axis(3+)
    C Button L = axis(2-)
    C Button R = axis(2+)
    C Button U = axis(3-)
    DPad D = hat(0 Down)
    DPad L = hat(0 Left)
    DPad R = hat(0 Right)
    DPad U = hat(0 Up)
    L Trig = button(4)
    R Trig = button(5)
    Start = button(9)
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)
    Z Trig = button(6)

    Y este es uno genérico que tengo conectado, es marca MegaFire:

    [DragonRise Inc. Generic USB Joystick ]
    plugged = True
    plugin = 3
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    Mempak switch =
    Rumblepak switch =
    mouse = False
    A Button = button(0)
    B Button = button(1)
    C Button D = axis(4+)
    C Button L = axis(1-)
    C Button R = axis(1+)
    C Button U = axis(4-)
    DPad D = hat(0 Down)
    DPad L = hat(0 Left)
    DPad R = hat(0 Right)
    DPad U = hat(0 Up)
    L Trig = button(4)
    R Trig = button(5)
    Start = button(9)
    X Axis = axis(0-,0+)
    Y Axis = axis(3-,3+)
    Z Trig = button(6)*

    Todo esto es en el archivo InputAutoCfg.ini

    Lo siguiente lo tengo en el input.xml

    <inputList>
    <input name="AnalogDeadzone" value="4096,4096" />
    <input name="a" value="C Button R" />
    <input name="b" value="A Button" />
    <input name="x" value="C Button U" />
    <input name="y" value="B Button" />
    <input name="start" value="Start" />
    <input name="select" value="" />
    <input name="pageup" value="L Trig" />
    <input name="pagedown" value="R Trig" />
    <input name="l2" value="Z Trig" />
    <input name="r2" value="" />
    <input name="up" value="DPad U" />
    <input name="down" value="DPad D" />
    <input name="right" value="DPad R" />
    <input name="left" value="DPad L" />
    <input name="joystick1up" value="Y Axis" />
    <input name="joystick1down" value="Y Axis" />
    <input name="joystick1left" value="X Axis" />
    <input name="joystick1right" value="X Axis" />
    <input name="joystick2up" value="C Button U" />
    <input name="joystick2down" value="C Button D" />
    <input name="joystick2left" value="C Button L" />
    <input name="joystick2right" value="C Button R" />
    </inputList>



  • Muchas gracias!



  • Estoy intentando cambiar cosas de la configuración del mando, pero la cosa sigue igual. ¿Alguien me ayuda con el mando de PS3 o con el de retrolink de N64?





  • @jesús-bl Perdona por tardar, Jesús! La verdad es que te agradezco la ayuda, pero me siento super perdido... El tema en todo caso no es ni la configuración del mando ni el bluetooth. El de PS3 de hecho lo tengo asociado por bluetooth y sin problemas para el resto de consolas. Lo que me falla es claramente el mupen64, porque ahí no me va ni el de retrolink ni el de PS3. Por eso me pregunto si el ImputAutocfg.ini está mal, ya sea porque hayan cambiado la configuración de mandos o lo que sea.



Want to support us ?

Join us on :

234
Online

25554
Users

13367
Topics

101282
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.