Joystick arcade USB + Brook Fighting Board PS4



  • Bonjour à tous,

    j'ai modifié un joystick arcade pour installer une carte Fighting Board afin de jouer sur PS4 et sur Recalbox (j'avais vu dans un post que cela fonctionnait). Quand je branche le joystick, il n'est pas détecté tout de suite, il faut bien 2 minutes avant que l'interface réagisse à la manette ou aux boutons. Ensuite, c'est nickel, tout marche bien, mais si je reboote, c'est pareil, il faut attendre.
    Pour info, j'ai réinstallé complètement une 4.0.1 avec mise à jour 4.0.2.

    Dans les fichiers configs de Emustation, je vois bien la présence de cette manette:
    <string name="INPUT P1" value="DEFAULT" />
    <string name="INPUT P1GUID" value="03000000120c0000300e000011010000" />
    <string name="INPUT P1NAME" value="ZEROPLUS P4 Wired Gamepad" />

    ainsi que l'assignation des boutons:
    <inputConfig type="joystick" deviceName="ZEROPLUS P4 Wired Gamepad" deviceGUID="03000000120c0000300e000011010000">
    <input name="a" type="button" id="1" value="1" code="305" />
    <input name="b" type="button" id="2" value="1" code="306" />
    <input name="down" type="hat" id="0" value="4" code="16" />
    <input name="hotkey" type="button" id="12" value="1" code="316" />
    <input name="left" type="hat" id="0" value="8" code="16" />
    <input name="pagedown" type="button" id="9" value="1" code="313" />
    <input name="pageup" type="button" id="4" value="1" code="308" />
    <input name="right" type="hat" id="0" value="2" code="16" />
    <input name="select" type="button" id="8" value="1" code="312" />
    <input name="start" type="button" id="5" value="1" code="309" />
    <input name="up" type="hat" id="0" value="1" code="16" />
    <input name="x" type="button" id="0" value="1" code="304" />
    <input name="y" type="button" id="3" value="1" code="307" />

    Quelqu'un aurait une idée de la raison de ce "retard" de détection?

    Par avance merci!


  • Moderator
    Team

    @sacochito j'ai le pb avec un xarcade qui met 6-8s, mais pas 2 minutes lol

    Clairement non, aucune idée. Même problème sur un PC ?



  • @substring
    J'ai chronométré à nouveau, on est pas loin des 2 minutes. Sur PC et PS4, pas de soucis par contre. Bizarre...


  • Moderator
    Team

    @sacochito si ce n'est pas détecté, c'est une histoire de kernel, donc il faudrait voir ce que dit dmesg



  • @substring
    Pendant les 2 minutes il me répète ça:
    0_1507036672109_df0a8d30-5771-4328-93e2-a15591698c4c-image.png

    et quand ça marche, il me met ça:
    0_1507036714213_1926f6b7-3851-41fa-b58f-4cfb58ba1e27-image.png

    J'ai bien compris le "taking a long time" ;)


  • Moderator
    Team

    @sacochito C'est donc bien un message kernel, ca va être compliqué sans bump du kernel ... A voir si en 4.1 tu auras pareil (une fois qu'elle sera sortie)



  • @substring
    Disons que ça laisse le temps d'aller chercher une bière...

    Comme je veux monter ça sur une borne arcade, je vais peut être essayer de cabler depuis la Fighting Board sur le GPIO, et je me servirais de l'USB pour la PS4. A voir si ça fait pas tout fumer...

    Merci pour ton aide en tout cas!



  • @sacochito

    Salut!
    Tu as toujours un délai de 2 min ? Ou cela c'est arrangé (et si oui comment ^^).
    Car j'hésite à faire la même chose.



Want to support us ?

Join us on :

248
Online

27406
Users

14109
Topics

107061
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.