Bios while using external USB



  • Hi All,

    I'm looking to use an external USB for all my roms, I have sorted out the USB stick and know where to place the ROMS but where im stuck is on the BIOS.

    1)Do I need to just drop the file into the BIOS folder or do I need to create a folder for that BIOS first as some have a number of files like Sega 32x?

    2)Do I need to rename some of my BIOS? as currently I have [BIOS] Atari Lynx (USA, Europe).lnx but some places are saying lynxboot.img?

    Thanks





  • @kaz69

    Hi,

    When you put an formatted usb device on your recalbox, go in system settings and chose this device. Then recalbox reboots and create "share" on your device.
    Put your roms then in "roms folder" and bios in "bios folder".
    1)https://github.com/recalbox/recalbox-os/wiki/Use-an-external-usb-storage-device-on-recalbox-%28EN%29

    2)https://github.com/recalbox/recalbox-os/wiki/Add-system-bios-%28EN%29



  • @substring Hi, yes I went over the guide but I just need a specific answer to the questions which i cant find.

    @abunille thanks, I have downloaded the zip file for the Sega 32 but there are 7 .bin files do i just transfer all of them across in to the BIOS folder?

    regarding naming do i have to rename the file to the one on the list you had on the link?



  • @kaz69

    How is written in the wiki.
    directly /recalbox/share/bios/
    I see only 3 files for that system in wiki.



  • @abunille I think the first file number i search from the list had all the Bios in the list on plus more and that is what got me confused. i'll transfer all and see how it goes.

    thanks



  • @kaz69

    If it works please mark this Topic as solved:

    Press the three vertical squares on the right..
    Topic Tools -> Ask a question + Topic Tools -> Mark as Solved



  • @abunille Thanks I do that



  • So have managed to get a number of BIOS across that work all ok, the one i'm having issues with is the Atari Lynx Bios as I have search for the one recommended in github but the only one that comes up is

    [BIOS] Atari Lynx (USA, Europe)

    I know lynxboot.img is needed so i changed the name but still the roms wont load.

    when I load a game the screen goes black then back to the game selection screen.



  • @kaz69

    Hi,
    have you checked the "md5sum" how is written in the wiki?
    When its not the md5sum you need, you must search further i think.

    And have you checked your rom extension?
    When they are .zip files, look into the .zip, if the file inside is an supported extension.



  • @abunille

    Thanks, let me get on this and see how I go



  • @abunille

    i checked the file extension with the read me file in the Lynx folder and i'm using a .lnx file.

    im checking the md5sum tonight as been having some laptop issues



  • @kaz69 Is your problem with the lynx bios or lynx roms themselves ? The current core doesn't support the no-intro file format



  • checked BIOS on md5sum and it matches the one on github.

    @Substring I'm not sure which as the BIOS number matches up right and the Roms are correct for whats said in the read me file .lnx Whats he no-intro file format?



  • @kaz69 the lynx emulator is quite a pain, it doesn't accept whichever rom ...



  • i downloaded the roms from a trusted site and all their other roms are fine, maybe its just lynx
    ,



  • @kaz69 as I said, the emulator is very picky on roms and doesn't support the widespread rom headers (some crap like that)



  • @substring thanks I guess it's just trying out different games and seeing what works and doesn't.

    Do you know what other emulators are like this so I'm prepared for it 😊



  • @kaz69 well, dunno if you tried arcade yet ...



  • @substring

    Yeah tried arcade and got a few working on FBA libretro that didn't work on MAME but I'm still trying to get the Michael Jackson Arcade game to work.

    Lynx I'm still working on but fingers crossed I'll find something, then I can post my findings here



Want to support us ?

Join us on :

194
Online

29809
Users

14883
Topics

112111
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.