[Résolu] Manette NES



  • Salut, J'aimerai câbler les manettes de ma nes directement sur le GPIO du raspberry mais je ne sais pas trop comment m'y prendre. J'ai juste trouvé ceci:   si j'ai bien comprit sa devrai donner sa:


  • Team

    Tu as tout ce qu'il faut :) connecte les fils qui correspondent sur tes GPIO et active le gamecon gpio dans recalbox.conf. Tu va rencontrer sans doute certains problèmes,  n’hésite pas a demander de l'aide :) Par contre ne branche pas le 5V sur la manette, met du 3V



  • merci Retroboy =) restera plus qu'a tester ;) Tout le câblage est bon a part le 5V a changer avec le 3V ?



  • Salut les gars, je boss également sur l'adaptation des manettes nes d'origine, j'ai pue faire le montage en suivant vos shémas (merci du partage) par contre je suis bloqué sur le recalbox.conf. J'ai tester plusieur parametre mais je n'arrive pas a faire marcher la manette nes, quand j'utilise la commande cat /proc/bus/input/devices dans un terminal la manette est bien reconnu (comme une manette snes cela dit) mais quand je teste avec jstest les bouton ne renvoie aucune info. Avez vous reussi a quelque choses ??



  • J'ai pas encore pu faire de test, je reçoit mes cables pour le gpio dans la semaine =) Sinon je croit que tu doit mettre dans recalbox.conf Enable_gamecon=1



  • oui cela je l'ai bien fait, ca permet la reconnaissance de la manette par l'intermediaire de la commande cat /proc/bus/input/devices sans cela la manette n'apparait pas, par contre j'ai pas plus d'activité sur la manette :(



  • Ta moyen de mettre une photo de ton câblage stp =)



  • essaye avec sa  gamecon_args=map=2



  • j'enverai une tofs mais c'est un peu le bordel dans la "Nesboite" :D pour le map=2 j'en etait arrivé a deduire la meme chose, ce qui du coup m'affiche bien Manette Nes et non plus Snes mais pas de changement je me demande si cela n'est pas du a un probleme d'alimention, j'ai broché le 3,3v mais je crois lire sur certain forum que le 3,3v pause probleme mon anglais etant precaire je n'en sort pas plus d'infos.



  • Au dessus retroboy conseille de brancher sur le 3,3V mais normalement sa change rien



  • Oui justement c'est pour ca que je me suis fixé sur la 3,3 mais apres plusieur recherche je commance a me demander oO



  • essaye plutôt gamecon_args=map=2,2,0,0 j'ai trouvé un lien qui pourrait aidé https://github.com/RetroPie/RetroPie-Setup/blob/master/scriptmodules/supplementary/gamecondriver.sh je regarderait sa de plus près demain ^^



  • Devant les ligne enable_gamecon et gamecon_arg enleve le point virgule C'est peut être juste sa



  • C'est fait, je fait un peu de prog le principe des commentaires ne m'est pas inconnue ;-)



  • je me demande si le probleme vient pas de mon cablage ou la manette, c'est qui est chiant c'est que j'ai pas de quoi tester la manette, pour le cablage j'ai fait ca avec une nappe ide de floppy je pense avoir tout bien raccorder mais j'ai commandé des cables pour le gpio pour fair un truc plus propre, si ta l'occasion de faire fonctionné ca avant moi ou si Retroboy a quelque idée je suis preneur :D Pour le moment tout ce que j'ai reussi c'est faire reconnaitre le "bornier" nes ave cat /proc/bus/input/devices, il m'affiche bien Nes gamepad, mais que la manette soit brancher ou pas ca ne change rien... :(


  • Moderator
    Team

    Bonsoir essaie jstest : https://github.com/digitalLumberjack/recalbox-os/wiki/Tester-votre-joystick-avec-jstest-(FR) edit : tu as bien édité recalbox.conf avec nano via putty ?



  • met nous une photo du câblage pour voir, il y a peut être un truc qui va pas



  • Oui le fichier recalbox.conf et bien édité avec nano, via ssh je referait un test en fin de semaine avec des cables de connection gpio, là la photo ne donnerai rien les câbles étant sur une nappe ide j'ai déjà du mal à les suivres au multimètre alors en photo... :D



  • Bon j'ai reçu mes câbles gpio refait le montage et toujours le même résultat, à savoir que dalle... Je fichier est bien édité, jstet affiche bien "contrôleur Nes 4 boutons", mais aucune interaction de la part de la manette. Je commence à croire que ma manette est foireuse ...   un truc me chiffonne tout de même quand je fait un dmesg, j'ai ce message et je ne comprend pas le partie en gras ? [    3.558006] usbcore: registered new interface driver xpad [    5.328947] input: NES pad as /devices/virtual/input/input1 [    5.335733] GPIO4 configured for NES pad data pin Si je ne m'abuse n'y aurais t'il pas un probleme sur le schéma donner plus haut je me suis basé sur ton schéma Dylan Tretoutmais si je comprend la sortie de Dmesg je devrai connecter le data de la manette 1 sur le "PAD 2" de ton schéma , je testerai en rentrant du tafs ce soir.



  • Problème réglé ça venais bien du schéma le pin pour connecter le "data" des manettes n'est pas le bon. Dylan si tu as l'occasion de le modifier sinon je prendrai 5mn pour en refaire un ;-)


Log in to reply
 

Want to support us ?

Join us on :

303
Online

28985
Users

14707
Topics

111074
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.