Rookie question



  • Hi all.
    First I´d like to thank all of you that has made this great...mod? (what the heck are theese things called)
    Been tweaking and fiddling around for a good few days, when I managed to delete my settings in MAME. so I had to restart from scratch...but that aint the problem ;)
    I have SNES controllers, everything is perfect, beside that pesky little error (in my opinion) that A and B are wrong in NES, but correct for the SNES ( and more or less everything else)
    Did the settings as I want it;
    Y=B
    B=A
    A=X
    X=Y
    Saved in in retroarch and after a few hours of using the guides, trying both Total Commander and putty to find my retroarch saves and no succsess...
    the darn . in the the adress was the badguy. Or maybe that I am a noob...
    \RECALBOX\share\system.config\retroarch\config
    there it was, using window search for the name did the trick.
    And here I thought I was done... Just to type the correct path to the newly saved config file... accordingly to the guide would be;
    nes.configfile=/recalbox/configs/retroarch/inputs/nesconf.cfg

    But nooo, it just killes emulatur (the nes one), making no game to start, and if I delete the line, it still does not work...
    I have to put in the copy of the recalbox.conf to get it to work again.
    I even tried to write another path to it, since I thought it was wrong... the actutall path to config is;
    \RECALBOX\share\system\configs\retroarch\inputs
    Atleast on my image.
    Sooo, if anyone still here and reading, can you help me to figure out were I should change the recalbox.conf
    so it overrides the setting and uses MY settings for the Nes.
    The guide reads;

    ## You can override the global configuration here
    ## Here is the snes example
    ;snes.videomode=CEA 4 HDMI
    snes.core=snes9x_next
    ;snes.shaders=/recalbox/share/shaders/shaders_glsl/mysnesshader.gplsp
    ;snes.ratio=16/9
    ;snes.smooth=0
    ;snes.rewind=1
    ;snes.autosave=0
    ;snes.emulator=libretro
    ## If you do not want recalboxOS to generate the configuration for the emulator : 
    ;snes.configfile=/path/to/my/configfile.cfg~~~~
    
    and I have added my line just below the last part.
    And tried to replace it, and my own path....I am all out of ideas :/
    Hope someone here knows a solution.
    Thanks in advance and sorry for the wall of text.
    /Jonas


  • And I found the error...
    Using Total Commander to swap the new file in, did NOT work.
    Using the ip interface (fantastic by the way) and there change the lines did the work :)


Log in to reply
 

Want to support us ?

279
Online

24274
Users

12901
Topics

97741
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.