NTP never syncs



  • I'm running V4.1.0-DEV and NTP doesn't seem to want to sync. I've tried killing the service and running it manually with ntpd -gxq4 and it prints out the following, then just sits there forever.

     1 Jan 01:40:49 ntpd[1220]: ntpd 4.2.8p8@1.3265-o Thu Apr 27 13:08:26 UTC 2017 (1): Starting
     1 Jan 01:40:49 ntpd[1220]: Command line: ntpd -gxq4
     1 Jan 01:40:49 ntpd[1220]: proto: precision = 0.833 usec (-20)
     1 Jan 01:40:49 ntpd[1220]: restrict: ignoring line 11, address/host '[::1]' unusable.
     1 Jan 01:40:49 ntpd[1220]: Listen and drop on 0 v4wildcard 0.0.0.0:123
     1 Jan 01:40:49 ntpd[1220]: Listen normally on 1 lo 127.0.0.1:123
     1 Jan 01:40:49 ntpd[1220]: Listen normally on 2 wlan0 192.168.0.123:123
     1 Jan 01:40:49 ntpd[1220]: Listening on routing socket on fd #19 for interface updates
    

    Other relevant info:

    # cat /etc/ntp.conf
    server 0.ca.pool.ntp.org iburst
    server 1.ca.pool.ntp.org iburst
    server 2.ca.pool.ntp.org iburst
    server 3.ca.pool.ntp.org iburst
    restrict default nomodify nopeer noquery limited kod
    restrict 127.0.0.1
    restrict [::1]
    
    # ping -c3 0.ca.pool.ntp.org
    PING 0.ca.pool.ntp.org (198.245.51.213): 56 data bytes
    64 bytes from 198.245.51.213: seq=0 ttl=56 time=29.441 ms
    64 bytes from 198.245.51.213: seq=1 ttl=56 time=37.053 ms
    64 bytes from 198.245.51.213: seq=2 ttl=56 time=33.911 ms
    
    --- 0.ca.pool.ntp.org ping statistics ---
    3 packets transmitted, 3 packets received, 0% packet loss
    round-trip min/avg/max = 29.441/33.468/37.053 ms
    

    Any help is appreciated.


Log in to reply
 

Want to support us ?

Join us on :

347
Online

31227
Users

15140
Topics

113883
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.