Resolution NOOBS



  • Hello guys,
    On my raspberry I installed Jessie, and recalbox,
    It all starts after the initial boot screen, which one chooses which one to start.
    If the raspberry is connected to a monitor or TV via HDMI, all right;
    The problem arises when I use my raspy connected to a 7 inch touch screen, resolution 1024X600,
    In the initial screen (Nobbs) you see only vertical rows.
    I configured the config.txt file so I did not have any problems with Jessie and recalbox when I started, but I do not know what and how to change screen resolution on this first boot screen (Nobbs).
    Can you help me please?
    Does anyone know if there is a file to edit or another solution?



  • Errrr ... No idea, but https://raspberrypi.stackexchange.com/a/30037 could be a start



  • nothing!

    There is a system or configuration file of noobs, in addition to recovery.cmdline?
    There must be a file that "tells noobs" the hdmi resolution.



  • @Usato it may just query a valid resolution by hdmi and revert to a default one if none was obtained



  • My display is 1024x600, if I do not set this resolution, in the boot menu, I see nothing and I can not choose which system to start (recalbox or raspbian or kodi or other)
    If "key 2" or "key 1" selection noobs changes resolution, means that it reads a resolution file,
    I would like to edit those files.
    not possible?



  • @Usato no the key strokes have a meaning, where noobs sets composite, hdmi ou hdmi safe output. I don't have noobs anymore, it's hard for me to search



  • Good,
    TK



  • @Usato NOOBS doc says :

    Your Pi will now boot into NOOBS and should display a list of operating systems that you can choose to install.
    If your display remains blank, you should select the correct output mode for your display by pressing one of the following number keys on your keyboard:
    1. HDMI mode - this is the default display mode.
    2. HDMI safe mode - select this mode if you are using the HDMI connector and cannot see anything on screen when the Pi has booted.
    3. Composite PAL mode - select either this mode or composite NTSC mode if you are using the composite RCA video connector.
    4. Composite NTSC mode
    

    So I'd press 2.

    Have you tried adding a config.txt file where you'd set yourself the resolution ? Looks like it may work



  • @Usato Just got the confirmation from one of the author of noobs : you can use a config.txt 🙂



  • I have already tried to press 1-2-3-4
    It would want the option 5 (Custom Resolution Settings)

    The config.txt file has changed and thanks to this I have no problems in viewing recalbox and raspbian, but the boot menu can not be displayed.
    I see white screen with vertical lines.



  • @Usato drop it in the very first partition, the noobs one. It's like configuring BIOS, this file is read prior to booting the OS.



  • This is interesting...
    can you explain it better?
    I would like to have more details ...



  • If I modify the files:
    /media/pi/SYSTEM/noobs.conf ?

    or

    / Media / pi / 01A6-0A6B (I believe the noobs partition) /config.txt ?

    For a reboot i saw the picture of noobs, bad quality, but i was fine, then i deleted the string: "hdmi_drive = 1" and after everything came back as before ... then i got it back but nothing.
    I really do not understand.

    Ps: I will reboot 30 times to do the tests.



  • I have no idea where it is mounted in raspbian, i'd rather trust it's the /dev/mmcblk0p1, up to you to check where it is mounted with mount



  • This was the result of "mount"

    /dev/mmcblk0p9 on / type ext4 (rw,noatime,data=ordered)
    devtmpfs on /dev type devtmpfs (rw,relatime,size=469532k,nr_inodes=117383,mode=755)
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    proc on /proc type proc (rw,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
    tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
    tmpfs on /etc/machine-id type tmpfs (ro,mode=755)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    configfs on /sys/kernel/config type configfs (rw,relatime)
    /dev/mmcblk0p8 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
    tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=94776k,mode=700,uid=1000,gid=1000)
    gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
    /dev/mmcblk0p7 on /media/pi/3b5fdb55-32a7-4b35-85e2-c7144bb88443 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
    /dev/mmcblk0p6 on /media/pi/01A6-0A6B type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)
    /dev/mmcblk0p5 on /media/pi/SETTINGS type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
    /dev/mmcblk0p12 on /media/pi/share type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
    /dev/mmcblk0p11 on /media/pi/root0 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
    /dev/mmcblk0p10 on /media/pi/boot01 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)

    I honestly do not understand what to do.



  • @Usato The aim is to mount /dev/mmcblk0p1 (the very first partition of the sdcard that is in fact noobs) and add a config.txt from here

    just out of my mind, try :

    mkdir -p /tmp/noobs
    mount /dev/mmcblk0p1 /tmp/noobs
    

    If mount succeeded, you should be able to cd /tmp/noobs and create a config.txt from there. Do you know which lines you're supposed to add to the config.txt for noobs ?



  • hmdi_group=2
    hdmi_mode=87
    hdmi_cvt 1024 600 60 3 0 0 0

    correct?



  • command:
    mount /dev/mmcblk0p1 /tmp/noobs

    message:
    mount: only root can do that

    ????



  • @Usato Sorry I'm so used to be root, and not having to sudo

    So :

    mkdir -p /tmp/noobs
    sudo mount mount /dev/mmcblk0p1 /tmp/noobs
    

    Then editing the file needs to be done through sudo, always. For example : sudo nano /tmp/noobs/config.txt. I'm not sure about the mount options to give any user the read/write access to the mount point



  • ok, now?

    ps
    Why created folder / tmp / noobs?


Log in to reply
 

Want to support us ?

280
Online

80.5k
Users

21.6k
Topics

158.2k
Posts