Recalbox 7.0

IkeArcade



  • After I finished my SNES project (forum.recalbox.com/topic/6031/snes-mod-gpio-controller-start-stop-reset-und-led/9) I decided to make a similar table like presented on element14. But I didn't want to use the small LACK table and wanted a bigger screen. So I bought a 32" screen and the 117x88 LACK table. The project is almost finished. I will add an acrylic to protect the screen and the table surface, a power button and a power led. It was not very complicated and lots of fun.

    0_1487937426864_20170222_105329.jpg
    0_1487937442143_20170222_105759.jpg
    0_1487937465661_20170222_123136.jpg
    0_1487937476094_20170222_170101.jpg
    0_1487937506904_20170222_115945.jpg
    0_1487937522940_20170223_204326.jpg
    0_1487937536684_20170223_214401.jpg
    0_1487937668617_20170223_224021.jpg
    0_1487937712774_20170224_085538.jpg



  • Very nice and successful integration !!! Congratulations !!! Hardly any flaws on your work, you made it perfect 🙂 And pretty WAF compatible 🙂



  • Thank you Substring. I also have to mention that I had to do the following in order toget the XCSOURCE Arcade Button/Stick set (www.amazon.de/dp/B01LAUYMQ6) working properly.

    • fresh recalbox install

    • configure player 1 controls and set INPUT P1 to #0 TWIN USB GAMEPAD

    • ssh into recalbox

    • make the boot partition writeable with "mount -o remount, rw /boot"

    • open cmdline.txt with "nano /boot/cmdline.txt"

    • insert "usbhid.quirks=0x810:0xe001:0x040" at the end of the content of "cmdline.txt"

    • reboot the system

    • IMPORTANT! NOW DO NOT CONFIGURE THE PLAYER 2 CONTROLS just set INPUT P2 to #1 TWIN USB GAMEPAD and it will work and have the same configuration as Player 1 controls (if you would configure the player 2 controls the stick would be inverted in Mame games)

    Greetings,
    Faxe



  • @faxesystem Great job! I see you used quite the same gear as I did:-)
    I built a 4 player cocktail table. Great to play two player cocktail games like tetris with 90° turned Screen as well.
    0_1488101675764_WP_20160926_07_20_57_Pro.jpg

    @Substring
    But with 4.1 I ran into a weir problem. My joysticks (a XIN-MO Dual and two Dragonrise) are configured in Emulationstation like P1=XIN-MO (#2), P2=XIN-MO (#3), P3=Dragonrise (#0), P4=Dragonrise (#1). When I run a game with retroarch the joysticks are in different sequence (P1=Dragonrise (#1)) and so on). Couldn't get it to work even with trying to change sequence in retroarch. Any ideas?



  • Hi @peterpan123123 ,

    your table is just awesome! I'm really now thinking of also drilling some more holes and putting in two more sticks and a few buttons. Since I dont have your encoders I can't help you with the problem but maybe you have to do the same and just configure ONE Player of each encoder set?

    Also how do you do the screen rotation? When I try to rotate the screen in the retroarch on screen menu it get's rotated but the aspect ratio is not changing.

    Greetings,

    Faxe



  • Ah I just got it. One has to change the aspect ratio by hand :D. So not using "core provided" but 4:3 for example. 😄



  • @peterpan123123 do you always change the input of player 1 and 2 manually when playing tabletop games or is it possible to have 2x Play1 and 2x Player2?



  • @faxesystem I don't know if I got you right. I use FBA for two players game with oposite players (cocktail mode) and use mame2003 and FBA_libretro for 1-4 player games. So for each emulator I got different settings. It works great, well it used to work great until the controllers got mixed up:-(



  • @faxesystem Thank you:-)
    Yes the XIN-MO Dual works exactly that way (configure just player 1 (player 2 has always the same config as p1)).

    Btw. did you turn your screen upside down as well? It makes a big difference with my screen. The angle is much better (just add display_rotate=2 to your /boot/config.txt).



  • @peterpan123123 xinmo problem solved ?



  • @Substring Thanks for asking. Yes! Tried quite alot of things.

    Changed the sequence in Emulationstation from 1P XINMO, 2P XINMO, 3P Dragonrise, 4P Dragonrise to 1P Dragonrise, 2P Dragonrise, 3P XINMO and 4P XINMO. I could use the joysticks in retroarch (before it moved eraticly) but in wrong order (4P is still first).

    Deleted all configs and tried again without any luck.

    I even plugged the USB cables in different USB ports - with the result, that it worked!!! So it seems something changed from 4.0.2 to 4.1. Weird, I always thought, that the order in which I plugin the USB cables doesn't matter:-)
    I had to delete all the states and saves otherwise the game wouldn't start.



  • @peterpan123123 are these dragonrise some xin-mo like encoders ?



  • @Substring they are these 0_1488180084398_usb-encoder.JPG

    @Substring I still got a weird problem. Neogeo uses FBA and works perfectly. FBA does not detect any Joystick, even it should be the same core? I configured, that the config should be saved per core. Even deleting all the configs in .config didn't solve the problem.
    Btw. I do have the yellow square problem with FBA and MAME (even deleting the config files like stated as a Workaround).

    I try to reinstall recalbox. Maybe I just messed up somewhere.



  • @Substring Sorry, that was a little confusing. I use the FBA core for neogeo. In neogeo I use the FBA core and everything works. In piFBA I use FBA as well and all the joystick and buttons don't get recognised at all.



  • @peterpan123123 what pi are you using ? If you have a pi2/3, don't bother with pifba



  • @Substring I use a pi3. Because I want to rotate the screen for cocktail 2P games this is easy with a different Emulator. So I config piFBA to rotate the Screen 90° for cocktail games (or games not in landscape mode). Therefore I never have to change this setting anymore:-)
    If you would have another solution for this, I would be pleased to know.



  • @peterpan123123 mmmhhhhh ... Too early yo say it's ready, but i'll add a way to rotate screen on a pergame basis. But that's not before weeks



  • @Substring That would be absolutely awsome!!!



  • @peterpan123123 for people hving fun with rotating screens, hell yeah ! Mame now includes a TATE mode (not fba, sadly), to autoswitch to a vertical resolution



  • Nice! I did something similar recently but with the smaller table.
    https://goo.gl/photos/hxzFX18aBPpewbuz9

    Out of curiosity, how do things look on the bottom of your table? I'm always curious how people choose to supply power to their set up and whether things are mounted to the bottom or contained internally


Log in to reply
 

Want to support us ?

109
Online

79.1k
Users

20.4k
Topics

149.2k
Posts