Problème manettes GPIO



  • Salut à tout, Je suis en train de rénover une vieille borne de jeux "Arcades Electronic", j'ai donc changé les boutons et les joysticks, j'ai tout connecté au ports GPIO de mon Raspberry Pi 2 (sans oublier les masses) comme c'est indiqué dans la notice :     GPIO J'ai bien édité le fichier recalbox.conf comme c'est indiqué ici : http://blog.recalbox.com/forums/topic/gpio-boutons-non-detectes/ # ------------ E - GPIO Controllers ------------ # ## If one of the enable[controller] is set to 1, set the other to 0_ ## GPIO Controllers ## enable controllers on GPIO (mk_arcard_joystick_rpi) enable_mk_gpio=1 ## mk_gpio arguments (map=1 for only one gpio controller) mk_gpio_args=map=1,2 ## DB9 Controllers ## enable db9 drivers ;enable_db9=0 ## db9 arguments ;db9_args=map=1 ## gamecon controllers _## enable gamecon controllers, _ ;enable_gamecon=0 ## gamecon_args ;gamecon_args=map=1 Puis je redémarre, je vais avec le clavier dans "configurer les manettes" et là "Aucune manette détectée". Es-ce que j'ai oublié une étape ? Il faut faire quelque chose de plus ?


  • Tester

    A priori tu as tout fait correctement. Essaye de redémarrer sans ton clavier branché, et à la page d'accueil d'emulationstation, ça devrait te demander de rester appuyé sur une touche pour configurer, dans ce cas reste appuyé sur un de tes boutons. Pour ma part ça a fonctionné du premier coup, tu es bien sur à 100% de ton câblage ?



  • Merci de ton aide, Alors, j'ai essayé de démarrer sans clavier mais là il ne me demande pas de rester appuyé sur une touche pour configurer et si je rebranche le clavier j'ai toujours « Aucune manette détectée » Pour mon câblage, on n'est jamais sur à 100% avant d'avoir essayé mais je devais avoir au moins quelques boutons qui fonctionnent. Es-ce qu'il ne faut pas aussi activer quelque chose du coté de ## DB9 Controllers et ## gamecon controllers ? Ou installer un script comme indiqué sur cette page ? : https://github.com/digitalLumberjack/mk_arcade_joystick_rpi


  • Tester

    Non il n'y a rien d'autre à faire que ce que tu as fait. db9 et gamecon sont d'autres controleurs sans rapport avec ce que tu veux faire. Et il n'y a pas de script à ajouter. Quant à ton câblage, si tu as fait une chaine de masse, et qu'il y a un souci dès la première chaine, aucun de tes boutons ne fonctionnera, ceci dit c'est peu probable je te l'accorde.



  • au pire un petit test de continuité sur la chaîne de masse histoire d'écarter cette source de problème ?



  • Finalement, j'ai laissé tomber le GPIO, et j'ai commandé 2 Encodeur Joystick-boutons arcade USB chez SmallCab, livraison ultra rapide, ça marche très bien et comme c'est de l'USB, si un jour je décide d'utiliser un autre ordinateur, ça marchera aussi. Mais merci pour votre aide. Edit : Je crois que j'ai compris pourquoi ça ne marchait pas. Je me suis connecté en SSH et j'ai édité le fichier recalbox.conf, comme c'est expliqué ici. Dans mon fichier recalbox.conf, il y avait écrit ^M à la fin de chaque ligne. C'est surement parce que j'avais édité le fichier depuis windows avec WordPad. Alors, si vous rencontrez le même problème, vérifiez votre fichier recalbox.conf en SSH.


Log in to reply
 

Want to support us ?

226
Online

82.1k
Users

22.6k
Topics

163.3k
Posts