[RESOLU] X-arcade en USB non reconnu dans les jeux mais menu ok



  • Bonjour à tous, je possède un stick arcade " X-Arcade Dual Joystick: USB " celui ci est reconnu comme un clavier. Lorsque je mappe dans l'interface les boutons, j'arrive parfaitement à naviguer dans les menus et lancer une rom et c'est la que ca coince, aucun bouton n'est reconnu. Quelqu'un à déjà eu ce problème et comment le résoudre ? Merci de votre aide.


  • Staff
    Global moderator
    Team

    Bonjour, Il semble que ce soit en effet un probleme connu sur ce gamepad. :s. Très sympa au demeurant, il pause problème sur retroarch et donc, sur la majorité des distributions raspberry :/. C'est un problème déjà identifié sur les controlleur usb intégrant 2 gamepad en un :s Je t'invite à regarder ce tutoriel cependant qui semble réglé le problème. Je l'ai juste survolé mais il doit y avoir moyen de l'adapter à notre recalbox. http://blog.petrockblock.com/2014/06/01/xarcade2jstick/ Malheureusement, si ce n'est te montrer le chemin, je ne pourrais pas t'accompagner plus loin. D'autres sont plus compétent que moi sur le sujet. 😕 N'hésite pas à donner tes infos pour que d'autres puissent t'aider. Bon courage.



  • Merci de ta réponse, je regarde ca dès que j'ai le temps 🙂



  • Bonjours j’utilise le X-arcade sans problème avec recalbox il faut juste editer manuellement le retroarchcustom.cfg et rajouter les valeurs de tes touches voila en example le mien pour le player 1 input_player1_b = "z" input_player1_b_btn = "nul" input_player1_b_axis = "nul" input_player1_y = "x" input_player1_y_btn = "nul" input_player1_y_axis = "nul" input_player1_select = "num1" input_player1_select_btn = "nul" input_player1_select_axis = "nul" input_player1_start = "rshift" input_player1_start_btn = "nul" input_player1_start_axis = "nul" input_player1_up = "up" input_player1_up_btn = "nul" input_player1_up_axis = "nul" input_player1_down = "down" input_player1_down_btn = "nul" input_player1_down_axis = "nul" input_player1_left = "left" input_player1_left_btn = "nul" input_player1_left_axis = "nul" input_player1_right = "right" input_player1_right_btn = "nul" input_player1_right_axis = "nul" input_player1_a = "s" input_player1_a_btn = "nul" input_player1_a_axis = "nul" input_player1_x = "a" input_player1_x_btn = "nul" input_player1_x_axis = "nul" input_player1_l = "c" input_player1_l_btn = "nul" input_player1_l_axis = "nul" input_player1_r = "v"



  • je ne trouve pas ce fichier 😞


  • Staff
    Global moderator
    Team

    Bonjour tu dois te connecter en SSH avec un accès root via winscp pour voir les fichiers. tu peux trouver le fichier donnée dans /recalbox/share/system de mémoire. Jete un oeil sur les mini-how. https://github.com/digitalLumberjack/recalbox-os/wiki/Mini-How-To-(FR)



  • Il faut se connecter avec winscp pour voir tout les dossiers



  • via ssh, ce fichier est vide, ou je peux trouver un tuto avec tous les boutons ? Merci



  • avec putty, j'arrive à me connecter mais winscp veut pas.... Peut etre pour ca que je ne vois quasi aucun fichier.



  • meaculpa pour winscp... j'ai vu mon erreur 🙂



  • malgré avoir renseigné les touches, ca marche toujours pas 😞

    core_options_path = /recalbox/configs/retroarch/cores/retroarch-core-options.cfg
    
    system_directory = /recalbox/share/bios/
    
    config_save_on_exit = false
    
    video_threaded = true
    
    #video_aspect_ratio = 1.33
    aspect_ratio_index = 0
    aspect_ratio_index = 0
    #video_force_aspect = false
    video_aspect_ratio_auto = true
    #video_scale_integer = true
    
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    
    video_gpu_screenshot = true
    
    video_shader_enable = false
    video_smooth = true
    
    screenshot_directory = /recalbox/share/screenshots/
    savestate_directory = /recalbox/share/saves/
    savefile_directory = /recalbox/share/saves/
    extraction_directory = /recalbox/share/extractions/
    
    fastforward_ratio = -1.0
    input_autodetect_enable = true
    
    joypad_autoconfig_dir = /recalbox/configs/retroarch/inputs/
    
    input_player1_analog_dpad_mode = "1"
    input_player2_analog_dpad_mode = "1"
    input_player3_analog_dpad_mode = "1"
    input_player4_analog_dpad_mode = "1"
    
    input_enable_hotkey = "escape"
    input_exit_emulator = "escape"
    
    input_player1_b ="f"
    input_player1_a ="g"
    input_player1_y ="r"
    input_player1_x ="e"
    input_player1_l ="t"
    input_player1_r ="h"
    input_player1_start ="x"
    input_player1_select ="w"
    input_player1_up ="z"
    input_player1_down ="s"
    input_player1_left ="q"
    input_player1_left ="d"
    input_enable_hotkey_btn = "f1"
    
    input_player1_joypad_index = 0
    input_player2_joypad_index = 1
    input_player3_joypad_index = 2
    input_player4_joypad_index = 3

  • Staff
    Global moderator
    Team

    Bonsoir et en copie/collant ce que factor250 a posté vu qu il a apparemment la meme manette que toi ne pas oublier de rebooter le pi



  • Non ça ne marchera pas car mon assignation des touches n est pas celle par défaut du x arcade



  • yakta !!!!!!!!!!!!!! en fait, il faut appuyer 2 fois sur le bouton "mémoire" (situé à l’arrière) pour faire un rappel a chaque redémarrage du pi 🙂 Autre question, peut-on créer un mapping de bouton en appuyant sur 2 touches ? EX: input_exit_emulator = "touche1 + touche2" merci.



  • oui c'est possible avec la hotkey par exemple input_enable_hotkey = "F1" input_exit_emulator = "t" pour sortir de l'emu il faut que tu appuie sur les touches du x-arcade qui correspondent à F1 et t en même temps



  • Bonjour à tous ! Je suis nouvel utilisateur de ce superbe environnement en version 3.3.0-beta17 et je souhaiterais utiliser mon X-arcade (tankstick). Je me retrouve confronté (malgré mes essais de modification de multiples fichiers de configuration) au même problème : navigation dans les menus OK, mais pas sous les émulateurs (à part deux boutons au hasard). J'ai fait pas mal d'essais avec fba_libretro et j'ai l'impression que les fichiers de configuration sont "écrasés" lorsque je lance l'émulateur. Y aurait-il quelque chose à changer dans les fichiers de configuration de recalbox afin de lui faire passer les bonnes infos aux différents émulateurs ou alors quelle est la technique pour paramétrer chacun d'eux ? Désolé de reposer ces questions, mais malgré mes nombreuses recherches, je n'ai pu trouver de réponse concrète. Merci pour votre aide !



  • @xoff @bbtoff je viens de plancher pour compiler xarcade2jstick, qui permet de faire reconnaitre le XArcade en 2 pads. Est-ce que vous pourriez faire du test avec moi ? Merci



  • Merci de cette réponse rapide : je serai heureux de pouvoir tester cela. Je suis informaticien, mais débute dans l'environnement "recalbox", avec un minimum d'information sur la procédure à suivre je suis partant pour aider. Je reste donc dispo sur le sujet !



  • @xoff Ce qu'il y a à tester est facile si tu connais les rudiments de Linux :

    1. Télécharger http://dl.free.fr/mYY68uj1T
    2. brancher ton xarcade et démarrer ton Pi
    3. poser sur ta recalbox xarcade2jstick que tu as téléchargé en 1. Penser à faire un chmod u+x dessus
    4. ouvrir un shell avec putty, lancer xarcade2jstick -> il devrait dire qu'il a trouvé un XGaming X-Arcade quelque chose
    5. faire la configuration des 2 joysticks dans EmulationStation
    6. tester des émulateurs

    Ce que xarcade2jstick affichera m'intéresse beaucoup Si tu as des problèmes, je suis très souvent sur IRC, c'est plus simple pour les échanges en direct



  • OK super pour ces instructions détaillées, demain je suis full, mais vendredi je pourrai tester tout ça. Concernant le dépôt du fichier y a-t-il un dossier en particulier où il faut le déposer ?



Want to support us ?

235
Online

82.0k
Users

22.5k
Topics

163.0k
Posts