WINScp, ssh en général et caractères accentués dans recalbox



  • Bonjour,

    Je viens de migrer depuis quelques jours mon media center sous recalbox afin de profiter en plus de kodi de la fonctionnalité console.

    Tous mes fichiers était et sont toujours stockés sur un disque dur externe connecté en USB.

    Le Kodi de ma recalbox les voit : OK.

    J'arrive à me connecter en ssh (via linux ou windows), pas de soucis : OK.

    J'ai trouvé le point de montage du disque dur : OK.

    J'ai vérifié que le FS est bien reconnu, /etc/mtab me montre bien qu'il a reconnu l'ext4.

    J'arrive à accéder au contenu de ce disque via winscp sous windows : on y est presque...

    Mais dès que j'essaie d'entrer dans un dossier contenant un accent, ça m'envoie une erreur du style :
    La commande 'cd "Ast??rix CD1 French (dessins anim??s) by [SG_TE@M]"'
    a échoué avec pour code de retour 1 et pour message
    -sh: line 74: cd: Ast??rix CD1 French (dessins anim??s) by [SG_TE@M]: No such file or directory.

    Je remarque d'ailleurs que lorsque j'essaie d'accéder à ce type de dossier en console via ssh, je ne peux y accéder qu'à l'aide de la complétion (qui complète avec les accents) mais pas en tapant moi-même ces accents.

    Je souhaiterais :

    • corriger le soucis rencontrer avec les accents,
    • pouvoir accéder à mon disque via samba aussi simplement que j'accède aux roms (ça, ce serait vraiment bien...)

    Merci pour votre aide.



  • Bonjour,

    Bon, je continue de creuser... J'ai configuré le clavier dans recalbox.conf (au cas où...), redémarré, mais ça n'a rien changé : toujours le même problème.

    J'ai cherché les variables d'environnement du système mais quand je tape "locale", je vois bien que cette gestion n'est pas opérationnelle sur le système compilé en l'état : peut-être un truc utile à ajouter dans les prochains builds ?

    J'ai creusé du côté de dropbear pour voir s'il était possible de régler des variables "locale" dans le serveur : rien trouvé.

    Je sèche un peu là... Renommer 2To de fichiers, ça ne m'enchante pas trop...



  • Nouvelle tentative : passer par samba.

    J'ai effacé les répertoires movies, pictures et music du répertoire kodi, je les ai remplacé par des liens symboliques vers mes répertoires et ... patatra : pour des raisons de sécurité, samba ne suit plus les liens symboliques...

    J'ai édité /etc/samba/smb.conf pour y ajouter :
    # suivre les liens symboliques
    unix extensions = no

    Et... patatra : Error writing smb.conf, Read-only file system.

    Du coup, un autre truc qui serait vachement bien : débrider l'accès au file system. J'ai l'impression d'avoir un linux sans possibilité de le bidouiller à ma sauce, c'est frustrant...

    Prochaine étape ? Me compiler une recalbox perso ? (Erf, c'est pas ce que j'avais prévu...)


  • Staff
    Global moderator
    Team



  • Nouvelle tentative : modifier le smb.conf sur un autre linux directement sur la carte sd. Modification faite, mais semble disparaître après le boot... soit je tape pas dans le bon fichier de conf sur la sd, soit il y a un système de génération automatique de conf au démarrage qui me vire mon option, soit je me suis gauffré dans l'écriture de l'option, soit.... bref, quelque chose m'échappe...



Want to support us ?

168
Online

80.5k
Users

21.6k
Topics

158.2k
Posts