Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problème GPIO et WIFI



  • Bonjour à tous

    Je suis tout nouveau dans le domaine mais je bloque depuis hier.
    Impossible dans un premier temps de mettre le WIFI sur mon Raspberry 3 (sous Recalbox), j'ai été dans la configuration (via l'adresse IP) pour mettre le SSID et le mot de passe mais ça me marque quand même déconnecté.
    Deuxième gros problème, j'ai branché les fils au GPIO, j'ai mis controllers.gpio.enabled=1 mais rien ne fonctionne, aucun bouton.

    Si vous pouviez m'aider avec des solutions simples ^^

    Merci !!



  • @gohanblog Salut,

    1. WiFi : est-ce que tu as une adresse IP d'attribuée ou non ? Peux-tu accéder à http://recalbox/ si tu es sous windows (http://recalbox.local/ pour les 2 autres OS) ? Si oui, il y a un sujet épinglé pour résoudre ce problème dans le sous-forum Général
    2. Va falloir détailler comment tu as branché, là c'est trop peu pour qu'on puisse t'aider. Pas de photo avec 25 fils emmêlés hein 😉


  • @Substring j'ai bien accès à http://recalbox/ donc le wifi doit fonctionner ? (même si quand je vais dans le menu il indique déconnecté).
    Pour le GPIO bizarrement d'un coup ça marche, mais, il me propose 2 GPIO controller (au lieu d'un seul, j'ai qu'un joystick + boutons). J'ai configuré un GPIO controller mais impossible de naviguer dans le menu avec mon joystick par exemple ?).
    (Je navigue avec une manette Xbox 360 du coup)



  • @gohanblog pour le réseau, lis https://forum.recalbox.com/topic/5436/statut-deconnecte-alors-que-le-réseau-marche-solution et tu comprendras

    Ton GPIO : le driver doit quasi toujours (sauf si tu changes les paramètres dans le recalbox.conf) détecter 2 sticks

    Le truc : utiliser evtest en SSH et tester ton GPIO. Mais il doit sûrement mal etre branché.



  • @Substring Merci pour tes réponses, tu peux juste préciser pour "utiliser evtest en SSH", c'est trop technique pour moi.
    Dernière question : le son est hyper hyper faible (pourtant il est a 91 % et lorsque je branche mon téléphone par exemple en jack on voit bien que les enceintes peuvent donner beaucoup beaucoup plus ^^



  • @gohanblog ben le son du jack est juste une horreur. Souffle affreux, faible dynamique ... Ton téléphone lui a peut etre une sortie plus puissante que le pi 😉

    Pour evtest : tu te connectes en SSH (il y a un tuto sur le wiki), et une fois au prompt, tu tapesevtest


Log in to reply
 

Want to support us ?

120
Online

78.5k
Users

20.1k
Topics

147.5k
Posts