[Résolu][GPIO] Boutons non détectés



  • Bonjour ! J'ai installé et mis à jour ma Recalbox sur une Raspberry Pi B+ afin de créer à terme une borne d'arcade. J'ai acheté un kit de joysticks et boutons que je suis en train de connecter sur le GPIO de ma RPi en suivant le schéma sur le wiki. Pour l'instant, pour tester, je n'ai branché que le joystick et les boutons du premier joueur. J'ai ensuite démarré la box et suis allé dans le menu de configuration des manettes, mais lorsque j'appuie sur un bouton, rien n'est détecté. Y a-t-il autre chose à activer dans Recalbox OS pour activer le GPIO ? Merci d'avance pour votre aide !



  • Hello , Moi aussi j'ai comme projet de faire une borne d'arcade alors je me suis un peu renseigné sur le sujet. De ce que j'ai lu sur ce forum , <del datetime="2015-04-11T20:42:07+00:00">il faut que tu édites ton fichier config.txt <del datetime="2015-04-11T20:43:37+00:00">- Pour pouvoir éditer le fichier config.txt</del> https://github.com/digitalLumberjack/recalbox-os/wiki/Editer-le-fichier-config.txt-(FR) - Tu dois aller dans la partie du fichier concernant les GPIOS : ça doit ressembler à ça ## GPIO Controllers ## enable controllers on GPIO (mk_arcard_joystick_rpi) ;enable_mk_gpio=0 <------ Tu dois modifier cette ligne en `enable_mk_gpio=1 ## mk_gpio arguments (map=1 for only one gpio controller) ;mk_gpio_args=map=1,2 Voilà j'espère ne pas avoir dit de bêtise et que cela résoudra ton problème .</del> [Edit] éditer le fichier recalbox.conf , sorry pour la mauvaise info



  • Oula non les gars ne touchez pas au fichier config.txt. C'est le fichier recalbox.conf qu'il faut éditer pour activer les gpio.



  • Horwell :

    – Tu dois aller dans la partie du fichier concernant les GPIOS : ça doit ressembler à ça ## GPIO Controllers ## enable controllers on GPIO (mk_arcard_joystick_rpi) ;enable_mk_gpio=0 <—— Tu dois modifier cette ligne en `enable_mk_gpio=1 ## mk_gpio arguments (map=1 for only one gpio controller) ;mk_gpio_args=map=1,2

    T'inquiètes pas pour l'erreur, je suis allé voir le fichier config et j'ai pas trouvé ces lignes de toute façon ! ^^ rockaddicted :

    Oula non les gars ne touchez pas au fichier config.txt. C’est le fichier recalbox.conf qu’il faut éditer pour activer les gpio.

    OK, merci pour l'info ! Par contre, comment on fait pour accéder au fichier ? On peut passer par recalboxOS ou il faut enlever la SD pour la mettre dans un ordi ? En tout cas, merci à vous deux pour votre aide ! EDIT : Je crois qu'il n'y a pas trop de rapport, mais quand je vais dans le menu "configurer les manettes", parfois à la place de la ligne "appuyez sur ECHAP pour annuler", y'a écrit ":/opensans_hebrew_condensed_regular.ttf". On sait jamais, je préfère le préciser. EDIT 2 : ...Ah ben j'avais pas bien lu le Wiki ! ^^ Désolé pour le dérangement ! Je vais tester ça de suite. EDIT 3 : C'est bon, les boutons et les sticks sont détectés. J'ai activé le GPIO comme ceci : # ------------ E - GPIO Controllers ------------ # ## If one of the enable_[controller] is set to 1, set the other to 0 ## GPIO Controllers ## enable controllers on GPIO (mk_arcard_joystick_rpi) enable_mk_gpio=1 ## mk_gpio arguments (map=1 for only one gpio controller) mk_gpio_args=map=1,2 Après, y'a quelques boutons qui sont mal reconnus, mais je pense que ça doit être dû à une mauvaise connexion de ma part ! Merci beaucoup pour votre aide ! Et vive la RecalBox ! ^^ EDIT 5 : Il me semble qu'il y a une erreur sur le schéma de connexion : appremment, les boutons B et A du Joystick 1 (vert) sont inversés. EDIT 6 : Pareil pour le joystick 2.



Want to support us ?

355
Online

81.3k
Users

22.2k
Topics

161.2k
Posts