Difficulté avec mon Raspberry 2



  • ![Bonjour,
    Je m'apelle Yves, 37ans habitant en France et heureux possesseur d'un Raspberry.
    Un grand bravo à tout ce travail partagé à la communauté.
    J'ai quelques difficultés avec mon Raspberry 2.
    Je n'arrive pas à réglé la résolution de la tv quand je lance un jeu sur l'émulateur N64.
    J'ai pourtant trouvé quelques pistes en farfouillant pendant de nombreuse heures le forum et sur d'autres sites mais je n'arrive pas à comprendre comment réussir à résoudre mon soucis. J'ai trouvé qu'il faillait modifier la résolution de l'écran en rajoutant une ligne d'écriture dans le dossier source du Raspberry. Mon soucis et que je ne connais pas l'emplacement exact de la phrase " n64.videomode=CEA 2 HDMI "
    Le problème est qu'il n'existe pas d'emplacement pour un changement de résolution dans RécalboxOS 4.0 comme le stipule le tuto du forum
    https://github.com/recalbox/recalbox-os/wiki/N64-retour-sous-ES-(FR)
    Du coup j'ai placé cette ligne dans la rubrique " H - HERE IT IS - GLOBAL EMULATOR CONFIGURATION " et je n'ai pas eu de résultat positif
    J'ai un écran noir puis la page d'accueil avec la résolution choisi pour le lancement des jeux N64 et cela fait de même avec différentes résolution.
    Voici des liens d'images de mon dossier source
    http://hpics.li/1072eca
    http://hpics.li/f5ec3ec
    http://hpics.li/98520c7
    http://hpics.li/956f076
    Merci de bien vouloir m'indiquer dans quelle emplacement dois-je mettre ma ligne d'écriture ?
    Merci pour vos réponses

    Cordialement
    Balou1841

    Raspberry Pi 2
    Recalbox version (build) : 4.0
    Matériels (Micro SD, Power Supply, etc.): sd 16Go
    Manette(s): Pad xbox 360 filaire
    Quel emulateur : N64


  • @Balou1841 Salut !

    L'emplacement importe peu dans le fichier, tant que l'info y est presente. par défaut c'est n64.videomode=DMT 4 HDMI ce qui correspond à du 640x480. Ta tv n'arrive pas à la mettre en plein ecran ?



  • @Substring Bonsoir,

    Merci pour ta réponse et j'espère qu'on pourra trouver une solution ensemble.
    J'ai effectué cette commande "tvservice -m DMT" et sauf erreur de ma part, aucune résolution en DMT n'a été trouvé sur ma tv. Seul des résolutions en CEA ont été trouver.

    édit : justement j'ai fait une erreur de frappe pour le DMT et j'ai trouvé un mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive.
    Du coup j'ai modifié le dossier source en mettant " n64.videomode=DMT 4 HDMI " et j'ai toujours l'erreur page noir au lancement du jeu n64 puis modification de la page d'accueil en 480p

    Les jeux sur SNES tourne sans aucun problème en 720p et ils sont affiché en 4:3 car il y a des bandes noirs verticales sur les 2 côtés de l'image. Je n'arrive pas à comprendre pourquoi quand je lance un jeu N64, j'ai une page noir puis je reviens sur la page d'accueil avec la résolution demandé 720p par exemple ce qui me donne ma page d'accueil grossi par rapport à sa résolution d'origine en 1080p.
    Si je suis mon résonnement, j'arrive qu'à modifier la résolution de la page d'accueil après chargement du jeu n64 ?
    Dans tous les cas, merci pour ton coup de main, d'avoir pris le temps de lire mon pavé et d'avoir pris la peine d'y répondre.

    Balou


  • Staff
    Global moderator
    Team

    Bonjour
    il faut que les roms soient décompressées. est ce le cas ?



  • @acris said in Difficulté avec mon Raspberry 2:

    Bonjour
    il faut que les roms soient décompressées. est ce le cas

    @acris said Bonjour,

    Oui les fichiers sont bien dézipper, ils sont bien en n64 et ils sont bien au format n64.
    A ne niveau là, pas d'erreur 🙂



  • Écran noir, mais du son ou pas ?



  • Re,

    Juste écran noir sans le son.



  • @Balou1841 par curiosité, mets defaultau lieu du DMT 4 HDMI pour voir si ca passe



  • @Substring

    Je démarre le Raspberry, la page d'accueil s'affiche avec une certaine musique, je choisis l'émulateur n64 puis choisi le jeu Zelda. J'obtiens une page de chargement avec les inscriptions du Récalbox en bas à gauche de la page. Ensuite, j'obtiens une page noir en 720p puis je retombe quelques secondes plus tard sur la page d'accueil avec une nouvelle musique qui est celle de Tretis avec la résolution de l'image changé en 720p alors qu'elle devrait être en 1080p de base.
    Voici exactement ce qu'il se passe quand j'essaie de lancer des jeux n64.
    Avant de te répondre, j'ai essayé 3 jeux n64 différents et toujours le même résultat.



  • Même avec default ça ne marche pas ? Donc ce n'est pas un problème vidéo mais autre chose. Il faudrait que tu lances le script de support que je vois tes logs



  • @Substring

    Ok pas de soucis sauf que n'ai pas encore vue un sujet qui traite ce sujet du script de support.
    Je vais lancer une recherche sur Google et je te tiens au courant de mon avancé.


  • Staff
    Global moderator
    Team

    @Balou1841
    Tu as configuré ts les boutons de ta manette et activé xboxdrv ds recalbox.conf ?
    https://github.com/recalbox/recalbox-os/wiki/Recalbox-support--(FR)



  • @acris

    Merci acris c'est sympa de ta part.


  • Staff
    Global moderator
    Team

    Jai edit av 2 questions si jms



  • @acris

    J'ai suivi le tuto que tu m'as donné et pour le moment ça fonctionne très bien.
    J'ai réussi à me connecter à ma récalbox avec WinSCP.
    Je n'ai pas encore compris comment fait-on pour trouver le script support.
    Je vais farfouiller et trouver la solution 🙂

    Merci du coup de main



  • @Balou1841 said in Difficulté avec mon Raspberry 2:

    @acris

    J'ai suivi le tuto que tu m'as donné et pour le moment ça fonctionne très bien.
    J'ai réussi à me connecter à ma récalbox avec WinSCP.
    Je n'ai pas encore compris comment fait-on pour trouver le script support.
    Je vais farfouiller et trouver la solution 🙂

    Merci du coup de main

    Edit : est-ce normal que le rapport du script support est de type Snes9x ROM ?
    Voici le lien hébergeur
    http://dl.free.fr/wjc3pmqA1



  • Bonsoir,

    Je relance mon sujet pour résoudre mon soucis avec mon Raspberry.
    Je n'arrive pas à faire tourner les jeux N64.
    @Substring Ai-je fais une erreur avec le rapport script support ?

    Balou



  • @Balou1841 on voit que ca plante effectivement. As-tu bien mappé L et R sur ton pad ?
    Par SSH, i lfaudrait que tu tapes /etc/init.d/S31emulationstation restart, que tu lances ton jeu et que tu colles le message issu du plantage ici stp (si mapper L et R n'a rien résolu)



  • @Substring excuse moi pour le temps de ma réponse.
    Je vais regarder le bouton L et R. Faut-il qu'ils soient configurer avec quelle bouton ?

    Balou



  • @Balou1841 il faudrait deja que tu fasses ce que j'ai demandé avant 🙂


Log in to reply
 

Want to support us ?

300
Online

80.5k
Users

21.6k
Topics

158.2k
Posts