Recalbox 7.0

Configuration GPIO pour Stick Arcade



  • Bonjour, Je suis nouveau sur le site et merci pour le boulot qui a été fait pour cette distribution. Je possede un RPI2 et ce lot : http://www.ebay.fr/itm/121551540944?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649 Je n'ai pas utilisé l'interface usb car il parait qu'il y a un problême pour faire marcher les 2P. Alors j'ai brancher ça sur les GPIOs en me fiant au plan de cablage. Rien ne marche sur emulstation. Je suis allé sur le wiki (https://github.com/DigitalLumberjack/mk_arcade_joystick_rpi) J'ai voulu configurer en SSH depuis mon ordinateur,au moment de taper cette commande: sudo sh ./install.sh updatesystem il me met un message d'erreur. Donc j'ai laissé tombé,aprés je suis allé dans recalbox.conf pour essayer de modifier le fichier et aprés de le sauvegarder. J'ai enlevé les ; devant enable _mk_gpio=0 mk_gpio_args=map=1,2 enable_db9=0 db9_args=map=1 enable_gamecon=0 gamecon_args=map=1 ;enable_mk_gpio=0 ## mk_gpio arguments (map=1 for only one gpio controller) ;mk_gpio_args=map=1,2 ## DB9 Controllers ## enable db9 drivers ;enable_db9=0 ## db9 arguments ;db9_args=map=1 ## gamecon controllers ## enable gamecon controllers, ;enable_gamecon=0 ## gamecon_args ;gamecon_args=map=1 Et toujours rien,je suis un peu perdu,je voudrais continuer la construction de mon Bartop mais je préfere finir la configuration avant,merci d'avance Sherkan


  • Global moderator
    Team

    Je n'ai aucune experience en configuration gpio (pour le moment mais j'ai un petit projet en tete). De ce que j'ai lu sur d'autres topic, les commandes sudo ne fonctionnent pas sous recalbox. Donc il faut les lancer sans sudo. Après, si je m'en réfère au wiki, j'ai l'impression qu'a partir du moment ou tu respect le plan de cablage et que tu active les gpio dans la config de recalbox, cela est sensé fonctionner directement... :s https://github.com/digitalLumberjack/recalbox-os/wiki/Notice-(FR)#g---boutons-sur-gpio Il ne te reste plus qu'a patienter le temps que tu ai un retour d'un utilisateur de gpio. :s



  • Salutation, passe la ligne enable_mk_gpio=0 en enable_mk_gpio=1 et chez moi sa marche ^^ bon courage a toi


Log in to reply
 

Want to support us ?

126
Online

79.1k
Users

20.4k
Topics

149.2k
Posts