[Résolu] Overscan sur tous les émulateurs.



  • Bonjour à tous et merci pour ce p***** de projet qu'est recalbox !!
    Je sais que le sujet a été abordé plusieurs fois car j'ai fouiné le forum en long en large et en travers, mais j'ai besoin d'un coup de pouce.
    Mon interface EmulationStation remplit parfaitement l'écran en activant l'overscan, MAIS tous les jeux que je lance (mame, fba, nes, snes, gb, gba, gbc; megadrive) ne remplissent pas l'écran.
    J'utilise recalbox 4 sur rpi2.
    J'ai testé tout ce que j'ai lu quasiment, changer l'overscan dans config.txt, mettre overscan_scale=1 ou pas, tenter de changer le nombre des pixels pour chaque cotés de l'overscan.
    J'arrive bien à "rétrécir" l'image en jeux, c'est à dire qu'il y a un contour noir plus épais quand je change les left right etc... mais je n'arrive pas à faire l'inverse.
    Quelqu'un aurait la bonté de mes faire part de ses lumières?
    Merci par avance.


  • Themer

    @akh150 t'as essayé de mettre des valeurs négatives pour lesvaleurs d'overscan ?



  • C'est l'option integerscale qu'il faut activer (ou désactiver en fait) je pense ;)

    Tape dans config.txt : global.integerscale=0

    ça devrait résoudre ton problème peut être...



  • Ou passger par ES dans les options des jeux, desactiver integer scale. Les jeux sont en 4:3 hein, pas en 16:9 (sauf l'arcade)



  • Salut à tous, alors :

    @voljega oui j'ai essayé mais ça ne fonctionne pas.
    @Kyo-Ni merci je vais tenter cela ce soir.
    @subs à priori c'est pas le format qui gène car j'ai lancé des jeux qui sont en 16/9 et eux aussi n'atteignent pas les bords de l'écran.

    En tout cas, merci pour vos réponses.



  • Il faudrait une photo de ton telephone et une capture par la commande raspi2png histoire de voir le pb



  • Bon..J'ai bien désactivé integerscale, j'ai bien un mieux, la bordure s'est rétrécie mais pas au point de toucher les bords haut et bas de l'écran.
    Je vous joints les images:
    1 2 3 4

    L'interface avec pixel perfect activée
    5 6

    Si vous avez des idées je suis preneur.



  • ton moniteur n'aimerait-il pas le 720p ? juste pour tester, essaie de mettre global.videomode=default dans le recalbox.conf (par defaut c'est CEA 4 HDMI)



  • @subs je teste ça ce soir.
    Ce qui me rend fou c'est qu'avec la version 3 de recalbox, l'overscan fonctionnait parfaitement.



  • @akh150 il me faudrait aussi ton /boot/config.txt



  • Mais le problème c'est que tu actives l'overscan car il manque un bout de l'image en haut et en bas de l'écran avec les réglages par défaut?



  • @Akik oui



  • @akh150 Donc c'est un problème de réglage de ta TV. Je l'ai eu aussi sur ma Bravia. Quelle est la marque de ta TV ?



  • @subs en mode global.videomode=default y a du mieux, il me reste encore une bordure en haut et en bas, mais c'est déjà mieux.
    voici le config.txt : ici
    et voici 3 screenshots avec l'évolution, le screen de droite étant en global.videomode=default : ici
    @Akik c'est unt toshiba, et ça me fait exactement la même chose sur une samsung smart tv. Du coup, y a quoi comme réglages à faire?

    Si vous ne voyez pas d'autres solutions, je me satisferais parfaitement de cela, et merci encore pour votre aide.



  • @akh150 Pour la TV Samsung il faut brancher ta recalbox sur le port HDMI/DVI dans un premier temps. Une fois que c'est fait tu as la possibilité de choisir le type de source qui est branché dessus. Il faut que tu choisisses "PC" et tu devrais avoir l'affichage complet.
    Teste cette première solution et fais nous un retour. Merci

    ps: n'oublie pas de reconfigurer ta recalbox d'origine pour les paramètres vidéo.



  • c'est quoi ce config.txt tordu ???



  • @subs c'est à dire?



  • des options ui n'ont rien à faire dans un config.txt genre global.integerscale
    Et des valeurs qui ne servent à rien
    Vire tout ce qui a le mot overscan de ton config.txt



  • Bon j'ai tout enlevé du config.txt. Pas de changements.
    Au final, la configuration qui me va le mieux est de mettre global.videomode=default.
    Il me reste une légère bordure mais ça me va.

    En tout cas merci beaucoup pour votre aide.


Log in to reply
 

Want to support us ?

Join us on :

160
Online

28897
Users

14663
Topics

110813
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.