[Résolu] Plus aucun jeu ne se lance



  • Bonjour tout le monde. Ça fait un mois à peu près que j'ai acheté mon matériel et que j'ai installé ma recalbox. Jusqu'à aujourd'hui, je ne jouais qu'au clavier. Puis j'ai découvert le virtual gamepad. J'ai joué une petite heure avec en solo et en multi et je suis allé voir si je pouvais éditer mes touches... Je les ais éditées, le Gamepad marchait très bien dans le menu. Je lance un jeu et là paf : plus rien, l'émulateur charge, écran noir et je reviens au menu. J'ai essayé tous les émulateur : rien a faire !!! J'ai cherché sur les forum, internet... Rien ! Je ne sais pas si le problème vient du virtual gamepad mais je sais qu'avant que je l'utilise, ça ne me l'avait jamais fait. J'ai essayé tout ce qui était possible dans les options mais : rien de rien. Précision sur mon matériel : raspberry pi model b, recalbox 4.0.0 pas d'overclock, carte sd 64g. Je sais que les forums sont des endroits où se produisent des miracles. je vous remercie d'avance.



  • <mode Jésus on>
    tu peux te connecter en SSH, lancer /etc/init.d/S31emulationstation restart, garder ton putty ouvert, lancer un émulateur et me mettre le message d'erreur ? (tout ce qui concerne LC_ALL, n'est pas utile poru le diagnostique)



  • Merci beaucoup jésus, tu es mon sauveur : je fait ca tout de suite et je t'envoie le message d'erreur.



  • Voilà le message d'erreur du terminal.

    # lvl0: 	System "favorites" is missing name, path, extension, or command!
    Traceback (most recent call last):
      File "/var/jenkins_home/workspace/recalbox-rpi2/output/target/usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 136, in <module>
        args.p5index, args.p5guid, args.p5name, args.p5devicepath)
      File "/usr/lib/python2.7/site-packages/configgen/controllersConfig.py", line 68, in loadControllerConfig
        controllers = loadAllControllersConfig()
      File "/usr/lib/python2.7/site-packages/configgen/controllersConfig.py", line 35, in loadAllControllersConfig
        tree = ET.parse(esInputs)
      File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1182, in parse
        tree.parse(source, parser)
      File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 656, in parse
        parser.feed(data)
      File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1642, in feed
        self._raiseerror(v)
      File "/usr/lib/python2.7/xml/etree/ElementTree.py", line 1506, in _raiseerror
        raise err
    


  • C'est bon : problème résolus, on a trouvé la mauvaise configuration du virtual gamepad : je l'avais configuré deux fois, une première fois sans erreur mais impossible d'utiliser la hotkey, je l'ai reconfiguré une deuxième fois, je me suis trompé et je n'arrivais plus a quitter. Et c'est donc la deuxième config qui se trouvait dans le dossier si dessous qui n'allait pas. merci beaucoup subs (quand je parlais de miracles j'avais raison!).
    ~/.emulationstation/es_input.cfg

            <inputConfig type="joystick" deviceName="Virtual gamepadZ&#01;" deviceGUID="03000000030000000300000002000000">
                    <input name="a" type="button" id="1" value="1" code="305" />
                    <input name="b" type="button" id="0" value="1" code="304" />
                    <input name="down" type="axis" id="1" value="1" code="1" />
                    <input name="hotkey" type="button" id="6" value="1" code="314" />
                    <input name="left" type="axis" id="0" value="-1" code="0" />
                    <input name="pagedown" type="button" id="5" value="1" code="311" />
                    <input name="pageup" type="button" id="4" value="1" code="310" />
                    <input name="right" type="axis" id="0" value="1" code="0" />
                    <input name="select" type="button" id="6" value="1" code="314" />
                    <input name="start" type="button" id="7" value="1" code="315" />
                    <input name="up" type="axis" id="1" value="-1" code="1" />
                    <input name="x" type="button" id="3" value="1" code="308" />
                    <input name="y" type="button" id="2" value="1" code="307" />
            </inputConfig>
    

Log in to reply
 

Want to support us ?

Join us on :

363
Online

29847
Users

14893
Topics

112150
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.