Problems with Metal Slug 3

  • Hi all I've read about other people have issue with Metal Slug 3. Searched for a solution i've tried some fix but nothing make this game work, searched some other thread here not find one for this game in international forum, btw sry if this is a copy thread
    I use a Rasperry Pi3vB Recalbox 4.00 build 170
    I ve tried Different Roms, all working with Kawaks on win, and tried different bios.
    Other Metal Slug game of serie work like the 4 and 5, but not the Third
    Ive tried Unibios replacing the file in original Bios... other game fine not MS3
    I tried Neogeo Fba and FBA liberetro emulators and it start only in Fba and NeoGeo with fba2x core, but in FBA start a Grid like Hatch comparison, and in NeoGeo the game start but is ALL glitchy like squares and impossible to use..
    Ive tried the solution with replacing a file in original rom.. no way
    The fun fact is the the bootleg rom work fine not the original game...
    I've read of someone get the solution, and keep a modified rom working, im curious and i love Metal slug serie if someone can help me i appreciate a lot
    Thanks for help and sry for my bad english

  • Banned

    @kurra please read the two arcade pages on the wiki.

  • Honestly i've read the whole two pages, but i've not seen anything useful to solve my problem with this specific rom, i got 80% of those pages..
    All other like 20 roms (cps2/neogeo) i tried work, some with one emulator, certain with other one...
    I've read somwhere but i think in this forum a solution based on replace some file in the original rom with some of bootleg rom but now i cant find that post..

  • Banned


    I'm gonna make it even easier : please re-re-read the first arcade page and pay a little, just a little attention to the part where romset versions are specified.

    Your reference to "I ve tried Different Roms, all working with Kawaks on win, and tried different bios" shows pretty clear that you didn't read the wiki too much or you would know what to do and that Metal Slug 3 works perfectly on a Pi3 with FBA_libretro if you have the right version.

  • Where it talk about romset? ok read about it, but i had just single rom downloaded, and all work except on.. btw problem gone, the rom work nice in neogeo emulator with mame078 core, the problem was rom start with red screen and green one a bit glichy, and take like 15 second more then other core, and i supposed not work...
    My curiosity persist on why all Metal Slug series ( run well with default core except MSlug3, it has something different?
    Btw thanks for help hope this post can be useful for someone else who got same issue

Log in to reply

Want to support us ?