Image tronquée en haut et en bas



  • Bonsoir à tous ! Après moult essais infructueux, je me résous à lancer un appel au secours ! J'ai remarqué en jouant à Tetris GB qu'il me manquait quelques lignes en bas de l'écran... En y regardant de plus près, même chose en haut... Je teste Super Mario Land GB, même topo... Je me dis alors qu'il y a un souci avec l'émulateur GB, je fais des essais avec d'autres jeux sur d'autres supports, et y regardant de plus près, le problème se retrouve sur tous les jeux, de la GameBoy à la Playstation ! J'entre dans le panneau de configuration RetroArch : Options > Video Option > Custom Ratio. Je change la définition qui est par défaut de 960x720, à 960x684 (il me manque exactement 18 pixels en haut et autant en bas). Je vérifie que j'ai bien activé "Configuration Save on exit", c'est bon, je quitte RetroArch, je relance un jeu, et... retour à la case départ ! C'est grave docteur ? Que dois-je faire ? Est-ce que ça vient de ma télé ? En activant l'overscan dans EmulationStation effectivement le problème est réglé, mais c'est plus que radical, cela ajoute de bonnes grosses marges de chaque côté... Un grand merci d'avance à ceux qui prendront le temps de me lire et de me répondre 😉



  • Peut-être en jouant sur les lignes

    overscan_top=16
    overscan_bottom=16
    

    du fichier config.txt


  • Staff
    Developer
    Global moderator
    Team

    Salut, trois solutions : Sois tu active l'overscan, comme le dis iMaster tu peux faire des réglages fins dans config.txt. Sois tu va dans le menu de ta tv, et tu cherche "Afficher tous les pixel" ou "1:1" ce qui te permet d'avoir toute l'image. Si dans emulationstation tu as toute l'image mais pas dans les jeux sans l'overscan, troisième solution, tu change le hdmi mode dans recalbox.conf



  • Merci pour vos réponses ! Effectivement dans EmulationStation j'ai toute l'image mais pas dans les jeux sans l'overscan. J'ai essayé de changé le HDMI mode dans recalbox.conf, en 4 et en 5, mais ça ne change strictement rien... Sur ma TV je n'ai pas l'option dont tu parles... Il me reste qu'à essayer de modifier config.txt, mais ça me fait un peu peur !



  • Si tu as peur de faire une bêtise tu peux toujours copier config.txt quelque part pour avoir un fichier valide en sauvegarde. Je te conseille aussi de passer les lignes en commentaires et de les copier du style:

    #overscan_top=16
    #overscan_bottom=16
    overscan_top=20
    overscan_bottom=20


  • Merci pour tes conseils 🙂 Je tâcherai d'essayer ça demain !



  • Après plusieurs tests, je n'y comprends plus rien, je ne saisis pas la logique... J'ai donc rétabli les valeurs d'origine pour l'instant. De plus, si je comprends bien, d'une TV à une autre les réglages sont perdus, n'est-ce pas ? Juste une petite question : à quoi correspond "overscan_scale" ?



  • Trouvé ici: http://elinux.org/RPiconfig

    overscan_scale=1 caused the output of openFrameworks to respect the overscan_left, overscan_right, top and bottom settings with the use of an LCD display connected via composite.



  • Ok merci, donc aucun intérêt pour ma connexion via HDMI.


  • Staff
    Developer
    Global moderator
    Team

    Sinon tu peux changer le video mode et mettre du 1080p pour tous les jeux.



  • Via le fichier config.txt ou par un autre moyen ? Je suis justement en train d'explorer les options de ma TV pour trouver une solution, mais pour l'instant je suis bredouille...



  • Si tu as une télé Samsung tu peux essayer de te brancher sur la prise HDMI portant l'indication dvi puis aller dans les options des sources dans les réglages. Là sélectionnes l'entrée HDMI en question, renommes la et choisis PC dans la liste de presets proposés. Édit: chez moi avec ce réglage de télé full screen, overcan désactivé et les réglages par défaut de la recalbox.



  • Je suis sur une Sony Bravia, je vais tenter ce que tu dis ! Au passage, Recalbox m'en fait apprendre sur ma TV : j'ai découvert la norme HDMI-CEC, ma TV ayant 5 ans je ne pensais pas l'avoir, eh bien si ! Du coup je peux contrôler Kodi avec la télécommande de la TV, c'est GE-NI-AL !



  • OK si tu trouves les réglages sur ta télé fais nous en profiter ça servira sûrement à d'autres.



  • J'ai trouvé la solution ! C'est ce que disait Retroboy depuis le début ! Le problème est que lorsque la TV affiche l'image de la Recalbox, contrairement aux autres entrées (TV, Décodeur...), je ne peux pas accéder au menu normal et donc à l'ensemble des paramètres. Pour cela, il faut passer par le menu Bravia Sync (touche idoine de la télécommande) > Commande TV > Accueil (Menu) > Réglages > Affichage > Commande écran ; puis désactiver le Format Auto, désactiver la Zone d'affichage automatique et configurer la Zone d'affichage sur "Tous les pixels", comme cela a été dit plusieurs jours auparavant 🙂 Etrange tout de même qu'on ne puisse pas accéder simplement au menu et qu'il faille passer par Bravia Sync, mais bon, je ne me plains pas, cela est maintenant réglé ! Le top du top maintenant ce serait que je puisse démarrer le Rpi2 depuis la télécommande de ma TV, mais là je crois je rêve 😄 Le CEC a ses limites !



  • Bonjour, je cherche à régler le format de mon image qui est tronqué que ce sois le menu recalbox ou bien dans les jeux.Elle est coupé à gauche /droite et haut/bas. Je précise que je sort en rca, sur une tv cathodique de 80cm. J'aimerai au pire le faire à la mano,dans le fichier config.txt mais le probleme c'est que je ne sais pas quel valeur mètre,plus grosse,plus petite? Bref un petit peu d'aide svp,merci!



  • Je ressort mon sujet car personne n'a voulu m'aidé à mon probleme... Personne à ce probleme sur un écran cathodique ? Comment gérer le réglage? Merci!



  • As-tu tout essayé dans les réglages de ta TV ? Vois dans le fichier recalbox.conf s'il ne faut pas changer le videomode.



  • Oui mais c'est une 80cm Sony cathodique et il y a juste 16/9 ou 4/3 comme réglage...ou sinon je vois pas où c'est? c'est un modèle trinitron..




Log in to reply
 

Want to support us ?

227
Online

82.0k
Users

22.5k
Topics

163.0k
Posts