Recalbox 7.0

[RÉSOLU] Ecran noir au premier démarrage



  • Bonjour, Je viens d'essayer d'installer votre distribution sur ma raspberry pi rev B. Celle-ci est branchée à l'écran à l'aide d'un adaptateur HDMI (pour la rasp) --> DVI (Pour l'écran). avec clavier+souris, ethernet branché et Alim of course. 1er boot tout se passe bien, je me retrouve sur noob, lance l'installation et il ne semble pas y avoir d'erreur. Noob me prévien que l'OS est bien installé, je valide et BOOM, écran noir. Je redémarre et de nouveaux écran noir. j'ai bien essayé d'allez par la suite dans les fichier de config et de dé-commenté une ligne sans résultat. J'ai aussi essayé d'appuyé sur les touche 0 puis 1 puis 2 pour voir si ça changeait quelques chose (comme indiqué dans le readme de l'archive) mais non. Je m'oriente donc vers vous afin de trouver une solution. En vous remerciant par avance. Mathieu


  • Developer
    Global moderator
    Team

    Salut Mathieu et bienvenue. Edite le fichier config.txt a l'aide de noob et commente la ligne hdmi_drive=2 Cette ligne force le mode HDMI, et permet d'avoir le son sur toutes les TV. Je dois donc la laisser, mais tu peux la modifier pour le cas de l'utilisation avec le DVI.



  • Merci Retroboy, N'y a pas moyen d'avoir les deux configuration dispo directement, car je vais être amené à jouer soit sur DVI soit sur HDMI, c'est embêtant de modifier le fichier à chaque fois. En tous les cas je fais la modification ce soir au retour du boulot ! Encore merci pour la rapidité !


  • Developer
    Global moderator
    Team

    Non il n'y a pas moyen sinon ca serait déjà comme ca. Si on enleve la ligne HDMI_DRIVE=2 il n'y a pas de son sur beaucoup de tv hdmi.



  • D'accord. En tout cas merci pour le boulot !



  • Bonsoir, Même pb que mth.richer, mais pas résolu. Je suis par contre en hdmi sans adaptateur. Ecran noir au démarrage, malgré les bidouilles dans le fichier de config. Une idée ? Merci beaucoup !



  • Ah, et petit détails, je suis sur un raspberry v1 avec une SD de 4Go. Help


  • Developer
    Global moderator
    Team

    Salut, Alors essaie les options proposés sur http://elinux.org/RPiconfig#Video_mode_options Surtout hdmi_safe=1 pour voir si tu as une image. Commente toutes les autres options qui concernent la video (hdmi_*)



  • Ok j'essaye ça ce soir !



  • Je viens de tester la config ci-dessous, pas mieux... je commence sérieusement à désespérer... # uncomment if you get no picture on HDMI for a default "safe" mode hdmi_safe=1 disable_overscan=1 # uncomment to force a specific HDMI mode (this will force VGA) #hdmi_group=1 #hdmi_mode=1 # comment to get jack audio #hdmi_drive=2 config_hdmi_boost=0 #hdmi_force_hotplug=0 # uncomment for composite PAL #sdtv_mode=2 # Overclock gpu_mem=256 avoid_safe_mode=1 kernel=zImage # NOOBS Auto-generated Settings: #hdmi_force_hotplug=1 config_hdmi_boost=4 overscan_left=24 overscan_right=24 overscan_top=16 overscan_bottom=16 disable_overscan=0



  • Hello, Tout d'abord félicitations pour ce projet très ambitieux qu'il me tarde d'essayer ! Félicitations également pour votre site qui envoie du pâté. 😉 Je suis dans le même cas que Kawaikiwi. J'ai un Raspberry Pi 1 et je suis connecté en HDMI sans adaptateur sur ma TV full HD. J'arrive bien à installer l'OS mais une fois arrivé à 100 (ou au redémarrage), j'obtiens un écran noir. J'utilise une alimentation de bonne qualité. Avez-vous trouvé une solution ? Je vais continuer d'essayer différents réglages en suivant aussi le lien RPiConfig mais pour le moment c'est sans succès malgré pas mal de modif du fichier config... J'ai essayé la dernière release et celle d'avant : même résultat. A +, Adrien



  • Pour compléter mon précédent message : Je viens ce soir encore de faire quelques tests. J'ai réussi à arriver sur la page d'accueil de RecalBox en réinstallant l'OS depuis le SafeMode en dé-commentant le hdmi_safe (bizarre, j'étais pourtant sûr d'avoir essayé cette config). Je navigue dans les paramètres avec ma manette et choisi la langue Français, le système me demande de redémarrer et là, plus d'image. Je redémarre en Safe mode, je vérifie que hdmi_safe est toujours uncomment et c'est bien le cas... Donc normalement, à part pour la langue, la config n'a pas bougé. J'avoue ne pas comprendre. Je viens de réessayer la ré-install à partir du safemode et l'uncomment de la ligne hdmi_safe mais pas d'image. J'avoue ne plus rien comprendre. D'autres pistes avant de jeter ma TV par la fenêtre ? ^^ EDIT : Je viens de tester en HDMI avec un moniteur PC = Même résultat. Vous pensez que le problème vient de mon Raspberry Pi ? De ma carte SD (Samsung SDHC 10 16Gb)?



  • Bon bah désolé des deux premiers commentaires dans le vent... Je viens de trouver l'origine de mon problème : Ma carte SD. En testant avec une autre, tout fonctionne niquel. La carte SD qui pose problème est une samsung 16 Gb SDGC classe 10 (modèle MB-SPAGA). Au cas où d'autres personnes ont ce genre de souci. A + !



  • Désolé, erreur de post. MIRABO



  • Pour info aussi j'avais une carte de 64GB Samsung Extreme plus SDXC et elle ne fonctionne pas non plus. J'ai mis une SDHC et la niquel !



  • Salut à tous, j'ai le meme problème que décrit ci-dessus. Quand je branche ma recalbox sur la tv aucun problème, par contre en la connectant à un écran DVI par un adaptateur hdmi -> dvi, au démarrage j'ai un affichage avec toutes les couleurs pendant une fraction de secondes, puis plus rien. J'ai cherché ou éditer comme c'est écrit mais je ne trouve pas la ligne EDIT: j'ai créé un autre sujet, celui-ci étant signalé comme résolu 😄 http://blog.recalbox.com/forums/topic/probleme-avec-ecran-dvi/


Log in to reply
 

Want to support us ?

111
Online

79.1k
Users

20.3k
Topics

149.0k
Posts