Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Raspberry Pi 3/Recalbox wi-fi : "erreur de configuration wifi"



  • Bonjour, J’obient le message "erreur de configuration wifi" avec le Wi-fi intégré du Raspberry Pi 3 et ma Livebox Play. La connexion ne se fait pas. Parfois j’ai un pop-up qui me dit qu’il y a une erreur de connexion sinon rien à part “disconnected”. Parfois, il y a “disconnected” avec en plus une adresse IP en IPV6. Je ne sais pas d’où elle sort… Quelqu’un peut m’aider ?   Merci



  • Hello ton réseau wifi utilise quel mode de sécurité ? quel canal ? Perso, sur freebox revilution + module wifi embarqué dans le rpi3, impossible de me connecter sur le canal 13 (choisi quasi systématiquement par le mode auto des freebox). Je dois donc basculer manuellement sur un canal entre 8-10 pour être tranquille.



  • Je suis en canal manuel 10 et mode de cryptage WPA/WPA2 Mixed.



  • SAlut tt le monde,

    je ne parviens pas à me connecter au wifi depuis recalbox
    je rentre manuellement ssid et clé alphanumérique mais rien ne se passe.
    il n'y a pas d'autodetection du réseau wifi?
    tt marche parfaitement en rj45 evidemment mais lorsque je debranche le cable et active wifi, ras, mode déconnecté.
    Je dois mal m'y prendre qq1 aurait il une astuce?
    merci d'avance



  • @petitnicolas evite le wpa, chez moi il n'a jamais marché avec le wifi du pi3

    @boulococo il nous faut les memes infos que demandé plus haut : quel canl, quelle sécurité



  • @subs pas de WPA ? C'est peut-être pour ça que le wifi de mon pi3 ne fonctionne pas. Il me semblait pourtant qu'il ne supportait pas le WEP.

    Chez moi je suis en WPA (TKIP) sur le canal 11 et j'ai le même problème. Et j'ai la flemme de changer la sécu du wifi et de devoir modifier tous les autres systèmes connectés en wifi chez moi... :p



  • @Nalkozz ni wep ni wpa ;)
    Ta flemme va priver ta recalbox de wifi ... Donc de ssh, de mises à jour, de transfert de données par reseau ... :P



  • @subs RJ45 ! Y a juste le câble qui traîne par terre quoi... ;)
    Ce qui m'embête le plus, c'est que quand j'aurais terminé mon bartop, je n'aurais plus les mises à jour auto de Recalbox. À moins de laisser traîner un RJ45 entre le bartop et la box... ^^"

    À l'époque où j'étais sous Retropie (y a un mois environ, avant que Retropie foire totalement et que j'ai du tout recommencer...), le wifi avait fonctionné en faisant "aptitude upgrade" et "aptitude update" (une maj des paquets de raspbian quoi, vu que Retropie est basé dessus). Si ça peut donner une piste d'upgrade de Recalbox ^^

    Du coup, quelle est la sécurité à mettre pour que le wifi fonctionne ? Parce que j'ai pas des masses de possibilités : WPA (AES/CCMP), WPA (TKIP+AES), WPA (TKIP) ou WEP...



  • Alors que retropie est un plugin sur raspbian, la vision de reclbox est complètement differente. Nous sommes un linux built from scratch, que nous parametrons nous-mêmes, qui est compilé de 0. Donc pas de apt chez nous.

    Pour les niveaux de sécurité gérés, peut etre que ca évoluera avec la version 4.1 puisque le gestiinnaire de connexions est changé.

    Pour le moment, je ne peux meme pas te dire quelles sécurités marchent. On conseille de passer en wpa2 parce que ca marche (j'en ai fait l'expérience moi-même)



  • sur freebox v6 le WPA2-PSK/TKIP fonctione tres bien avec ma pi3.
    test avec ton telephone par ex si tu as un android tu le met en point wifi avec le meme chryptage et tu test voir si la pi3 se connecte .
    après je vais faire mon pessimiste mais c'est une livebox :) :) y a souvent des bug avec cette box sur tout et n'importe quoi .

    test deja le tel et tiens nous au jus



  • j'avais aussi un probleme avec une freebox mini 4K je suis passer en WPA2-PSK/AES et Canal 10 et maintenant ça fonctionne grace a subs



  • @subs Aaaah merci, je sais enfin pourquoi pas d'apt, de sudo ou quoi ;) Continuez comme ça alors, je trouve Recalbox plus stable et plus performant que retropie. Sans doute grâce à la surcouche en moins ^^

    On verra sur la 4.1 si j'ai besoin de changer la sécu de ma connexion ou pas alors. Sauf qu'en fait j'ai pas d'option WPA2, donc je vais rester avec mon câble qui traîne pour l'instant :p





  • @spriggan59 Je suis sur une freebox crystal ;) C'est petitnicolas qui est sur une livebox play :)



  • @Nalkozz , j'avais exactement le meme probleme que toi et je viens de trouver la solution. J'ai aussi une freebox crystal. Par defaut elle est en IP V4 et il faut la passer en IP V6 pour pouvoir etre connecté avec recalbox sur le raspberry pi 3.
    Pour cela il faut aller dans ton espace abonné freebox. Tape ton identifiant et mot de passe freebox. Ensuite clique sur l'onglet ma freebox puis sur le lien passer au protocole ip v6 et là deplace le curseur sur activé pour l'IP V6. Et voilà! pas besoin de changer de sécurité à mon avis!



  • Après il n'y a plus qu'à allumer la recalbox. J'avais déjà configuré le menu option reseau avec le nom du reseau ssid et le mot de passe clé wifi dans recalbox. Une fois configuré ca devrait être noté "connecté" avec une adresse ip du type 1.192.168.0.11.
    Pour transferer les jeux depuis un pc sous windows 10 je vais dans l'explorateur et je tape http://recalbox et après il n'y a plus qu'à envoyer les roms vers les emulateurs.



  • Pas mal, en IPv6 mon pi est connecté au wifi avec ta méthode ! Le seul hic, c'est que j'ai bien le partage samba, mais pas le ssh.
    Comme pour l'instant je n'ai plus d'affichage sur ma Recalbox (problème d'écran ou d'adaptateur hdmi > vga), je ne sais pas d'ou ça pourrait venir. Avant le reboot après avoir débranché le rj45, le ifconfig me montrait que des bonnes choses pourtant. Voilà ce que j'ai dans recalbox.log quand je boot sans le rj45 :

    udhcpc (v1.24.1) started
    Sending discover...
    Sending discover...
    Sending discover...
    No lease, failing
    ---- recalbox-config.sh ----
    [ 27.94] : wlan0 be used as wifi interface
    [ 28.05] : starting wifi
    udhcpc (v1.24.1) started
    Sending discover...
    Sending select for 192.168.0.15...
    Lease of 192.168.0.15 obtained, lease time 864000
    deleting routers
    adding dns 212.27.40.240
    adding dns 212.27.40.241
    inet addr:192.168.0.15 Bcast:192.168.0.255 Mask:255.255.255.0
    [ 32.14] : Starting S92switch
    [ 32.15] : script /recalbox/scripts/powerswitch.sh [ STARTED ]
    [ 32.40] : Starting S94manager
    Will not start pm2 : system.api.enabled is set to 0

    Donc tout se passe bien pour le wifi : démarrage, bail dhcp, dns...



  • Je double post pour la bonne cause : j'ai mon ssh maintenant :) Le service a mis 10 minutes mais maintenant c'est bon, j'ai tout (le ssh et samba, juste ce que je demande quoi) !

    Merci @tod59 pour l'astuce ;)



  • as tu testé depuis un tel portable en point wifi si ca marche ?
    il se peut aussi comme une Wii que le canal wifi doit etre sup à 10 , oui un Wii sur le canal 2 par ex marche pas
    au dessus de 10 plus de soucis :)



  • Bonjour, du nouveau sur le Wifi ?

    J'ai également le même problème, et pourtant tout mes équipements se connectent sans problème, y compris le rpi3 sous Raspbian. Le problème vient donc logiquement de Recalbox.

    Peut-on espérer que la fameuse MaJ 4.1 règle ce problème ? La connexion ethernet c'est sympa, mais moins pratique, quand-même.

    Au cas où ça aide quelqu'un, ma configuration wifi :

    Livebox (dernière version)
    Wpa 2 mix (Tkip et Aes)
    En ipv6 et 5Ghz
    J'ai essayé plusieurs canaux, aucune différence. De toute façon, Raspbian détectant ma config sans changement, le matériel est donc forcément compatible avec cette dernière. Reste à trouver ce qui coince sur Recalbox :/



Want to support us ?

399
Online

59107
Users

18465
Topics

138832
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.