Installation EmulationStation pour Windows



  • edit : la solution a été de tout réinstaller et je retrouvé le tuto qui m'avait servi la première fois à cette adresse. Bonjour, Pour mon problème il ne s'agit pas de recalbox sur Raspberry Pi, mais de l'installation d'EmulationStation sur Windows. Je vous demanderais de bien vouloir être tolérant envers ce petit "Hors sujet" car le forum officiel d'Emulationstation est complètement envahi par le spam et est inexploitable. En plus ici le forum est francophone ce qui est bien plus facile pour expliquer mon problème. Je suis sur windows 10 x64 et j'ai formaté mon PC il y a 2 jours. J'ai réinstallé à nouveau Windows 10 x64. Maintenant que mon système est clean, et que tous les programmes sont installés, j'aimerais réinstaller EmulationStation, mais le plus simplement possible : en copiant mon dossier précédemment sauvegardé ! J'ai donc téléchargé ES depuis le site officiel et installé dans le répertoire par défaut : C:\Program Files (x86)\EmulationStation Lorsque je le lance la première fois, il me met un message d'erreur, ce qui est la procédure normale, et il me copie à ce moment 1 dossier et 2 fichiers de config dans le répertoire : C:\Users\MonPseudo*.emulationstation* Seulement, mon système Windows installé sur C: est sur un SSD sur lequel je n'ai pas la place d'installer la totalité des roms, etc. (J'avais précédemment sauvegardé mon dossier .emulationstation et il fait 50Go). Dans ma précédente installation, le dossier .emulationstation était placé sur un autre disque, un SSD D: pour le jeu qui lui a la place pour accueillir ces 50Go. J'ai donc copié l'intégralité de mon dossier précédent .emulationstation dans D: , puis j'ai créé un lien symbolique (avec un logiciel, j'ai l'habitude de faire ainsi) de manière à faire apparaître le dossier D:*.emulationstation* dans C:\Users\MonPseudo*.emulationstation* Le résultat, comme vous pouvez le voir dans cette capture, c'est que quand je me rends à l'adresse C:\Users\MonPseudo*.emulationstation* je retrouve bien l'intégralité de mon dossier .emulationstation J'ai donc pu recréer la copie parfaite de ma précédente installation.   Je récapitule :

    • Le logiciel Emulationstation est installé dans son répertoire par défaut C:\Program Files (x86)\EmulationStation
    • Le dossier .emulationstation est physiquement présent sur le disque D:*.emulationstation*
    • EmulationStation a créé lui-même le répertoire C:\Users\MonPseudo*.emulationstation*, puis je l'ai remplacé par un lien symbolique qui amène au bon endroit l'intégralité de mon répertoire précédemment sauvegardé.

    Je pensais avoir bien fait en faisant ainsi, ça m'évite de tout refaire l'installation des émulateurs et des configs manuellement, seulement ça ne fonctionne pas. Cela dit, je crois qu'avant c'était la même chose, je me souviens que je ne devais pas lancer l'exécutable de Emulationstation.exe, mais un fichier startemulator.cmd situé dans .emulationstation\Emulators et j'ai bien ce fichier mais il ne lance rien du tout. Voici le contenu de ce fichier batch si ça parle à quelqu'un :

    @echo off FOR /f "tokens=" %%D IN ('dir /b "%~dp0AutoHotKey"') Do (set AUTOHOTKEY="%~dp0%%D") if "%1"=="nes" goto :RETROARCH if "%1"=="snes" goto :RETROARCH if "%1"=="n64" goto :RETROARCH if "%1"=="gc" goto :DOLPHIN if "%1"=="wii" goto :DOLPHIN if "%1"=="gb" goto :RETROARCH if "%1"=="gbc" goto :RETROARCH if "%1"=="gba" goto :RETROARCH if "%1"=="nds" goto :RETROARCH if "%1"=="psx" goto :RETROARCH if "%1"=="ps2" goto :PCSX2 if "%1"=="psp" goto :PPSSPP if "%1"=="atari2600" goto :RETROARCH if "%1"=="gamegear" goto :RETROARCH if "%1"=="megadrive" goto :RETROARCH if "%1"=="dreamcast" goto :DEMUL   exit /b %ERRORLEVEL%   :DOLPHIN start "autohotkey" /d %AUTOHOTKEY% "AutoHotKey.exe" Mouse.ahk FOR /f "tokens=" %%D IN ('dir /b "%~dp0dolphin"') Do (FOR /f "tokens=" %%A IN ('dir /b "%~dp0%%D\Dolphin.exe"') DO ("%~dp0%%D%%A" /b /e %2)) goto :EXIT   :PCSX2 start "autohotkey" /d %AUTOHOTKEY% "AutoHotKey.exe" PCSX2.ahk FOR /f "tokens=" %%D IN ('dir /b "%~dp0pcsx2"') Do (FOR /f "tokens=" %%A IN ('dir /b "%~dp0%%D\PCSX2.exe"') DO ("%~dp0%%D%%A" %2 --fullscreen --nogui)) goto :EXIT   :PPSSPP start "autohotkey" /d %AUTOHOTKEY% "AutoHotKey.exe" PPSSPP.ahk FOR /f "tokens=" %%D IN ('dir /b "%~dp0ppsspp"') Do (FOR /f "tokens=" %%A IN ('dir /b "%~dp0%%D\ppsspp64.exe"') DO ("%~dp0%%D%%A" %2 --escapeexitsemu --fullscreen)) goto :EXIT   :DEMUL start "autohotkey" /d %AUTOHOTKEY% "AutoHotKey.exe" Demul.ahk FOR /f "tokens=" %%D IN ('dir /b "%~dp0demul"') Do (FOR /f "tokens=" %%A IN ('dir /b "%~dp0%%D\demul.exe"') DO ("%~dp0%%D%%A" -run=dc -image=%2)) goto :EXIT   :RetroArch start "autohotkey" /d %AUTOHOTKEY% "AutoHotKey.exe" Mouse.ahk FOR /f "tokens=" %%D IN ('dir /b "%~dp0retroarch"') Do ("%~dp0%%D\retroarch.exe" -L "%~dp0%%D\cores%3" %2 -f) goto :EXIT   :EXIT taskkill /f /im AutoHotKey.exe exit /b %ERRORLEVEL%

    Voilà, à tout hasard est-ce que l'un d'entre vous saurait m'aider ? En attendant d'avoir ma recalbox j'apprécias l'émulation sur PC. Merci d'avance et encore désolé aux admins pour cet écart de la ligne du forum.


  • Moderator
    Team

    Bonjour oui effectivement totalement hors sujet....Mon instinct devrait fermer le sujet pour eviter d'avoir d'autres sujets de meme genre.4 J'ai pas de réponse à fournir.



  • Salut Actris ; bon, tu peux fermer le sujet :) Je vais faire une nouvelle install, ça va être un peu plus long que j'espérais :)


  • Moderator
    Team

    En effet nous ne pourrons pas trop t'aider sur ce sujet. Juste check peu être ton fichier es_systems.cfg dans /.emulationstation Aller je clos le sujet ;)


Log in to reply
 

Want to support us ?

Join us on :

370
Online

31156
Users

15125
Topics

113811
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.