Affichage sur TV impossible avec WinSCP



  • Bonjour,
    Recalbox '7.1.1 Reloaded' est installé sur PC (Samsung 17" - Intel-Core à 2,5Ghz – 64 bits / 6Go RAM / Chipset Graphics Intel HM76 / Résolution 1600 X 900 – Windows_8) mais impossible de l'afficher sur écran TV (Philips 119 cm). Depuis plusieurs semaines je cherche, j'essaie, je cherche,….bref, je ne fais que lire, pour rien.
    Ne connaissant pas grand-chose à l'informatique, je me suis lancé dans ce 'truc' SSH en installant 'WinSCP' et j'ai appliqué la procédure trouvée sur le Forum-Recalbox, ici: [https://forum.recalbox.com/topic/17875/recalbox-sur-pc-portable-vers-ecran-tve](url du lien).
    Lorsque j'ai enfin trouvé le fameux fichier 'xinitrc' ,j'ai pu le modifier comme indiqué, mais au moment de sauvegarder, BIM ! comme d'hab, y a un problème ! => j'ai ce message: "Copie du fichier 'C:\Users...............................\etc\X11\xinit\xinitrc' échoué" + au dessous: "scp: /etc/X11/xinit/xinitrc: Read-only file system"
    Alors que faire maintenant ?
    J'ai le sentiment d'être arriver au bout du chemin.
    Merci, au cas où...



  • salut,

    tu as probablement raté cette étape : mount -o remount, rw / puis executer

    C'est elle qui rend ton disque modifiable.



  • Merci yogi_om,
    Mais justement quand on est novice et que l'on essaie d'apprendre, on est assez vite désabusé (pour pas dire dégouté) car je m'explique:
    "Console' je savais pas ce que ça veut dire, et encore moins ou c'était. Alors, je n'ai pas pu le faire. Et comme dans le sujet qui m'a servi de base (Cf le lien) c'est pas du tout écrit (comme si c'était évident !) ben, on ne trouve pas....
    ET c'est vraiment, mais vraiment par grand hasard que j'ai trouvé cette "Console" ! Après encore beaucoup de temps pour comprendre le fonctionnement (merci le confinement !) j'ai donc pu saisir cette commande complète:
    mount -o remount, rw / puis executer
    DISPLAY=:0.0 xrandr puis executer

    Puis, cette fois j'ai pu taper et VALIDER cette ligne:
    xrandr --output LVDS-1 --off --output HDMI-1 --mode 1600x900 (donc sans le #), juste sous la ligne [# xrandr --output output_name --off ] Et c'est enregistrer.
    Mais grosse déception, car maintenant j'ai juste un écran-logo de 'Recalbox' qui s'affiche au démarrage puis écran noir.

    Je ne dois pas être loin de la solution mais je ne sais plus quoi faire.....

    en tout cas "yogi_om", bien vu ! c'était bien celà....même si au final ça ne règle pas le problème



  • @Patabar

    Cette résolution "batarde" est probablement celle de ton ordi, ta tv doit prendre du 1920*1080 non ?



  • (D'abord, merci pour ton aide hyper-rapide)

    En fait, dans la Console, j'ai copier/collé la commande mentionné dans l'autre sujet (https://forum.recalbox.com/topic/17875/recalbox-sur-pc-portable-vers-ecran-tv)=> DISPLAY=:0.0 xrandr puis executer ,
    et j'ai vu cette résolution en 1er. voilà pourquoi.
    Mais 1600X900 c'est mon PC (17 pouces).
    Et tu as raison, ma TV c'est 1920X1080.
    J'ai bien tout refait dans WinSCP mais.......Écran noir !
    Donc, je déprime...😕



  • Ce qui est bizarre, c'est qu'en allumant 'Recalbox', une séquence animée de Récalbox se lance quelques secondes ET ce n'est d'ailleurs pas la même séquence que les images sur le PC en même temps 😱 !
    Puis, sur le PC, dès qu’apparait l'écran blanc de "Chargement", ma TV devient noir.
    Comment est-ce possible qu'il y ait un affichage très temporaire et pas le même que sur le PC ?

    Merci pour essayer de me faire avancer....☺



  • tout simplement cet écran doit être envoyé à toute les sources. il faudrait que tu puisses lister les tiennes pour être sur que tu essayes bien d'activer la bonne.



  • Sans vouloir abuser de ton temps,
    pourrais-tu m'expliquer autrement (ou plus en détail) parce que là, je ne comprends pas:
    les sources ? c'est pas mon Pc ?
    Lister mes sources ? comment fait-on cela ?
    Activer la bonne ? ben, c'est ce que je croyais pourtant avoir fait avec WinSCP ?

    Où peut-être qu'au final, Recalbox n'est pas pour tout le monde, je peux l'entendre, parce que là je ne sais pas ce qu'il faut faire, et à par toi, y a quand même pas grand monde pour aider....donc, c'est que ça doit pas être simple

    Merci, si tu peux m'expliquer un peu plus où et comment je dois agir.....



  • @Patabar said in Affichage sur TV impossible avec WinSCP:

    DISPLAY=:0.0 xrandr

    disons que si tu tapes des trucs sans comprendre ce que tu fais ça ne peut pas marcher...

    si tu tapes xrandr tout seul il t'affiche une liste non ?



  • @yogi_om reprenons le topic que tu as utilisé ça sera plus simple...

    mount -o remount, rw / puis executer (pour avoir le disque en lecture/écriture facultatif pour le moment...)
    DISPLAY=:0.0 xrandr puis executer (voir ci dessous)
    Ça te donnera le nom de tes écrans et de voir les résolutions acceptées par chaque écran

    peux tu afficher la liste donnée par la commande ?



  • Salut 😀 ,
    Oui, c'est exactement ça, j'ai fait sans vraiment comprendre puisque je n'ai rien trouvé d'autre. mais depuis ton aide, je suis sage 🤗
    Alors, avec "DISPLAY=:0.0 xrandr", ça donne ça:
    WinSCP-(Screenshot).jpg

    Grace à tes éclaircicements, si je comprends bien, Dans LVDS1, c'est mon PC et en bas, dans 'HDMI1' c'est ma TV (d'où le format 1920X1080).

    (À noter que je m'étais permis de faire aussi avec "1280X720" dans le fichier xinitrc, mais sans résultat)



  • en complément, avec la modif de résolution faite hier :WinSCP-(xinitrc).jpg



  • @Patabar said in Affichage sur TV impossible avec WinSCP:

    Salut 😀 ,
    Oui, c'est exactement ça, j'ai fait sans vraiment comprendre puisque je n'ai rien trouvé d'autre. mais depuis ton aide, je suis sage 🤗
    Alors, avec "DISPLAY=:0.0 xrandr", ça donne ça:
    WinSCP-(Screenshot).jpg

    Grace à tes éclaircicements, si je comprends bien, Dans LVDS1, c'est mon PC et en bas, dans 'HDMI1' c'est ma TV (d'où le format 1920X1080).

    (À noter que je m'étais permis de faire aussi avec "1280X720" dans le fichier xinitrc, mais sans résultat)

    sauf erreur de ma part la sortie à activer c'est HDMI1 pas HDMI-1 non ? (donc remplace dans la ligne de commande que tu as tapé HDMI-1 par HDMI1)

    mount -o remount, rw / puis executer
    DISPLAY=:0.0 xrandr puis executer

    Puis, cette fois j'ai pu taper et VALIDER cette ligne:
    xrandr --output LVDS1 --off --output HDMI1 --mode 1920x1080

    et tu as raison LVDS c'est l'écran intégré à ton ordi portable (Low Voltage Display Screen)



  • Voilà, je viens de le faire mais ça ne fonctionne pas. voici les lignes de commande pour être sûr que je ne me suis pas trompé: WinSCP-03.jpg



  • puisque les images parlent mieux que les mots, voici concrètement ce qui se passe pendant la minute de chargement de 'Recalbox 7.1.1'

    WinSCP-04.jpg
    La séquence d'animation du départ n'est jamais la même sur la TV, puis dès "Chargement" (photo du milieu), c'est l'écran noir !

    (C'est d'ailleurs idem avec 'Batocera v30')



  • @Patabar said in Affichage sur TV impossible avec WinSCP:

    puisque les images parlent mieux que les mots, voici concrètement ce qui se passe pendant la minute de chargement de 'Recalbox 7.1.1'

    WinSCP-04.jpg
    La séquence d'animation du départ n'est jamais la même sur la TV, puis dès "Chargement" (photo du milieu), c'est l'écran noir !

    (C'est d'ailleurs idem avec 'Batocera v30')

    tu as bien pu sauvegarder tes modifs ?

    si tu tapes ça quel est l'affichage ? xrandr --prop

    ok je ne maitrise pas les commandes et je peux pas tester la tout de suite mais tu peux essayer la commande d'origine ?

    xrandr --output LVDS-1 --off --output HDMI-1 --mode 1920x1080 (qui est la commande d'origine normalement...)



  • Si c'est bien cela que tu m'as demandé de faire (?): WinSCP-05.jpg



  • Quand à la commande que tu m'indiques, c'est exactement ce que j'avais indiqué avant, donc j'ai remise à nouveau, mais toujours que la petite animation sur 10 secondes au début puis 'Pas Bon'....

    (et encore un peu merci pour ce temps que tu passes pour ça)



  • Et OUi, j'ai bien pu sauvegarder les modifs ( en cliquant en haut à gauche sur le bouton de la disquette 'Sauvegarder'). J'ai fermé puis re-ouvert et il y a cela:WinSCP-06.jpg

    NB: Je sais que je n'y connais rien mais en ajoutant la ligne au-dessous (en Bleu), il n'y a pas un double emploi avec celle au-dessus (En Vert)



  • @Patabar said in Affichage sur TV impossible avec WinSCP:

    Et OUi, j'ai bien pu sauvegarder les modifs ( en cliquant en haut à gauche sur le bouton de la disquette 'Sauvegarder'). J'ai fermé puis re-ouvert et il y a cela:WinSCP-06.jpg

    NB: Je sais que je n'y connais rien mais en ajoutant la ligne au-dessous (en Bleu), il n'y a pas un double emploi avec celle au-dessus (En Vert)

    le dièse met en commentaire une ligne et n'est donc pas interprété...
    Il faut que je fasse un test avec un portable chez moi avec recalbox, du réseau et de l'hdmi.
    J'essaye de bidouiller ça demain, ce soir je pourrai pas.


Log in to reply
 

Want to support us ?

233
Online

82.6k
Users

22.8k
Topics

164.4k
Posts