Incompatibilité entre core snes pour les sauvegardes



  • Bonjour
    On a le droit à un bon gros crash lorsque l'on essaye de lancer un jeu SuperNES avec le core snes9x si jamais ce jeu a déjà des sauvegardes (dans le dossier /saves) faites auparavant avec un autre core (snes9x2010 ou 2002)

    Pour étayer : je suis passer de RB6 à RB7 en changeant également de RPi3 à RPi4
    J'ai remarqué en lançant certains jeux qu'ils repartaient du départ, et pas de là où je m'étais arrêté (j'ai les sauvegardes auto activées), donc en clair le core par défaut de RB7.0.0 (qui était snes9x2002) ne peut pas charger mes sauvegardes faites avec RB6 (qui était en core snes9x2010)
    Jusque là, je me doute que c'est normal : un core ne peut pas forcément être compatible avec les fichiers "state" ou "state.auto" d'un autre)
    J'avais vu dans le futur changelog de RB7.0.1 que justement vous alliez passer de snes9x2002 à snes9x pour RPi4, donc je me suis dis que j'allais tester pour voir si les sauvegardes ne marcheraient pas avec celui-là (sait-on jamais)

    L'écran noir se lance, et plus rien. Impossible de revenir à ES avec les raccourcis manettes, obligé de tout redémarrer. (sous RB7.0.0, les boutons du Nespi4case ne répondaient pas non plus : arrachage de l'alim, même si c'est pas bien 😢 . Sous RB7.0.1, les boutons fonctionnent, c'est un moindre mal)
    C'est vicieux lorsqu'on a donc des "state.auto" car le jeu ne se lance même pas, mais c'est pareil si on essaye de recharger une vieille sauvegarde en cours de jeux : l'image se fige et plus aucune réaction

    Donc si jamais d'autres personnes font la bascule RB6 vers RB7.0.1 avec RPi4, il faut que soit vous supprimiez tous vos fichiers state et state.auto, soit changer le core par défaut (snes9x2010 marche bien sous RPi4) sinon vous allez avoir le même souci. En attendant peut-être une correction pour éviter le crash ? Ou bien passer RB7.0.2 en snes9x2010 par défaut ?

    Question subsidiaire : snes9x est mieux que snes9x2010 ?? Autant sur la version 2002 j'ai vu quelques glitchs, autant la version 2010 j'ai pas souvenir d'en avoir vu, et comme c'est la version par défaut sur RPi0/2/3...



Want to support us ?

407
Online

80.4k
Users

21.6k
Topics

157.8k
Posts