Superbly slow or black screen N64 emulation on old DELL Optiplex 755 with Dragonblaze 6.1.1

  • Hello all! thanks in advanced and for all the help you have already given me as i have lurked thought the forum for these problems.

    This is what I am working with:

    • Dell Optiplex 755 with a core 2 cpu and 8GB of RAM
    • No dedicated graphics card6.1.1 dragon blaze. x86_64 running off Flashdrive (SanDisk 32GB Cruzer Fit USB Flash Drive - SDCZ33-032G-G35)
    • connected to older HDTV with VGA
    • PowerA Mini xbox controler - (Wired USB)
    • Also have a keyboard, and second generic controller plugged in at the moment. All USB.

    My issue "simply" put is that i am not able to get any of the Nintendo 64 ROMs to work. I have tried a variety (Bomberman, Perfect dark, Crusin' USA, Mario Kart, chameleon twist, and various others) but most "testing" has been with Mario Kart 64 (because I can navigate it somewhat when there is no screen).

    I started with simply a black screen (honestly not sure if i had audio at the time, i was unaware).

    I followed the link in the readme ( and was able to determine that my TV (sucks) and only has the following options:

    tvservice -m DMT

    {"code":1, "width":1280, "height":1024 }

    tvservice -m CEA

    {"code":1, "width":1280, "height":1024 }

    Note: above is verbatim what I had (glad I took a photo), no multiple options, no additional information of ratio, clock or other fancy stuff.

    --------Red flag #1---------

    So i started poking around the config file, and long story short even after downloading a true text editor as suggested, when i make changes, sometimes they take, sometimes they do not. but end result when testing the emulator, was that I had made backwards progress. the game was now booting me out after a couple seconds (by this time i found out that the game, while in black screen, was playing in the background, as the audio would clue me in).

    Note: I also get mixed results when editing the config file though the "webpage" or whatever it is called when I type in the IP address and connect to the recalbox from chrome window. (as well as with a true text editor) and even thought the "console".

    -------- Red flag #2 ---------

    Today, i tried with a different monitor (old PC LCD), i did not take a photo, but i pretty much got the same single option for resolution outputs as above, but for some reason, when connected to the monitor, I was able to to see the game for the first time (only Mario Kart at this point). So i go back to the TV, and have the same results (good, i guess).

    I started poking/switching the emulators from the recabox itself (using the controller) since as mentioned above, i was having poor luck with saving the files: Question - should i re-boot when making changes? i mostly did, but am sure i did not some times. made a bunch of changes.

    Anyhow, we get to the point that when chaning the emulator (and core, but there is only one core per emulator) that i get the following results:

    Emulator: DEFAULT (MUPEN64PLUS)
    Core: DEFAULT (GLIDE64MK2)
    Result: The game exits virtually immediately. the GUI does that jumping into the screen thing, thinks about it for 2-3 seconds, and it then just brings me back to the game page.

    Emulator: MUPEN64PLUS
    Core: GLIDE64MK2
    Result: The game seems to run (I can hear it, it is at regular speed, I can even navigate some of the menus i remember) but i cannot see anything on screen.

    Emulator: LIBETRO
    Core: MUPEN64PLUS
    Result: The game boots, I have audio and video, but it lags a fantastical amount. For those of you familiar with Mario Kart 64, the opening sequence has the "Nintendo" logo spin as you hear cars race by. it takes 11 seconds per this YouTube video: It takes my set-up 1 minute and 50 seconds (ask me how i know 🙂 )

    So i am baffled that arguable 2 different settings (since "default" should behave as the same selection that is being forced to use) actually give me 3 different results (quite consistently as well, as i hopped around to make sure).

    So I'm going to say that is ---------- Red Flag #3-----------

    I think that completes my saga so far, any insight or suggestions would be appreciated as I cannot seem to make heads or tales here.

Want to support us ?