Reicast Dragonrise issue



  • Greetings everyone! Recalbox rookie here, looking to hopefully get some help.

    Raspberry Pi model: Pi 3b+
    Recalbox version (build) : 6.1.1 Dragonblaze
    Hardware: 64GB SDXC, 5V 2.5 A power supply
    Controller(s): 2 Dragonrise Generic USB
    Emulator: Reicast Sega Dreamcast Emulator
    Game: Jojo’s Bizarre Adventure

    The issue is pretty consistent. I’m using 2 Dragonrise zero delay encoder controllers with Reicast. For whatever reason, the joystick will not work with the game I’m trying to play. Looking into the p1 and p2 config file, there is no input for the dpad even though the joystick is set as the dpad and the joystick setting is unmapped in EmulationStation settings. I tried configuring the .cfg file for Reicast in recalbox\share\systems\config\reicast but after the emulator is launched the settings change back to the default setting. I tried mapping the buttons as the dpad and that works but refuses to work for the joystick. Couldn’t find anyone with the same issue.

    tldr; The joystick is defaulting to the joystick input for Reicast and not the dpad Any ideas?



Want to support us ?

356
Online

79.8k
Users

21.2k
Topics

155.0k
Posts