Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

/recalbox/share partition moved



  • I posted this question in discord but only got 1 response so maybe someone here can help.

    Last week I installed the 64bit pc version of recalbox, loaded up all my games, set everything how i wanted it, and the system was running great. Then I was letting my kids play on it and when i came back the system was rebooted and it was on a fresh install. after doing some digging it turns out that the /share partition wasnt mounted and now it was pointing the share to a 3gb partition. I figured it was something my kids did so i backed up everything reflashed the drive then reinstalled recalbox, then moved all my stuff back. Again everything was working fine, until i was using skraper the other day and somewhere during that process it rebooted and is now mounted on a smaller partition again and isnt mounting my larger share partition.

    It seems this same problem happend a few years ago with another user as described in this thread :
    https://forum.recalbox.com/topic/5035/recalbox-reset-itself-to-default-all-settings-and-roms-gone
    But I dont see a solution from @Substring

    Some information about my setup:
    Recalbox 6.1.1 x86_64 installed as operating system
    64bit HP CQ57-339WM
    1.50 GHz Intel Celeron Processor B800 1333 MHz FSB
    2GB DDR3 SDRAM
    Intel HD Graphics
    320GB 5400RPM hard drive

    Any help is appreciated!



  • @KizerAir This is exactly the same issue I am having as well. The same issue happened when I tried to scrap as well. I am wondering if there is an issue with the 64 bit version, have you tested the 32 bit version yet? I think, I will attempt that to check the stability.


  • Screenscraper

    Hi @ggarcia81 and @KizerAir !
    Just to know, are you using the integrated scraper, or Skraper, the external software ?



  • @redblueflame Thanks for getting back to us, in my case I have attempted both. When using the integrated scraper only with mamedb selected as server this failure occurred. I then used the external scraper as recommended and everything was working perfectly until I tried scrapping Wii games then the same issue happened again. At first thought, I believed maybe I had exceeded my storage limitations on the drive. Unfortunately this was not the case, I haven't even used a quarter of the drive capacity before failure. Thinking that maybe it was my drive that was the problem I then tried with another drive and again I had the same issue. Whats weird is that a new partition is created with exactly 128MB that only has the base factory Recalbox os. When I do an fdisk -l I can see additional partitions so not sure if its a matter of the Boot record getting corrupted here?


  • Screenscraper

    @ggarcia81
    By the way, just a question, how are you accessing the recalbox data ?
    For your information, it's normal if you have a problem with the partition if you try to modify anything on windows by directly plugging it in, the share partition will be corrupted...
    What I can recommend you tough is to map the recalbox as a network drive, and try to do everything this way. It will be slower, but you will be sure that the partition won't be corrupted.
    If that's not the case, the output of a fdisk -l would be really great !
    I'm available if you still have a problem,
    Redblueflame



  • @redblueflame Anytime I add roms or preform a scrape I am using my PC connected over the network to the recall/share folder. The only reason I attempted fdisk -l to check the disk was after Recalbox failed. I then went through Recalbox login from prompt then from there initiated the Linux command. My current setup is a mini computer using an SSD flashed with Recalbox as the primary.



  • @redblueflame This command still works "fsck /dev/{parition name here}" In my case fsck/dev/sda2 worked to bring me back to my original partition.



Want to support us ?

175
Online

78.5k
Users

20.0k
Topics

147.5k
Posts