Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Updating to 6.1.1 on an ODroid XU4



  • This morning, I decided to finally update RecalBox running on my XU4 to 6.1.1. I install RecalBox from EMMC and generally boot from a microSD card.

    Up until pulling the EMMC module out of my XU4 this morning, the entire system was working fine. I verified the XU4 image SHA, wrote it to my EMMC in balenaEtcher, verified successful image write, reinstalled in my XU4, and while I can tell the board is booting, I get no video output at all. I've tried letting the XU4 sit for about 15 minutes hoping it was just writing boot files to my microSD, but nothing happens. The TV does detect a video signal - but it's black and remains that way.

    I've verified that the XU4 is set to utilize the EMMC as opposed to SD card. I've seen on some forums that switching from EMMC to SD and back sometimes helps, but I don't understand how it would and I'm hesitant to try anything at this point without guidance or the ability to determine if my XU4 just bit the dust.

    I've also heard that trying different televisions and monitors might help, but I've been using the same TV for the last year and from the point of initial boot, it's always worked, so I don't see how my TV could suddenly not be supported.

    The microSD card still has all the files from the previous version. Am I perhaps running into this problem because the installation is noticing existing files on the SD and refusing to continue to the point of initializing video?

    I'd like to clarify this before spending hours pushing the thousands of games and saves on my microSD to a new drive just to find out the end result is the same. Has anybody else been in this predicament and is there a possible resolve?



  • I think I figured it out - sort of.

    After upgrading to 6.1.1, I forgot to jump into the boot.ini file and comment out a display mode.

    However, the option which worked under previous versions is no longer sending video to my television.

    I have a Sanyo FW32D06F which supports 720p at 60hz, but with a really weird resolution of 1366x768.

    Previously, I commented out the line:
    setenv videoconfig "drm_kms_helper.edid_firmware=edid/1280x720.bin"
    and made sure no other lines were commented out.

    That worked under the old version of RecalBox. Doesn't seem to work under 6.1.1 though. I'ma give this one more shot with a fresh image. I have a feeling this might be happening because notepad under windows isn't saving the file in a unicode format, but if that ain't the problem, I'm kinda stumped.



  • @grimfusion said in Updating to 6.1.1 on an ODroid XU4:

    1366x768

    After dinking around, I stumbled across a copy of a boot.ini file online that had far more video mode options.
    https://github.com/mdrjr/5422_bootini/blob/master/boot.ini

    Found one that matched my 1366x768 resolution precisely, so I copied the lines into my XU4's boot.ini file.

    1366x768 without monitor data using generic information

    setenv videoconfig "drm_kms_helper.edid_firmware=edid/1366x768.bin"

    I then made sure all other video configurations were once again commented out.
    Guess what? Didn't work. My TV is still just as dark as the first day I tried this out.

    I'm going to re-image again. I know this specific flavor of RecalBox for the XU4 is a fork and y'all probably aren't the best folks to reach out to when I'm running your OS off of super-specific hardware, but jesus it's hard to find sensible documentation.



Want to support us ?

256
Online

78.2k
Users

19.9k
Topics

146.8k
Posts