Wifi ew-7811Un not working (USB-Disconnect)



  • Hi, I have posted here before: https://github.com/recalbox/recalbox-os/issues/612 Problem is, that The Edimax Wifi-Dongle is beeing disconnected after a few seconds: <span style="font-family: 'Helvetica Neue', Helvetica, 'Segoe UI', Arial, freesans, sans-serif, 'Apple Color Emoji', 'Segoe UI Emoji', 'Segoe UI Symbol'; font-size: 14px; line-height: 22px;">[ 11.648141] usb 1-1.4: USB disconnect, device number 5</span><br style="box-sizing: border-box; font-family: 'Helvetica Neue', Helvetica, 'Segoe UI', Arial, freesans, sans-serif, 'Apple Color Emoji', 'Segoe UI Emoji', 'Segoe UI Symbol'; font-size: 14px; line-height: 22px;" /><span style="font-family: 'Helvetica Neue', Helvetica, 'Segoe UI', Arial, freesans, sans-serif, 'Apple Color Emoji', 'Segoe UI Emoji', 'Segoe UI Symbol'; font-size: 14px; line-height: 22px;">[ 11.650192] rtw_cmd_thread: DriverStopped(0) SurpriseRemoved(1) break at line 482</span> So there is no wlan0 - Interface I have also disabled the power savings in /etc/modprobe.d/8192cu.conf but with no luck. I have found a non-practicable workaround when setting USB-Ports to slow (/boot/cmdline.txt --> <span style="background-color: #f7f7f9; color: #8b8b8b; font-family: Monaco, 'Andale Mono', 'Courier New', Courier, mono; font-size: 12px; line-height: 15.203125px;">dwc_otg.speed=1</span><span style="line-height: 1.5;">), the Edimax is working fine, connects to my Wlan and is listed in lsusb, too:</span>

    • [root@RECALBOX ~]# lsusb
    • Bus 001 Device 008: ID 7392:7811
    • Bus 001 Device 003: ID 0424:ec00
    • Bus 001 Device 002: ID 0424:9514
    • Bus 001 Device 001: ID 1d6b:0002

    <span style="line-height: 1.5;">But then all other USB-Devices (Keyboard , Logitech Controller) doesnt Worky any more </span> <p style="text-align: center;"><span style="line-height: 1.5;">**:-(  **  </span></p> <span style="line-height: 1.5;">Tested in 3.2.11, 3.3.0B16 & 3.3.0B17  </span> Please provide the driver for this wifi-dongle. Why is it green in the compatibility-list?



  • Hello Humm I'm using this wifi dongle since recalbox 3.2.0 an never had problems. Only to add network informations in my recalbox.conf file, reboot then that is ok. Your wifi must be in WPA2, ssid not invisible, and ssid/key must not contains specials characters.



  • Hi, there is nothing to configure when wifi dongle is disconnected by usb 😞 My config is ok, because the stick will connect to my wlan, when in USB1.1-Mode (nano /boot/cmdline.txt     -->   dwc_otg.speed=1).  When usb is configured to fast-mode(usb2.0) the stick is disconnected after a few seconds. There is no wlan0-interface anymore.   Maybe its a new revision of the Edimax 7811UN? lsusb says: ID 7392:7811



  • Really I'dont know, lsusb give me the same ID. Did you try your dongle with an other OS ?



  • same problem in ubuntu mate for pi...hm...google shows many problems disconnecting edimax-wifi-devices on RaspPi.  it seems nobody found a workaround...till now 😞



  • And with a desktop pc ? Your dongle have maybe a problem. 😕



  • no problem on windows-pc



  • so, another ew7811un. works like a charm 🙂


Log in to reply
 

Want to support us ?

237
Online

82.1k
Users

22.6k
Topics

163.3k
Posts