Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Ecran Noir Raspberry pi3 b+



  • Bonsoir à tous,

    Ayant acheté un raspberry dans l'optique de me faire une petite machine de rétrogaming, je suis directement confronté à un problème : Je n'ai qu'un écran noir sur la sortie HDMI lorsque je lance la petite box montée.

    Après quelques recherches, je suis tombé sur ça : https://raspberry-pi.fr/hdmi-raspberry-pi-marche-pas-solution/

    J'ai donc tenté de comprendre et de lancer une connexion en SSH afin de pouvoir modifier le fichier "config.txt" selon leur procédure.

    Cependant, lorsque je rentre mon adresse ip, impossible de me connecté. J'ai le message "Connection timed out" à chaque fois.

    Le raspberry est bien connecté à internet, mon ordinateur aussi.

    J'ai commandé cela: https://www.amazon.fr/ABOX-Raspberry-Dernière-Alimentation-Interrupteur/dp/B07DC37YSS/ref=cm_cr_arp_d_product_top?ie=UTF8

    Tout semble ok, si ce n'est ce fichu problème !

    Quelqu'un peut-il me venir en aide, et/ou me poser des questions que je ne me suis pas posé ?

    En vous remerciant d'avance

    Cordialement,
    EdgarCS



  • @edgarcs bonsoir,
    pourrais tu nous donner ta configuration complète (modèle du RPi, modèle de ta télé ou écran). As tu pu testé avec un autre RPi ? Ou un autre écran ?
    Quelle est ta version de RCB ? (6.0 je présume ?)
    Comment te connectes tu à internet avec ton Pi (éthernet ? Wifi ?).

    Merci de ces quelques éléments.



  • @Scavy Merci de ta réponse.
    Le modèle est le Raspberry Pi 3 B+. Mon écran est un BenQ (mon écran rattaché à mon ordinateur en 144hz).

    Non je n'ai pas testé sur un autre écran, ni RPi.

    La version est effectivement la Recalbox 6.0.

    Enfin je me connecte en Ethernet.

    Aucun problème pour le flashage via Etcher.

    Merci à toi de ta réponse.



  • Au passage, j'ai tenté une installation avec NOOBS et pas de problème, j'ai eu un écran multicolor, mais j'ai ensuite eu accès à l'OS (affichage etc.).

    J'ai les leds rouge et verte qui sont présentes. Donc tout semble ok.

    Le signal est bien détecté par mon écran, mais l'affichage reste au noir complet. J'ai attendu 10 minutes, et rien ne s'affiche.

    Autant dire que je ne vois pas.

    Cordialement


  • Staff
    Moderator
    Team

    @edgarCS
    tu es relié en hdmi sur ton écran BenQ ?

    Pour le config.txt insère la microsd dans ton pc, il est accessible dans la seule partition visible BOOT sous windows.



  • @edgarcs L'adresse IP que tu rentres, c'est bien ton adresse locale (168.XX.XXX.XX) ?
    Tu es bien en réseau avec ton ordi ? (pas de VPN activé ou autre).

    Pour ton écran, il est possible que ton cela vienne de ton alimentation si elle est faiblarde, mais j'en doute, ou alors la prise HDMI du RPi qui serait endommagée. Je n'ai pas de retour négatif des écran BenQ, faut voir si le fichier config est bien paramétré. As tu essayé un autre câble HDMI au passage ?



  • @acris Oui je suis bien relié à mon écran en HDMI.

    @Scavy Mon adresse ip locale est à ce format là : 192.XXX.X.X
    Pas de VPN d'activé.

    Si l'HDMI était endommagé, je n'aurai pas l'affichage sous NOOBS. Par conséquent le câble lui aussi fonctionne bien...



  • Essayé à l'instant sur un autre écran. Cela me fait exactement la même chose que son mon BenQ.



  • Le problème ne pourrait-il pas venir d'un problème de boot ?



  • text alternatif

    Je viens de réessayer avec NOOBS et aucuns problèmes.



  • @edgarcs Oui 192.168.X.X je fatigue mais c'est bien du local.
    Sur ton ordi, tu arrives à afficher le manager via ton navigateur ?

    Pour l'écran, je penche pour une mauvaise valeur dans le fichier config de RCB. @acris t'en penses quoi ?



  • @scavy Non du tout. Tu parles bien de recalbox.local ?



  • UP.. je n'y arrive toujours pas !



  • Bonjour à tous,

    Je vous fait parvenir la config de RCB présente sur ma clé. Peut-être que cela aidera...

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.

    #hdmi_drive=2

    Using /etc/modules is deprecated and no longer supported on 4.4 kernel

    So manually enable audio

    dtparam=audio=on

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the hdmi output

    hdmi_force_hotplug=1

    uncomment for composite PAL

    #sdtv_mode=2

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it

    boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    default CEC name

    cec_osd_name=recalbox

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=384

    avoid_safe_mode=1

    kernel=zImage

    Raise the first security limit up to 70° instead of 60°

    temp_soft_limit=70

    Merci infiniment à ceux qui me viendront en aide.

    edgarCS


Log in to reply
 

Want to support us ?

Join us on :

143
Online

52534
Users

17763
Topics

133663
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.