Réglages joystick dans fichier .uae sur Amiga



  • @Bkg2k @voljega

    Bonjour à tous,

    Je voudrais savoir si quelqu'un connaissait la façon d'indiquer à Amiberry quels joysticks utiliser au lancement d'un jeu ?

    Par défaut, j'ai bien mon joystick XinMo player 1 dans le port joystick, et la souris dans le port 0.

    J'ai essayé de créer un .uae, en mettant ceci (copié du fichier config récupéré dans le répertoire /tmp après après configuré mes joysticks en port 0 et port 1)

    joyport0=joy1
    joyport0_autofire=none
    joyport0_mode=djoy
    joyport0_mousemap=right
    joyport0_friendlyname=Xinmotek Xinmotek Dual Controller
    joyport0_name=JOY1
    ;
    joyport1=joy2
    joyport1_autofire=none
    joyport1_mode=djoy
    joyport1_mousemap=right
    joyport1_friendlyname=Xinmotek Xinmotek Dual Controller
    joyport1_name=JOY2

    Mais curieusement, il me met bien un joystick dans le port 0, mais rien dans le port 1 !!!

    J'avoue ne pas comprendre, surtout que c'est Amiberry lui-même qui sauvegarde cette configuration ainsi, donc à priori ça devrait lui plaire 🙂

    Merci d'avance !



  • Je me suis relu et je pense ne pas avoir très lumineux...

    Au final c'est super simple, je souhaiterais savoir s'il y a un moyen de démarrer avec 1 joy dans le port 0 et un autre dans le port 1...

    C'est plus simple que tout mon baratin au dessus 🙂


  • Banned

    @flomartin je sais pas j'ai toujours pas essayé la 6.0...



  • Quel dommage 🙂 !

    Je ne comprends pas du tout la logique, je vois bien des changements selon ce que je mets comme paramètres, mais je n'arrive pas à avoir les 2 joysticks branchés en port 0 et 1...

    Très étrange le fonctionnement d'Amiberry quand même 🙂

    Merci quand même voljega !


  • Banned

    @flomartin c'est pas forcement amiberry, ça dépend comment les fichiers de conf pour le lancer sont générés, etc etc...

    tu devrais essayer de lancer ton jeu avec ce fichier de conf tweaké, et pendant qu'il tourne voir dans /tmp ce qu'il y a dans le fichier de conf

    ceci dit les paramètres pour les joysticks ont toujours été très chelou et légèrement chaotique, j'avais déjà eu quelques problèmes avec en 4.1 sur les versions précédentes d'amiberry



  • @voljega said in Réglages joystick dans fichier .uae sur Amiga:

    iberry, ça dépend comment les fichiers de conf pour le lancer sont générés, etc etc...
    tu devrais essayer de lancer ton jeu avec ce fichier de conf tweaké, et pendant qu'il tourne voir dans /tmp ce qu'il y a dans le fichier de conf
    ceci dit les paramètres pour les joysticks ont toujours été très chelou et légèrement chaotique, j'avais déjà eu quelques problèmes avec en 4.1 sur les versions précédentes d'amiberry

    C'est ce que j'ai essayé de faire, enfin je pense...

    J'ai lancé mon jeu, Extreme Violence dans le cas présent, un p'tit jeu bien fun à deux.
    Je suis allé dans le menu, j'ai configuré mes joystick, en mettant le joy1 dans le port 0 et le joy 2 dans le port 1.
    J'ai sauvegardé ma configuration, qui est bien apparue dans le répertoire temp.
    J'ai fait un copier-coller de la partie concernant les joyticks, comme indiqué dans un de mes posts précédents.
    Cette config a d'ailleurs l'air très cohérente.
    Je mets tout ça dans un fichier .uae, je lance, et ça ne marche pas du tout 😄

    Ce qui m'arrache les cheveux c'est le manque de logique, ou plutôt le fait que je n'arrive pas à saisir la logique.

    J'ai essayé plein de combinaisons possibles, et aucune ne donne le résultat attendu !

    Bref, je vais continuer à aller dans le menu pour paramétrer mes joysticks pendant un moment encore je crois 😄

    Je me suis fait à cette version 6.0, j'utilise le plus possible l'emulateur CD32 qui charge super vite, et pour le reste en Amiga 1200 j'utilise les fichiers ADFs qui vont assez vite aussi.

    Je suis sûr que sous peu il y a aura une solution pour lancer les jeux WHDL plus rapidement, je les remettrai à ce moment là.

    Merci encore pour tes conseils.


  • Banned

    @flomartin Euh non y'aura pas de solution pour lancer les whdl plus rapidement, c'est le loader amiberry qui est lent. à moins que l'équipe d'amiberry améliore le truc mais c'est pas sûr du tout.

    Sinon tu n'as pas fait ce que je t'avais demandé en fait 😄 relis...



  • Zut j'ai lu trop vite alors 😄

    Donc si je comprends bien, je le lance avec un fichier .uae personnalisé si on peut dire, je vais ensuite voir dans le répertoire tmp ce que lui a créé comme fichier ?

    Je vais tester ça !

    Pour les temps de chargement tu n'es pas très optimiste je vois... 🙂

    Le loader a l'air de prendre du temps pour créer un fichier particulier, au deuxième lancement ça va plus vite ! Mais dès que l'on éteint la recalbox, le fichier est supprimé.

    Peut-être il y a-t-il une solution pour que ce fichier reste sauvegardé ?

    Bon, je prends mon courage à deux mains et je regarde ce que fait Amiberry de ma config de joystick 🙂

    J'aimerais savoir aussi pourquoi le paramètre floppy speed ne passe pas !
    Je vais regarder tout ça !



  • @voljega tu es un génie 🙂 !!!!

    En étudiant ce que faisait amiberry de mon fichier de config, j'ai vu qu'il mettait 2 fois le joy2, à la fois dans le port 2 et le port 1...

    Du coup j'ai mis ça dans mon fichier .uae :

    joyport2_autofire=none
    joyport2_friendlyname=Mouse
    joyport2_mode=mousenowheel
    joyport2_mousemap=right
    joyport2_name=MOUSE0
    ;
    joyport0=joy1
    joyport0_autofire=none
    joyport0_mode=djoy
    joyport0_mousemap=right
    joyport0_friendlyname=Xinmotek Xinmotek Dual Controller
    joyport0_name=JOY1
    ;
    joyport1=joy2
    joyport1_autofire=none
    joyport1_mode=djoy
    joyport1_mousemap=right
    joyport1_friendlyname=Xinmotek Xinmotek Dual Controller
    joyport1_name=JOY2

    Et mes deux joysticks sont bien reconnus au lancement ! Il fallait juste la mettre la souris en port 2 !

    Peut-être serait-il bien de mettre ces infos dans le Wiki ?

    Je n'arrive toujours à passer le floppy_speed par contre, dans le uaeconfig il reste à 100 même si je le mets à 800 dans mon fichier. Mystère.

    En tout cas mille fois merci, je pense que ça sera utile à tous ceux qui ont un bartop et qui souhaitent jouer aux jeux avec 2 joy 🙂



  • @flomartin : Salut ! Est-ce que tu peux me confirmer que cela fonctionne en WHDLoader ?
    Pour le reste du fichier, tu mets quoi ?

    Merci !



  • @oldgreg

    Je ne sais pas en WHDLOAD vu que qu'avec ma Xin-Mo je ne peux pas utiliser le loader WHDLOAD...

    C'est pour lancer Extrême Violence en ADF avec les deux joysticks branchés directement.



  • @flomartin : Hors sujet, mais si tu aimes ce jeux, essaye de trouver Alien Frenzy. J'avais la disquette étant gosse et j'adorais. Dans le même style qu'Extrême violence.



  • Je ne connaissais pas, je vais chercher merci !



Want to support us ?

267
Online

81.4k
Users

22.2k
Topics

161.4k
Posts