Recalbox 7.0

Emulation Amiga 1200 écran noir après logo Amiberry sur écran 4/3...



  • Bonjour à tous,

    Je suis passé en 6.0 il y a quelques jours, et j'ai bien galéré avec l'émulation Amiga...

    Mais grâce à l'aide de certains spécialistes sur ce forum, j'ai réussi à faire fonctionner à peu près les jeux, sur ma machine de test, qui a un écran 16/9.

    Quand j'ai mis ma carte microSD dans le RPi3 de mon bartop, qui a un écran 4/3, catastrophe, les jeux Amiga ne se lancent plus du tout !!!!

    Le logo Amiberry apparait, puis après c'est un écran noir !

    J'ai bien essayé de changé le mode vidéo dans recalbox.conf, avec un videomode=DMT 35 HDMI, ça ne change rien.

    J'ai essayé de changer le mode global :
    system.es.videomode=DMT 35 HDMI, ça a le mérité de donner un ratio correct aux jeux sur mon écran 4/3, mais l'Amiga ne marche toujours pas.

    En partie H, j'ai essayé de modifier :
    global.videomode=auto avec default ou DMT 35 HDMI ou CEA 4 HDMI.

    En I, j'ai essayé de créer une ligne :
    amiga1200.videomode=default ou DMT 35 HDMI ou CEA 4 HDMI, sans succès 😞

    Je m'arrache les cheveux sur ce truc !!!!*

    Et sur un écran 16/9 ça marche, donc ça doit bien venir de l'écran, enfin de la configuration !

    Pourtant je n'ai pas de message de l'écran disant que la résolution est trop haute, rien.

    C'est un Viewsonic en 4/3, 1280x1024 d'ailleurs si ça peut aider !

    D'avance merci 🙂



  • Pour info, les jeux en ADF fonctionnent bien !

    Mais mes jeux en WHDL sous lha ne marchent pas.

    J'arrive à faire apparaitre l'interface d'Amiberry avec F12, mais je vois pas ce qui coince....

    Encore une fois, avec un écran 16/9, ça marche, il y a de quoi devenir chèvre avec cet Amiberry de malheur 😞



  • @flomartin

    i am non-french, sorry for that.

    bartop=usb encoder. which one you have?

    In general, i think this problem is more a "controller (maybe config?)" problem.

    Not a real solution, but.....
    Try the following (yes, i am not joking):

    • start the .lha game
    • turn your bartop joystick in circle, do not stop turning around....

    If all runs good the amiberry logo appears and after that the whdbooter starts and your game is loading.
    Try it and give feedback



  • Hi Abunille,

    My usb encoder is the XinMo.
    I do see the Amiberry logo, the trouble is that when the logo disappears, I just have a black screen.

    Will give a try to the joystick trick and let you know 🙂 Thanks !



  • I did not work unfortunatly 😞

    Thanks a lot anyway !



  • @flomartin

    mmhhh, i have also an xinmo.
    And your problem was the same to me.
    And the trick does it on more encoders than xinmo.
    You must turn around (and keep going in circles without stopping.) the joystick directly after starting the .lha rom.



  • @abunille said in Emulation Amiga 1200 écran noir après logo Amiberry sur écran 4/3...:

    mhhh, i have also an xinmo.
    And your problem was the same to me.
    And the trick does it on more encoders than xinmo.
    You must turn around (and keep going in circles without stopping.) the joystick directly after starting the .lha rom.

    You also have troubles just with the WHDL packages like me, your ADFs are working fine too ?

    This a really strange bug...

    And really annoying !



  • @flomartin

    Yep, same issue.
    The whdbooter didnt start.

    If you have a ps3 controller....connect it and test amiberry.
    With connected ps3 controller it was working for me (but useless on bartop for me). Thats why i think its a controller problem

    EDIT:
    I send you a link via PM to a video with "not working" and "working" whdbooter with circle trick. not the best video, sorry again.



  • Abunille,

    You're amazing !!!!

    I unplugged the Xin-Mo and plugged a 360 joypad.

    And it worked !!!!!!!!!!!!

    I would have never thought about this !!!!!

    But now I'm stuck, I still don't know how to make my bartop work 😞

    Turning the stick in circles didn't help in my case sadly.

    But it will help for sure the recalbox team or amiberry team to fix !

    Thanks a lot



  • @flomartin

    You are welcome (even if it's not a real solution).
    you are in the same situation than i (and a few others).
    @ian57 wanted to test a lha game in combination with a bartop encoder weeks ago, but it seems that he didn't had time.



  • I saw your video, really a curious trick !!!!

    I hope that the Amiberry team is aware of this trouble.

    Perhaps should I use another encoder, but I don't know one that will work for sure...



  • @flomartin

    i would say its not an amiberry issue itself, i am 99% sure.
    we have to pray that the recalbox team will be able to get the problem under control.
    My Bartop is waiting for a Amiga Party 🙂



  • @abunille @Bkg2k @voljega

    Ok so let's wait for Recalbox 6.1 😄

    I don't want to plug my Sanwas on the GPIO port, really not convenient at all !!!

    Thanks again a lot



  • @abunille said in Emulation Amiga 1200 écran noir après logo Amiberry sur écran 4/3...:

    en if it's not a real solution).
    you are in the same situation than i (and a few others).
    @ian57 wanted to test a lha game in combination with a bartop encoder weeks ago, but it see

    And do you know if another encoder would work, like the Zero Delay encoder ?



  • @flomartin

    sorry, i dont know. i am not a encoder specialist.
    i was already glad to have built my bartop without breaking, hahaha.

    But "dragonrise" is not the best option for now.
    @MarbleMad had the same amiberry issue with that encoder.



  • @abunille said in Emulation Amiga 1200 écran noir après logo Amiberry sur écran 4/3...:

    t the best option for now.
    @MarbleMad had the same amiberry issue with that encoder.

    Ok, so I will stick to the adf files and CD32 games... Waiting forward to the next update 😄



  • @flomartin

    where are your roms stored? sd card or usb?



  • @flomartin said in Emulation Amiga 1200 écran noir après logo Amiberry sur écran 4/3...:

    Ok, so I will stick to the adf files and CD32 games... Waiting forward t

    My files are on a USB stick, as advised by the Recalbox team.


Log in to reply
 

Want to support us ?

178
Online

79.2k
Users

20.4k
Topics

149.3k
Posts