Recalbox 7.0

N64 exits when using Wii Classic Controller



  • Hi guys,

    I tried original Nintendo Wii remote + original Nintendo Classic controller connected to it.
    Seems to work fine so far with latest Recalbox stable and all emulators, but NOT the N64!

    When I run N64 with other controllers, it works fine too. But as soon I run an N64 game with Nintendo Wii remote + Classic controller connected, it immediately exits (crashes?!) afterwards.

    In another thread I found a hint:
    It’s written that L1+R1 buttons have to be mapped for N64 to work properly. In case of Nintendo Classic controller these buttons are recognized as axis instead of buttons. Maybe the N64 emulator doesn‘t like this??
    Unfortunately I found no way to recognize them as buttons. Even not trying the mapping again a few times, like it sometimes works with other controllers.
    Is there a way to change axis to buttons manually in config file? Or does anybody have another idea why N64 emu doesn‘t like the Wii Classic controller combination?

    Another thing:
    As Wii remote and the directly to it connected Classic controller are recognized as 2 independent controllers, the Classic controller is always recognized as controller 2 (Wii remote itself always is controller 1 by default!)
    This means when I run a game as single player, it‘s always controlled by Wii remote by default. Have to choose Classic controller as controller 1 in Recalbox configuration before running a game because of that. Any chance to make Recalbox ignore the Wii remote itself and making Classic controller automatically to default controller 1 this way?

    My config:

    Thanks for your help!



  • Found a way to map L1/R1 as buttons instead of acis in the meanwhile. But problem with N64 persists, so it‘s not the reason 😞
    Any ideas?



  • This appears in es_launchstderr.log

    Traceback (most recent call last):
    File "/work/output/target/usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 227, in <module>
    exitcode = main(args)
    File "/work/output/target/usr/lib/python2.7/site-packages/configgen/emulatorlauncher.py", line 153, in main
    command = generators[system.config['emulator']].generate(system, args.rom, playersControllers)
    File "/usr/lib/python2.7/site-packages/configgen/generators/mupen/mupenGenerator.py", line 20, in generate
    mupenControllers.writeControllersConfig(playersControllers)
    File "/usr/lib/python2.7/site-packages/configgen/generators/mupen/mupenControllers.py", line 51, in writeControllersConfig
    config = defineControllerKeys(player)
    File "/usr/lib/python2.7/site-packages/configgen/generators/mupen/mupenControllers.py", line 92, in defineControllerKeys
    config['Z Trig'] = setControllerLine(mupenmapping, controller.inputs['x'], "Z Trig")
    KeyError: 'x'

    ... I have no idea what to do ...



Want to support us ?

113
Online

79.1k
Users

20.4k
Topics

149.2k
Posts