Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Préparation Bartop. problème re-mapping boutons certains émulateurs (NES, Dreamcast, ScummVM)



  • Bonjour à tous.

    avant toute chose, voici ma config existante :
    Raspberry Pi model: PI3B
    Recalbox version : 4.1
    Matériels : Micro SD pour l'OS et USB 3.0 128Go pour les rom/data
    Manette(s): 2 encodeurs USB 12 boutons compatibles recalbox (du moins pour tous les autres émulateurs que j'ai remappés)

    plusieurs recherches m'ont permis de remapper certaines consoles plus compliquées comme la N64 ou la PSP mais je bloque toujours sur certaines consoles pour remapper mes touches : NES, Dreamcast, ScummVM.

    Par rapport à EmulationStation, j'utilise la configuration de touches suivantes (touches en bleu) :

    0_1544270591288_snes.png

    Cependant, je prends l'exemple de la NES, je souhaite la configuration suivante :

    0_1544270981269_nes.png

    et bien meme en passant par retroarch, je n'y arrive pas. les fonctions de remapping que j'utilise sur les autres émulateurs sont juste bloqués et représentés par des "---". impossible d'y affecter des touches :

    0_1544272873706_IMG_20181208_133440.jpg

    Je pense qu'il y a un lien avec mon fichier FCEUmm.rmp, mais je ne comprends pas ce qui cloche. voici le contenu de mon fichier :

    0_1544273111140_FCEUmm.rmp.jpg

    Je ne comprends pas, si qqn a une idée?

    de même pour les consoles Dreamcast et ScummVM, je ne comprends pas trop comment cela fonctionne pour le remmaping donc si un expert passe par là :-).

    Mais bon la NES est pour moi plus importante à régler.

    D'avance merci une fois de plus pour votre aide.

    //minouch



  • Petit up ☺️



  • @minouch

    Hi,
    if you don't mind, i'll try it in english:
    (no guarantee. i can`t test at the moment, maybe some commands/points can be wrong)

    NES:
    Have you tried the remapping with another Core for NES (nestopia for example)?

    ScummVM:
    What do you want to remap here?

    Generally:
    First you have to find out which button is which output on your system.
    Connect via SSH and type this command: sdl2-jstest -t 0
    Press a button and write down the output (or remember it).

    If you have your output, navigate via WinSCP or whatever to:
    recalbox\share\system\.config\scummvm

    Now open the scummvm.ini file with an editor of your choice.
    Now add [keymapper] at the end of the file (if it doesn`t exist).

    For example we would add/remap left and right Mouse button:

    For left mouse button add joystick_button_lmouse=
    For right mouse button add joystick_button_rmouse=

    Add your output after the = (without space/blank)

    Save and try (maybe reboot)

    Here my example with ps3 controller output:

    [keymapper]
    joystick_button_lmouse=14
    joystick_button_rmouse=13
    

    Maybe this can help you a little bit.

    There are a few more lines to add, but untested on my side:

    joystick_button_escape=
    joystick_button_skip=
    joystick_button_pause=
    joystick_button_menu=
    joystick_button_vkeyboard=
    

  • Tester

    @minouch
    La version 4.1 d'Oct 2017 est plutôt ancienne.
    Il y a eu de tres nombreuses mises jour depuis.
    Pourquoi ne pas mettre à jour vers la dernière version stable 2018-07



  • @olivierdroid92

    absolutely correct, I overlooked that.

    @minouch
    maybe with your old version my suggestions won't work (or only partially)



  • Hey guys thanks for your input ☺️. Actually i was wrong with the version. I confirm you i have a version from 2018. I don t remember exactly the correct one but it s quite recent and i can use vertical wheel with this version for example.

    @abunille i m not sure how to change to nestropia core for nes. I will check on this forum when i ll be back home. I will also take a look on your other tests to perform. Great thanks already for this 🙂.

    Keep you informed by this evening

    //minouch



  • @minouch

    You can change the emulator and the core directly in EmulationStation.
    Navigate to an NES game
    Press SELECT and choose EDIT METADATA
    Here you can change the Emulator (to Libretro) and choose for example the Nestopia Core.

    With this method it is only changed for the one game. But for a Test its enough



  • @abunille
    perfect !!
    I tried your method changing core emulator on NES to Nestopia and remapping worked.
    so What I did then after the remapping was to copy paste the RMP file from Nestopia, and rename it to FCEUmm.rmp. then reusing FCEUmm core emulator was working great with good mapping :-)
    But I think there is clearly a problem with this core emulator since we cannot change the mapping from retroarch but we can with nestopia.
    Here is the config file which worked for me :

    input_player1_btn_b = "8"
    input_player1_btn_a = "-1"
    input_player1_btn_l3 = "0"
    input_player2_btn_b = "8"
    input_player2_btn_a = "-1"
    input_player2_btn_l3 = "0"
    input_libretro_device_p1 = "1"
    input_player1_analog_dpad_mode = "0"
    input_libretro_device_p2 = "1"
    input_player2_analog_dpad_mode = "0"
    input_libretro_device_p3 = "1"
    input_player3_analog_dpad_mode = "0"
    input_libretro_device_p4 = "1"
    input_player4_analog_dpad_mode = "0"
    input_libretro_device_p5 = "1"
    input_player5_analog_dpad_mode = "0"

    cause my mapping looks like this :

    0_1544638257274_mapping.png

    so it's quite strange how the mapping is done with NES emulators but it works now thanks to you.

    Now regarding scummvm,
    I added your lines and assigned buttons according to previous mapping drawing I have but I have 2 issues now :

    • with my joistick, I can only go from left to right ro right to left. it's like up and down don't work here. (It was also the same issue before I update this configuration file actually)
    • my buttons are not taken into account. Could that be that I need to link the scummvm.ini somewhere in recalbox ?

    Thanks.
    //minouch



  • @minouch

    NES:
    Nice to see that NES is working now.
    And yes, maybe someone must look into this FCEUmm issue.

    ScummVM:
    Normally only the change in the scummvm.ini is necessary. nothing else.
    Mmmhhhh, i can't help from the head at the moment, i have to watch and test it myself.
    If i have time i test that at the weekend.

    EDIT: And check that you have an "up to date stable version" (18.07.13)

    ;)



  • @abunille
    I confirm you that i m on version 18.07.13 👍
    Thanks. I will check on some scummvm forum/websites if i can find something about this axis y issue i have.
    //minouch



  • @abunille
    You know what. I purchased a nice usb keyboard with integrated touchpad for doom scummvm and msdos :

    0_1545666565759_IMG_20181224_164910.jpg

    And it s actually working great. So I don t care anymore having scummvm working with my buttons and joisticks.

    Regarding the mapping issue on dreamcast. Do you have any idea how i could remap my buttons?

    Thank you ☺️



Want to support us ?

317
Online

61580
Users

18633
Topics

140015
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.