Problème GameBoyZero / Ecran 3,5 Pouces / Alimentation



  • Bonjour a tous, et merci de m’écouter sur ce forum de passionné ! et evidemment desolé si je fais un doublon d'un post deja effectué et que j'aurais loupé

    Je m'explique après avoir lu plusieurs articles et résolu énormément de problèmes grâce a vous tous, je suis toujours devant un problème
    Je suis en train de réaliser un projet GameBoy Zéro avec un Raspberry Pi Zero W, après avoir suivi plusieurs tutos je suis en train de réaliser la liaison ecran/alimentation/Rasp.
    Mes problèmes sont les suivants :
    1- quand j'alimente mon écran 3.5pouces (écran de radar de recul) a partir du Raspberry, il s'allume mais l'image est fortement degradée
    2- quand j'alimente par le booster de volt en 5,4v celui ci n'a aucune reaction

    Es ce que quelqu'un peut me dire si ce genre de problème lui est deja arrivée ? je commence a manquer d'idée !
    merci d'avance a tous



  • Hello !
    Tu as un schémas, et les références de tes différents composants ?
    A l’aveugle, comme ça, c’est un peu dur de t’aider B-)...



  • @greenalex sans problème demain si je fini pas trop tard je te donne toutes les infos que tu me demande
    Pour info pour ce qui est du matériel j'ai pris le pack luxe sur le site gameback.fr (aujourd'hui il se nomme le pack xl/xxl)



  • J’ai comme l’impression que les amis de Gameback créent quelques soucis !
    Tu as un copain pas loin ;-) : link text



  • @greenalex merci vraiment de prendre du temps à me répondre effectivement par rapport à la conversation de shlaf j'utilise exactement le même équipement (inter à glissière booster...Etc) je vais tout le suite essayer de brancher le booster sans passer par l'interrupteur histoire de voir



  • @greenalex en direct live je viens d'effectuer le branchement suivant :
    Alim 5V / 3A => Chargeur MICRO USB 5V 1A => Booster de volt 2A => écran radar de recul (modifier forcement pour fonctionner en 5v) et aucune réaction de l'écran
    Verdict je pense que je vais revoir mes composants parce que le premier prix à ses limites
    Je vais me diriger sur des produits correct et le site adafruit m'a l'air parfait pour ça et revoir la conception depuis le début puisque ça ne va pas vraiment



  • Tu n’as pas la batterie de branchée ? Suis pas sur que le chargeur puisse te fournir l’intensite nécessaire... Il est fait pour charger une batterie à 1A, pas plus.
    En général avec ce ce type de chargeur de base, tu charges et seulement après tu joues. Avec le mien, c’est ça en tous cas...



  • @greenalex effectivement je n'est pas essayer avec la batterie
    je pensais que ce type de chargeur aurais pu te permettre de jouer brancher avec un adaptateur secteur ou une batterie externe... Hummm élémentaire mon cher Watson ! Il faudrait que je trouve un chargeur plus puissant...
    Je test ça se soir en rentrant du boulot !
    Merci encore !



  • @greenalex Bon ben je vais peut être voir pour un nouveau booster je viens d'essayer le branchement suivant :
    Chargeur => Batterie => Booster => écran :
    Et Batterie => Booster => Écran:
    avec 3 batteries différantes j'ai bien 5,4v en sortie je voie mon écran qui se polarise au niveau des cristaux liquides mais pas de rétro-éclairage ni d'image...



  • J’ai regardé vite fait certaines parties du tuto (j’imagine que c’est le même que Shlaf) et j’aurais tendance à dire que le souci doit venir de l’ecran modifié. S’il y a effectivement une dizaine d’interfaces d’ecran différentes, ça rend le résultat assez aléatoire. En tous cas, je pense qu’il y a plus de chance que ca merde la, plutôt qu’un composant neuf foireux... Des composants qui deconnent ça arrive, mais par expérience, qd ça n’en fonctionne pas c’est généralement de notre faute B-) !



  • @greenalex effectivement si tu a regarder les tutos il s'agit de la chaîne #cetaitmieuxavant
    Te concernant es ce que tu a réalisé le projet GBZ ?
    Si oui quel type d'ecran prendrait tu ?
    Je pense que je vais recommander un nouvelle écran d'après tes informations



  • Non, je me suis attaqué d'emblée au gros morceau, me suis inspiré de Banjo, le grand maître du fer à souder B-)...
    Mais c’est clairement pas le même budget, et ça m’a pris presque un an, entre l’idée de départ, la compréhension des différentes parties, et la réception du matos. Aucun regret, mais j'aurais du mal à le conseiller comme première expérience de portable...
    Du coup, pour l’ecran 3,5 pouces, je n’ai pas étudié la question. Mais j’imagine que si tellement de gens sont passés par les modèles « radar de recul », c’est que le rapport qualité / prix doit être intéressant, et la taille doit coller au poil. Mine de rien, les difficultés d’integration de chaque élément représentent un sacré casse-tête...
    Et ds mon cas, l’ecran HDMI fonctionne en 5v, donc pas de tracas à ce niveau là.



  • @greenalex après avoir fait plein d'essai possible et imaginable j'ai enfin règle mes problèmes
    Mon écran à une image fixe et j'ai compris pourquoi mon écran ne s'allumait pas dans certains cas...
    Oufff mais l'achat d'un powerboost va devenir indispensable mdr
    Voilà je te tiens au courant merci encore de ton aide
    Maintenant je vais aller aider les autres



  • Nickel !
    Mais du coup, tu as résolu ton problème comment ?
    Ça pourra aider du monde si un des éléments du kit est problématique, ou si les tutos ont zappé un truc...
    Bonne chance pour la suite !



  • Ah oue, en réalité resumons j'avais deux problèmes d'affichage :

    1- (une image fortement dégradée plein de stries et parasité sur mon écran 3,5 pouces alors que l'affichage du menu de l’écran lui était parfait)
    La Solution : je me suis aperçu que c’était du a la modification électronique ...
    (le fameux pontage qui permet de faire fonctionner l’écran en 5v dans mon cas de figure)
    En retirant le pontage et en alimentant ce même écran à environ 9,2v avec une alimentation stabilisé mon image était nickel

    2- (un écran qui ne s'allumait pas alors que le fil jaune AV1 est bien branché)
    La solution : Le port TV du Rpi a deux emplacements le signal et une masse
    Dans mon cas, il a simplement fallu brancher cette masse sur la meme masse de l’écran
    Dans mon projet GBZ je vais donc modifier mes composants : je prend 1 Adafruit Powerboost Charger 1000 pour l'alimentation et le fonctionnement du Rpi Zero
    Le lien du produit
    et d'un booster classique pour l'ecran

    En espérant que cette solution permettra de résoudre quelques problèmes similaires



Want to support us ?

Join us on :

300
Online

31120
Users

15122
Topics

113784
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.