Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Error actualizando el sistema



  • @paradadf ok perfecto, le preguntaré. Si doy con la solución lo pondré por aquí para futuras personas con el mismo problema. Gracias.



  • @truha i hope you speak english :o

    So you've activated i2c, but it's not working / crashing ? Are you US ng the mk_arcade_gpio module ? On my side i've veen working on merging the master branch in the hotkey branch, i could test i2c and it was working fine. Still not available in recalbox though



  • @substring Yes, it works! at the beginning it gave me a bit of war when compiling, but in the end I got it. I only have the problem that the buttons are exchanged for the PAD but it does not cause me any problems.

    The problem I have with the update, that when I update the i2c stops working and I have to reinstall everything.

    I use the traditional method in the menu of the recalbox interface. When it restarts, it only shows me a black screen with many errors and it dies. I do not have access to the system through HTTP or SSH.



  • @truha ok. Between which versions does it stop working ? what are your edits ?



  • @substring I compiled the system using this manual:

    https://gitlab.com/recalbox/recalbox/wikis/compilation-process

    The only change you made is to enable i2c in mk_arcade_joystick_rpi.

    I currently use version 4.10

    When I configured the WiFi connection I was notified of a new update, I do not know the version exactly.



  • @truha still, i don't get how you use i2c ... do you enable the gpio controllers through i2c ?



  • @substring First I modify with make menuconfig to enable i2c:

    alt text

    Then I modify mk_arcade_joystick_rpi.c to be able to use the necessary buttons:

    alt text

    Compile the system and load the image in the microSD.

    Edit /etc/modules.conf and add at the end of the file:

    i2c-bcm2708
    i2c-dev

    Edit the /boot/config.txt and add following lines in it:

    #Activate I2C
    dtparam=i2c1=on
    dtparam=i2c_arm=on

    Edit the /boot/cmdline.txt and add at the end of line:

    bcm2708.vc_i2c_override=1

    I set the i2c address in recalbox.conf with the address obtained with i2cdetect -y 1:

    controllers.gpio.enabled=1
    controllers.gpio.args=map=0x20

    At this point it is when I set up the WiFi connection, it notifies me that there is a new update and when executing it it breaks my system.



  • @truha Ifnyou made some edits yourself, of course an upgrade will break it ! The whole system is upgraded, even the module you.ve edited ! Just reinstall the ko and you're good



  • @substring you mean you re-download and compile?

    Thank you very much for the help.
    A greeting.



  • @truha No ! I mean simply reinstall your version of mk_arcade_joystick_rpi.ko


Log in to reply
 

Want to support us ?

Join us on :

335
Online

53352
Users

17793
Topics

133854
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.