PC v18.04.20 Wifi/Bluetooth issue



  • So I've been trying to build a few different PCs up with recalbox for a fun hobby. Never had issues with any hardware until today. I've been trying to use wifi and bluetooth with the Intel Centrino Wireless-N 2230 2230BNHMW chip. Now I've searched the forums and found nothing that either worked or was relevant. Every unit I build I test with a bootable Ubuntu of both 18.04 LTS and 18.10 and as you say if it works with linux it will work with recalbox. I've tried this card on Ubuntu(s) and my Windows To Go stick. I've set the SSID and wifi key manually, I've tried adding known working bluetooth devices and have just recently added a cheap iogear bluetooth 4 dongle that just uses generic drivers anyway and it seems to function with the dongle only. I haven't had a chance to check what kernel recalbox was using but I believe 4.8 had support for this card. I will have to check if 4.10 came out yet. (Been a while since I've reviewed the changelog on the linux kernal.)


  • Moderator
    Team

    @halathos need dmesg output to know which drivers/firmare are missing



  • @substring [0_1526230972593_dmesg.txt](Uploading 100%)
    https://www.dropbox.com/s/j10kdm6thvdjgll/dmesg.txt?dl=0


  • Moderator
    Team

    @halathos And here is why it's not working:

    [    3.254577] Intel(R) Wireless WiFi driver for Linux
    [    3.254578] Copyright(c) 2003- 2015 Intel Corporation
    [    3.254710] iwlwifi 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
    [    3.254904] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-2030-6.ucode failed with error -2
    [    3.254911] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-2030-5.ucode failed with error -2
    [    3.254911] iwlwifi 0000:04:00.0: no suitable firmware found!
    [    3.268401] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-21e8.hcd failed with error -2
    [    3.268403] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e8.hcd not found
    

    Regarding the wifi, there was a very same topic this month. So you need to find the missing files and put them in /lib/firmware. Mind the path for the .hcd file



  • @substring I will look for the thread and see if I find it, what I am comfortable with changing myself. Thank you very much! I'm hoping I can get this figured out as I feel a bit lost.


  • Moderator
    Team

    @halathos my answr was mostly for people who are a little familiar with file handlingin Linux. But i can give a more detailled answer



  • @substring I very much appreciate that, I am reasonably versed within linux and have managed to get my way around so far. Any help you can give would be very much appreciated.


  • Moderator
    Team

    @halathos well you look like you have the required knowledge to sort this out by yourself :) Just google for the files, drop them in the right folders (/lib/firmware for the wifi fw, /lib/firmware/brcm for the BT fw, you may need to mkdir the brcm folder).



  • @Substring I've got the files but I've just dropped them on the share for now. trying to get filemanager working to move them to the appropriate folders and the kodi FM doesn't have write access to /lib/. I'm so close but so far away :)



  • @substring well I tried to Chmod the folder but no luck. Any other helpful hints :)



  • SSH and this command
    mount -o remount,rw /



  • @halathos said in PC v18.04.20 Wifi/Bluetooth issue:

    @substring well I tried to Chmod the folder but no luck. Any other helpful hints :)

    figured out how to write using Kodi filemanager (Didn't feel like plugging in a keyboard)

    "mount -o remount, rw /"

    Now to reboot and I will report back with results.



  • lol you beat me to it !!



  • @substring Still no luck on this. Wifi is not populating and Bluetooth cant find anything I have updated my dmesg in the dropbox link but just in case. It seems to have taken the files and used them properly. I feel like I'm missing something. https://www.dropbox.com/s/j10kdm6thvdjgll/dmesg.txt?dl=0



  • Well update on this, WiFi disable and delete stored values from my manual attempt and reboot and re enable got it working. Bluetooth although disabled and re enabled through recalbox.conf with reboot and removal of ../system/bluetooth/.. to make sure no settings were left over.


  • Moderator
    Team

    @halathos so ? Success or not ?



  • @substring no after a few reboots the wifi takes a while to initialize and bluetooth will not find anything. even external has stopped finding anything. updated the demsg just above. i'm going to continue to plug away at it. if you have any ideas it would be great :)


  • Moderator
    Team

    @halathos it dies say the wifi is ok :/
    For bt, can you type hciconfig and give me the output ?



  • @substring no output without the dongle. with the dongle I get
    hci0: Type: BR/EDR Bus: USB
    BD Address: 5C:F3:70:85:88:98 ACL MTU: 1021:8 SCO MTU: 64:1
    DOWN
    RX bytes:6760 acl:0 sco:0 events:820 errors:0
    TX bytes:72686 acl:0 sco:0 commands:818 errors:0

    Still no pairing. (No controllers found)
    FYI these are known working controllers even with this dongle.
    My apologies for the late response. Work life catches up once in a while :)


  • Moderator
    Team

    @halathos not pairing because it's down. Weird, there is a udev rule that should bring hci0 up



Want to support us ?

Join us on :

241
Online

28225
Users

14443
Topics

109283
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.