Pas d'image TV CRT et adaptateur GPIO/peritel



  • Bonjour a tous,

    J'ai acquis le raspberry pi 3 et un adaptateur GPIO/peritel pour revivre sur un viel ecran les sensations d'antan.

    mais je n'arrive pas a voir d'image sur le CRT. En HDMI, pas de problemes, ca fonctionne tres bien.

    J'ai configuré recalbox comme indiqué dans les tuto pour les crt (config.txt) mais toujours rien.

    Y a t il une manip particuliere a faire? je precise, je m'y connais peu en ligne de vommande/linux etc...



  • @sam-feyech il y a beaucoup a faire oui :

    • modifier le /boot/config.txt pour qu'il affiche par DPI
    • modifier recalbox.conf pour lui dire de ne pas switcher en 780p, voire mettre des résolutions particulières


  • bonjour substing, merci pour ta reponse!

    As tu un lien vers un tuto pour realiser la manip?

    Quelle resolution adopter? 480p? il s'agit d'une TV sony trinitron PAL supportant le 60 hz.



  • @sam-feyech non pas vraiment de lien, il existe plein de tutos sur le net pour ca, y compris sur le fofo



  • @substring

    je te suis tres reconaissant pour ton aide, mais apres m'etre cassé la tete dessus, ca marche pas...

    J'ai edité le config.txt en y collant les parametres prevus pour un affichage CRT, en modifiant les permissions a base d'obscures ligne de commande sur un portable linux.

    Mais le /boot/config.txt pour l'affichage en DPI, linux ne veut rien savoir "vous n'avez pas les permissions blabla" meme en usant des lignes de com que j'ai glané sur le net.

    et pis je vois meme pas comment lui indiquer, y'a pas la moindre mention de DPI dans les lignes de com du texte.

    Je suis meme pas sur que le GPIO est actif au branchement du rasp, mon CRT n'a pas le moindre soubresaut de debut de captation d'image.au moins l'icone EXT devrait trembler, ou s'effacer, ou affiche des lignes degueu en travers a la mise sous tension, mais là, que dalle...



  • @sam-feyech Dans le config.txt place çà en début de fichier :

    dtoverlay=vga666
    enable_dpi_lcd=1
    display_default_lcd=1
    dpi_group=1
    dpi_mode=6

    et dans ton recalbox.conf repère la ligne qui commence par global.videomode= et remplace là par global.videomode=CEA 8 HDMI

    Teste et dis-moi si cela change quelquechose à ton problème.



  • @sam-feyech par SSH il te faut avant tout mount -o remount, rw /boot



  • @gkralicek2 ,@Substring

    Merci pour votre aide!

    Bonne nouvelle, il y a un debut de vie sur mon CRT avec le gpio/peritel!

    En effet, l'icone ext montre une activité, et un timide trait blanc defilant dans lequel je crois reconnaitre le menu recalbox s'affiche.

    Mais ca va pas beaucoup plus loin helas. Toujours le meme probleme: je n'arrive pas a editer recalbox.conf, et la commande

    mount -o remount, rw /boot ne donne aucune autorisation d'ecriture ^pour changer le mode CEA.

    Je precise que le cable et la TV fonctionnent tres bien avec d'autres appareils.



  • @sam-feyech non tu mélanges :

    • recalbox.conf est éditable, pas de sushi pour ca. Passe simplement par le manager http://recalbox avec otn pi sur le réseau. Tu peux tenter de mettre auto si tu es en 18.04.20
    • config.txt, lui il faut bien le mount blablabla que je t'ai donné plus haut et qui a fonctionné


  • @Substring

    desolé, je veux pas passer pour un lourd, mais le recalbox.conf est en read only chez moi.... je precise, je mets la SD directement dans un pc linux mint.

    De plus, le rasp n'apparait pas sur le reseau : les lignes network sont vide, et j'ai maintenant un blackscreen en HDMI>< donc non editable via browser ou explorateur reseau autant qu'en y branchant un clavier...

    Pour finir, dans les lignes que m'a indiqué gkralicek, il n'y a pas d'indication de resolution, c'est normal que ca n'y figure pas?

    Je l'aurais mérité MAME sur mon CRT apres tout ca, lol!



  • @sam-feyech si tu mets dans un linux, tu devrais etre capable de voir que le proprio du fichier que tu veux éditer est root ... Pk faire compliqué ? Edite sur recakbox direct (sauf si ton pi n'aura pas de reseau, là ok)



  • @sam-feyech Ben si il y a mention de la resolution dans les lignes que je t'ai données :
    dpi_group=1
    dpi_mode=6
    Mode 6 dans le groupe 1 (CEA), ce qui veut dire réso de 480i (640x480i). Cà c'est dans le fichier config.txt pour l'affichage général incluant emulation station.

    Et dans le fichier recalbox.conf le CEA 8 HDMI signifie 240p (720 x 240p), çà c'est pour les jeux.

    Hmm je te conseille de jeter un oeil sur cette excellente page qui liste tous les modes video avec les résos associées :
    https://www.raspberrypi.org/documentation/configuration/config-txt/video.md



  • @Substring @gkralicek2

    re-bonjour,

    Apres une pause, je l'ai ressorti du placard pour tenter a nouveau de faire quelquechose.

    J'ai reformaté la SD avec recalbox moddé, specifique pour l'affichage crt (RGB-PI41 alpha)

    Du son: mais toujours ZERO image. J'ai verifié avec une autre peritel, elle n'est pas en cause. J'ai eu un embrayon d'image quand par erreur j'avais inversé l'adaptateur, distordue et grise, mais plus de son, ce qui prouve qu'il fait transiter les infos, et que c'est juste un reglage d'affichage...

    J'ai bien pigé que config .txt est pour le lanceur d'emu, mais quelque soit le mode choisi, son sans image.S'il est correctement configuré, je devrais au moins pouvoir voir l'interface, meme mal ajustée...



  • @sam-feyech tu es sur du câble qui transmet la video ? Le mien ce n'est pas le jaune mais le rouge ou le blanc



  • merci substring pour l'aide.

    Non, je n'ai pas de fil rouge: c'est un cable peritel. Voici l'adaptateur que j'ai acheté:

    https://www.ebay.fr/itm/RASPBERRY-USCITA-SCART-RGB-PER-TV-CRT-PI2SCART-GPIO-TO-SCART-RECALBOX-NO-VGA-666/282921803563?hash=item41df741f2b:g:o40AAOSwxg9ZbRjI

    Je vais contacter le vendeur pour avoir plus de precisions.

    Impossible d'en sortir une image, je vais laisser tomber pour l'instant. C'est dommage j'avais acheté une TV juste pour ca :(

    peut etre en recyclant une vielle tour windows j'arriverais a mes fins... merci quand meme!



  • @sam-feyech tu as mis quoi dans ton config.txt ?



  • voila;

    dtoverlay=vga666
    enable_dpi_lcd=1
    display_default_lcd=1
    dpi_group=1
    dpi_mode=6

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    disable_overscan=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    Sound output. Set to 0 or comment for autodetect, 1 for DVI, 2 to force HDMI.

    #hdmi_drive=2

    Using /etc/modules is deprecated and no longer supported on 4.4 kernel

    So manually enable audio

    dtparam=audio=on

    config_hdmi_boost=0

    force hdmi while the tv can take time before sending the signal on the hdmi output

    hdmi_force_hotplug=1

    uncomment for composite PAL

    #sdtv_mode=2

    uncomment for lirc-rpi

    #dtoverlay=lirc-rpi

    if you plug your tv at the same time as your rpi and that the rpi switches from the hdmi or give a low resolution because tv had no enough time to initialize it

    boot_delay=3

    uncomment if you don't want the rainbow at startup

    disable_splash=1

    default CEC name

    cec_osd_name=recalbox

    Overclock

    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=512

    avoid_safe_mode=1

    kernel=zImage



  • bonjour a tous,

    FINALEMENT CA FONCTIONNE.

    Apres des heures de prises de tete, j'ai tout simplement utilisé une autre carte SD 8gb. Pourtant les 2 sont de la meme marque, meme capacité....

    Je vous raconte pas mon soulagement quand j'ai vu l'interface de recalbox!

    MERCI a substring et tous les autres intervenants!!!

    sujet clos :)



Want to support us ?

Join us on :

759
Online

29813
Users

14885
Topics

112123
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.