Strange error in Dosbox


  • Banned

    @voljega
    @lmerckx

    I suppose that this is a new behavior in relation with the virtual keyboard.
    Because if you load dosbox with no dosbox.bat, he execute the foillowing commands before going to Z:

    set ROOT=/recalbox/share/roms/dos/xxxxxxx.pc

    what is totaly right. But after he make

    MOUNT C "/usr/share/dosbox"

    pointing C: not to the game directory, but to the virtual keyboard directory.


  • Themer

    @lmerckx
    @dragu

    also Wacky Wheels now lags horribly, whereas it was working perfectly fine before ....
    didn't try any other game but I suppose it will be the same

    EDIT : yeah same for Tyrian for me...

    do you have the same speed problem @Dragu ?

    bad compilation options maybe @lmerckx ?



  • @Dragu @voljega
    The share problem is perhaps linked to the virtual keyboard modification.

    But for the lag, I don't see the link.
    But I also made a version bump which needed some SDL2 adaptations. Hmmm...

    I will check ...


  • Banned

    @voljega
    @lmerckx
    I can also confirm the speed issue ! Just miles away from before. Some games becomes unplayable. I just tried with No Remorse, even the sound of the videos is interupted or echoed. It is as if you play with lowest framerate. Very strange.


  • Themer

    @Dragu
    @lmerckx

    I'm afraid that most games become unplayable, the ones I've tested are not really demanding


  • Banned

    @voljega
    @lmerckx
    I tried some things, also CtrL+F12. There is no changement and some-times he just jump out of the game with Ctrl Keys. Just nice, in Crusader you see now the bullets flying like in MaxPayne. ;)
    I was yesterday trying to install Oddworld and didn't arrive, so I will switch back to my Christmas SD.


  • Banned

    @voljega
    @lmerckx
    I just swapped OS, it seems to me that the speed issue is existing already from version 180209 ! So seems to be not a fresh issue. If somebody has still this not yet updated system version, he can perhaps confirm.


  • Banned

    @voljega
    @lmerckx
    Also to note, if it can help. I have not all versions but see a notable increase of size between 2017 and 2018 :

    OS 170417 Dosbox size 2977700

    OS 180209 Dosbox size 5048136

    OS 180330 Dosbox size 5111180

    For the moment I copied back the version from 170417 to /usr/bin, and again perfect.


  • Themer

    @dragu nice to know ! well maybe @lmerckx will have an idea (and 14 569 notifications :p )


  • Banned

    @voljega
    Also something new about the MOUNT C "/usr/share/dosbox" story.
    After copy of dosbox 2017 version, this always exist in the actual OS 180330, seems to be a configuration issue.



  • @Dragu @voljega For the moment, not too many notifications ! ;-)
    But sorry for the inconveniences.

    The /usr/share/dosbox usage is clearly new to virtual keyboard. The increase of size is strange indeed: new modifications due to bump and virtual keyboard modification can't explain this size.

    As voljega said before, can be due to a change in compilation directives !?

    I will check tonight. But, on my RPI2, I detected no lag ... what are your platforms ?


  • Banned

    @lmerckx
    Dont work in the nights !
    We have time and also a job to pay for the playing toys. :) Anyway, for the moment, I am fine with older version.
    In my case it is the PI3, but are there differences also in dosbox in PI versions ?
    And dont worry.


  • Themer

    @lmerckx RPI3 for me too


  • Banned

    @lmerckx
    @voljega
    Could this be a possible explication for the volume size increase, that the 2018 build is the 64-bit version and not the 32 ?



  • @Dragu @voljega
    Back home ...

    I've just tested my DosBox RPI2 (updated to 18.03.30) and I confirm: I have no lag problem on games Wolfenstein 3D, Epic Pinball, Ultima 7.
    The size of my dosbox is 5046488.

    Can you send a support archive ?

    Edit: Now, I can reproduce the /usr/share/dosbox bug ! I've never tested without dosbox.bat, in fact.
    I look for a correction.
    Still no idea for lags.



  • @Dragu Mine is still 32 bits.
    Here is the result of the "file dosbox" command, launched from another Linux workstation:
    dosbox: ELF 32-bit LSB executable, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 4.4.0, stripped


  • Themer

    @lmerckx doesn't work in recalbox for me : # file dosbox -sh: file: command not found

    tried Epic Pinball, lags horribly too :s

    @lmerckx do you have a RPI3 ?



  • @voljega Yes, I had to transfered my dosbox exec to another Linux workstation to get "file" command.
    I have a RPI2.

    Do you also launch games with autoexec or with a dosbox.bat script ?



  • @dragu So, I think I have solved the "/usr/share/dosbox" problem:
    When there is no dosbox.bat file in directory, DosBox scan other parameters to find a valid file to execute or directory to mount. When it find the share directory, it stops and go on with it.
    It explains why I had no problem. I always use the dosbox.bat file.

    So, the solution was to put the initialization of the virtual keyboard before the autoexec startup.

    But, I'm curious, how do you configure your autoexec ?
    Do you need to specify the mount and exit in it ?
    Do you have an example ?


  • Themer

    @lmerckx said in Strange error in Dosbox:

    shit I f you don't have a rpi3, it's not gonna be easy to find the issue ...

    Do you also launch games with autoexec or with a dosbox.bat script ?

    I always use a dosbox.bat with all necessary instructions in it (mount for instance but no need for exit), I keep no command at all in dosbox.cfg (I always have one too)
    If you need, I can give you my dosbox.bat and dosbox.cfg for Epic Pinball

    @lmerckx said in Strange error in Dosbox:

    Yes, I had to transfered my dosbox exec to another Linux workstation to get "file" command.

    figured as much, but I don't have any linux at home other than my recalbox ...


Log in to reply
 

Want to support us ?

Join us on :

462
Online

31222
Users

15139
Topics

113877
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.